ARC Pro

Upgrade to ARC Pro

Your robot can be more than a simple automated machine with the power of ARC Pro!

Thumbnail

Debug

How to add the Debug robot skill

  1. Load the most recent release of ARC (Get ARC).
  2. Press the Project tab from the top menu bar in ARC.
  3. Press Add Robot Skill from the button ribbon bar in ARC.
  4. Choose the General category tab.
  5. Press the Debug icon to add the robot skill to your project.

Don't have a robot yet?

Follow the Getting Started Guide to build a robot and use the Debug robot skill.

How to use the Debug robot skill

This skill helps you troubleshoot an issue you might be facing. It's helpful for figuring out what where you might be experiencing an error, what your settings are, or which version you are running.

*Note: The debug window at the bottom of the ARC interface can also be activated from the Options menu.

When this skill is added to ARC, the bottom popup debug will be deactivated and all log text will be routed to this skill.



Main Window



1. Information Display
Displays the date in YYYY-MM-DD format, time in 24Hr HH:MM:SS UTC format (minus your time zone), and information from Windows, ARC, skills, and hardware settings.

2. Copy Button
This button copies the Information display text to the clipboard.

3. Clear Button
This button clears the Information display.

How to use Debug


1) Add the Debug skill´╗┐ to your ARC project (Project -> Add Skill -> General -> Debug).´╗┐

2) Make changes to your skills and settings then read the information in the information display.


ARC Pro

Upgrade to ARC Pro

Harnessing the power of ARC Pro, your robot can be more than just a simple automated machine.