Canada
Asked — Edited

Signature Error On Adroid V4.1.2

Hello,

I try to install the ez buider on my android V4.1.2 and I get a signature error, do someone know what to do ?

Thx a lot


ARC Pro

Upgrade to ARC Pro

Synthiam ARC Pro is a new tool that will help unleash your creativity with programming robots in just seconds!

United Kingdom
#2  

V4.1.2 is compatable so no worries there. I would suggest deleting the version you have on your android at the moment, then reinstalling it. Don't know where you downloaded it from, but try downloading it again from Google play, or directly from EZ-Robot. The link below which has choices for both. :)

synthiam.com/Products/ARC

And here's the link for the Android download tutorial that may help you too incase you havn't read it yet. Hope it helps.

synthiam.com/Tutorials/Lesson/60

Canada
#3  

Thx a lot for quick answers.

Yes it's for install on a mobile with android 4.1.2

I'ven't be able to install it, I've try both way ( Google play and direct from EZ-Robot)

The exact error message is: " the signature of file of package is incorrect" and I've no choice to clik on "OK".... no more information, I can try to reinstall and get the same error.

I've already reinitialize the phone from factory setting and get the same error... tired

Thx agian if you have another idea... :)

#4  

It isn't on Google Play yet. You need to download directly from here.

Signature error was happening on Android versions earlier than 4.2 but DJ re-compiled for anything 4.03 and above (I think that was what he set as the minimum) and re-posted a month or so ago, so it should be working. Signature error is what you get if you don't meet the minimum version requirements.

Alan

Canada
#5  

Ok, it's all my fault, I have androide V 4.1.2 and OS V 3.0.31..

So I can't use it... stress

Thx for your answers and time.

#6  

It should work on v4.1.2. I also searched for the error, and it is not signature error if the version is wrong, but parser error, so what you are experiencing may be something unrelated to the version.

Do you have your Android set to allow install from unknown sources? (settings, security).

Alan

Canada
#8  

Yes I've already set it to accept unknow sources... tired

#9  

Alan, was there a specific version you're talking about? You can get ARC on google play, that's been around for awhile:) It's not on the Apple app store yet though - but will be very soon.

United Kingdom
#10  

Yes it will work on v4.1.2 for sure. Other members have used/are using the same OS version, and slightly older as well (I beleive v4.0.4 worked as well). Something that might be worth a try, and that's installing the latest Android OS your device can use, if your device allows it. :)

#11  

Thanks for the play link. I searched for it before answering and didn't see it.

Search for EZ-Robot doesn't find it. Search for ARC does. Most apps will show up if you search for thw publisher.

Alan

PRO
Belgium
#12  

it also say iff your device is compatible

User-inserted image

United Kingdom
#13  

Taken from Google play...

Quote:

Requires Android 4.0.3 and up

So the version your running is deffo not the issue.

#14  

@traxx, dumb suggestion, but have you restarted your Android decice lately? I hace occasionally seen a signature error on installs or updates if I haven't rebooted in a while.

Alan

Canada
#15  

Hummm, very strange... Yes I've restarted my device many time.

Canada
#16  

It.s seem to be compatible:

User-inserted image

United Kingdom
#17  

The only thing I can think of is that ARC Windows/Mobile was updated earlier today. I don't know the process of the update, but maybe there's a small bug that needs ironing out. Just a thought.

#18  

Can you post the exact error you are getting, and what make/model is your device (you can take a screen capture by simultaneously pressing power and volume down, and then post the picture here if that would be simpler. If doing screen captures, get both the error, and the Settings | About screen - may need to go one level deeper on settings about to get the Android and Software version numbers on the screen depending on make and model).

Alan

PRO
Belgium
#19  

traxx

are you french?

Canada
#20  

Yes, I'm french:) that's why i'm doing some mistakes when I write ;)

Here's screen shot of error:

User-inserted image

And mobile information:

User-inserted image

PRO
Belgium
#21  

can you set your phone to englich? and try again.

Canada
#22  

done, same error but in English :

User-inserted image

PRO
Belgium
#23  

can you see on your phone that you need to synchronize your mail adres , for google maybe?

Canada
#24  

It's already synchronized too... And I just install an other application with no error, it's just ezrobot appli make error.

Canada
#26  

So can we deduce that come from an update ? confused

United Kingdom
#27  

Possibly. Maybe one of the guys from the office might have an idea of what's causing the issue. ;)

PRO
Belgium
#28  

i downloaded google drive and install from there. will let you know if it works in few minites

#29  

I just installed the new version... no problems...

#30  

Quote:

I just installed the new version... no problems...

Worked for me as well. Android 4.4.4 phone and 5.0.2 tablet. I wonder if this is a version thing or a regional thing.

Alan

PRO
Belgium
#31  

rr

no luck whit google drive. any idea what these errors are?

#32  

A couple of discussions of this error on various Android sites suggest clearing the Google Play cache:

Quote:

Clearing the cache for the Google Play Store app seems to fix this problem. Go into Settings >> Apps, select that app, and click "Clear cache".

Won't help if the app really is improperly signed, but if it was then I don't think it would work for any of us.

Alan

United Kingdom
#33  

I just re-installed on v4.4.2 with no problems. So maybe it's a OS version issue then. Ideally we need someone to reinstall the app on v4.1.2 to confirm if it is a version issue or not. I can't think what else it could be.

Canada
#34  

I've seen and try it (clear cache) with no success.

#35  

The other links I found lead to something that DJ will need to fix in how the application was signed or in the java version installed on the machine where it was compiled (although that seems to be an old problem when Java 7 was new).

Alan

PRO
Belgium
#36  

traxx same here signed error

Canada
#37  

Nomad, what'S your version Android and OS ?

Java is great but make so many probems.

PRO
Belgium
#38  

android sony experia 4.04

United Kingdom
#39  

@nomad.

What Android version are you getting the signed error with? Is it v4.1.2?

Canada
#40  

so it happen on differents versions of android...

PRO
Belgium
#41  

mine is to low version.you have to have 4.1 atleast. maybe dj will chime in for you.

#42  

You might want to try Google play again.My phone just told me there was an update, so it might be fixed. (Update installed fine).

Alan

Canada
#43  

No way, same error, have also erase the Google play cache to be sure to get last version. Murphy law hit me ;)

United Kingdom
#44  

@traxx.

Can you update your devices operating system, or have you tried it already?

Canada
#45  

No update avaible, thx for your idea ;)

#46  

I have the same error I just tried to download the soft wear right now must just be the app

PRO
Synthiam
#47  

I've been trying to contact Google support for this issue. It appears android has this issue often - it's broken and hopefully Google will fix it soon.

#48  

I have an android version4.4 and I have the same issues.

PRO
Synthiam
#49  

Rod, we have been fighting with this for months. If anyone has a suggestion or helpful fix it would be extremely appreciated.