Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.

Get Started
Asked — Edited

Is There A Way To Get Previous Versions Of Ez Builder

I have an older computer that has XP, is there a way to get EZ Builder for it? I know EZ Robot does not support XP anymore.

AI Support Bot
Related Content
Synthiam
United Kingdom
#1  
Not unless a member of the community has one.

I have a few old version in my dropbox but I have no idea of which versions they are.

Can't you upgrade the XP to 7? Windows 7 starter should run fine on a PC that can run XP.

You also need to bear in mind that EZ-Script syntax has changed since some older versions as have a lot of the controls that use servo positioning. EZ-Cloud probably wont work and you will have no support since ARC was totally revamped with the Revolution release.
#2  
While most computers that run windows xp can be upgraded to windows 7 not all of them can be. Particularly laptops can be a problem. It is usually drivers that are the problem. For some machines drivers for windows 7 were never done. Sometimes the amount of memory becomes an issue; while windows 7 will run on older hardware it can become slow if it does not have a decent amount of ram. I have a windows vista laptop that doesn't have windows 7 drivers; it will eventually get to be a Linux laptop.
United Kingdom
#3  
You can use xp and vista drivers on 7. You can also get yourself windows 7 starter which requires much less ram and has run smoothly on every PC I've used it on.
#4  
I have from 2013-06-08 to current. Whats the last one that worked for you and I'll find a place on the internet to post it for you.
#5  
Thanks Antron, I have a version working on one of my two computers. But on one of my computers I upgraded to the latest version and there seems to be a problem. I was just wondering if I ever upgraded and there was a problem how would I back up. I guess I should back up working versions before upgrading. Thanks
#6  
I believe there are a couple of people having some issues with the latest version. Mine seems ok so far but I haven't tried connecting my board yet. My projects seem to load. But if you'd like to get an older version of ARC for that 2nd machine feel free to ask. If you do just tell me what one you want. I'm a bit of a digital packrat. I still have CD Roms I've burnt back in the 90's. I just tend to collect data. I'll confess that with the internet being what it is now I'm not as diligent. But I still like to keep some more important things around like good ol EZB.;)

[EDIT]
There is a new new version that seems to be all good now. Be sure to give it a try.:)
United Kingdom
#7  
The issues with ARC have been addressed and a new version released where the issues are no longer present.

To be honest, there is no reason to have backups of the installers since any problems that do come up are usually sorted out within hours.

There are a whole host of problems you may encounter if you do roll back, more so if you use the cloud or need help on controls and scripts. It's always advisable to run the latest version unless you have a very good reason not to.
#8  
Rich is correct. I've been livin' the EZ life for 8 or 9 months and there has only been a couple of issues and they've been solved within a day or so tops. In fairness this one had the installer issue then the halt() issue was discovered. But the EZ gang are on it.

I just archive data as a habit and hobby I guess. It's come in handy. When seiberton.com lost some of their galleries I had a 2 or 3 of them they had lost and was able to help them out. Just in case my friend. Just in case. ;)
#9  
@Rich, The computer I have a Vista and was upgraded to XP, I think I am going to keep it as is and hold on for the V4 board. I will just get a tablet or something then. Thanks