Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.

Get Started
Asked — Edited

Ez B Keeps Crashing Every Time I Give It A Command

is this because the batteries are getting weak?
or is it a software issue ez builder freeze everytime I ask to do something

AI Support Bot
Related Content
Synthiam
United Arab Emr
#1  
Robot Batteries should not affect ARC.
Most probably , issue with the software installation .
You need to provide more details about the setup , version .
New installation or old one?
Any new update before the problem start ?
This will help others to help you out .
#2  
yep it s weird it make all the servo go beserk and brown out occurs. then ARC freezes.
ever since the update on 6/8.
#3  
Fixing the problem will most likely be easier then figuring out why it happened. Try uninstalling ARC and framework. The install framework 4.0 and the latest version of ARC. Then connect with ARC to EZB as board 1 but do NOT load your project and open a digital switch panel and toggle it on and off. Check the pin to see if its turning on and off with a led or volt meter. If its turning on and off then ARC.is working.

Step two- load your project and then test , if your problem starts when loading the project I would suggest rebuilding the project newly.
#4  
this is what happened to me. check your wiring and make sure the battery is correct. i had 2 batteries fully charged and 4 dead ones in the battery pack and this caused a big problem. plus check to make sure your not plugged into the Gnd port in between d13 and d14. after I did this ARC oddly stopped having issues.
#5  
- wait you said brown out - that means power drops off and connection drops. How do you know it was a brown out? Just asking. Low batteries? I was troubleshooting based on the info the ARC just froze but if your board is disconnecting then the first culprit is low power, dead batteries or otherwise insufficient power supply.
United Kingdom
#6  
Sounds like a brownout issue, use a better power source.
#7  
Yup ...the batteries drain fast when using servos and the EZ-Board...I am thinking the trouble was coincidental when the new version was loaded. there are Tons of good threads here on the Forum regarding separate/better power sources.:)
#8  
Yup a new set of batteries and we re good to go again!
#10  
Hello all,
I think I am having the same issue. I have been trying to use the Sure Compass module. With it completely connected to the Ez-B.it works fine for about 20 seconds and the all the lights go out on the Ez-B and the ARC freezes up and so does the Ez-B. I have to CNTL /ALT DEL to get out of the ARC and pull the plug on the Ez-B. start over and the same thing happens. I tried the compass module with an externial power source and had no brownout issue on the Ez-B and no freez up on the Builder. The only problem I had was I thought I had 5v supplying the compass module. I figured out I had more voltage then 5v , when the smoke came out of the compass module. So I have ordered another compass module and will try it agin, with a verified 5v power source.
Netherlands
#11  
@airwave1206
How did you connect the compass?
I've been trying for weeks now to get the thing working and I keep getting the same problems you have.
But if I just have to power it externally, I'll do it the moment I get home.
#12  
@DudeIO
I not saying this is the fix since my compass module smoked. I took apart a usb car charger and attempted to connect power wires to get the regulated 5v. I have not measured the output of that device since it smoked with the compass module. But if you really think about it, if you have a 5v battery your trying to charge, are you going to use 5v? No, you have to have a higher voltage to get the battery to 5v. I am a automotive tech and the cars do the same thing. The car charges the 12v battery with 14.5v in most cases so they can achieve the 12v charge. Any ways, I connected the SCL and the SDA lines to the Ez-B's I2C port. The 5v and ground to the usb car charger. The compass worked flawlessly for around 2 min unti the smoke let loose. I am going to try this again, but this time I am going to verify the 5v and possable connect the ground to the power source and the EZ-B. I don't know if DJ have suggestions about this? So it's up to you, not saying its going to work or what will happen. So use it at you own risk. It costed me my a $10.00 compass module and a usb car charger. I might try a PC power supply. They are really regulated. Good luck and I will keep posting my findings.
Netherlands
#13  
@airwave1206
What I was trying to verify, was that if the EZ-b wasn't able to provide enough power to the compass, it would brown
out, so you should power it externaly, which if I understood you correctly, you did. Only with the wrong power supply.
So my plan was to just use a 5v regulator and power it of my batteries(2s lipo's).
#14  
That's correct most devices need external power , ie not through ezb.
#15  
@jstarne1
do think I need to have the grounds tied together from the power source the I2C compass module and the EZ-B? I was wondering if that had anything to do with the untimely release of magic smoke from the compass and the usb power supply. so now only waiting for the Sure compass module to come from China to retest the theory of external power supply.

@budel0
I have tried everything else. it only sounded logical to try an external power source. it was my mistake for not checking the voltage. I am still not sure about the grounds. I don't think it would hurt to have them all connected.

This is L.O.R.A.
User-inserted image