Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.
Get Started

Asked

How Do I... Not Be Hopelessly Lost?

I'm sorry for ANOTHER stupid question, but I'm having a REEEALLY hard time following the Tutorials and searching for help in the forums here. I've just attached my ultrasonic distance sensor to my EZ-B4, but I can't figure out how to do anything with it. At this point, I just want to have my robot navigate autonomously (which, to the best of my knowledge, should be a fairly simply process) before moving on to more complex tasks, but I've got no idea how to proceed from here.  What do I need to do to figure this out?


Related Hardware EZ-Robot EZ-B v4
#14  
Yes, I'm using the ultrasonic radar control.
User-inserted image


I slowed down the robot's speed, and it encountered the same issues as before. Sometimes it detected objects and avoided them, sometimes it didn't. I tried hitting STOP on the movement control and it just kept on going.
#15  
slow down the speed even more , is your sensor mounted on a rotation servo?
the dots below is what the robot detects.
#16   — Edited
No, the sensor isn't mounted on a rotation servo, and I REALLY hope that it doesn't NEED to be in order to be effective. I didn't get a satisfactory answer to my earlier question of why the rechargeable batteries I bought weren't working, and I just gave up and bought one of the batteries from EZ-Robot's store, making me wonder what the point was in including a holder for 6 AA batteries in the Developer Kit if the EZB was never intended to USE them. Is this another case where this particular component only works if it has ANOTHER component attached to it?

I'm sorry for ranting, but every problem I'm encountering with this is just REALLY frustrating, compounded by how it appears that I'm the only one having these issues.
#17  
rechargble AA batteries are 1.2 volts. non rechargebles are 1.5 volts.
so rechargebles are not so good for using robots .
a servo is 7.4 volt .the batterie case has 6 x 1.2 volt=7.2 volts not enought.

what happens when you slow down the speed even more?
#18  
btw keep ranting and don be a chame for it.and you are not the only one.
learn to be patients .you will live longer.:)
Synthiam
#19  
If you have questions about ezrobot products, they have a learn section with lots of info: http://www.ez-robot.com/Tutorials/

Questions about their products and such can be asked on their website with their Contact Us page. 

we’re not ezrobot. Ezrobot won’t see your messages or product feedback here. 

as for using an ultrasonic distance sensor, there’s some info in the ARC manual in the docs section:)
#21   — Edited
I've upgraded to the latest version of ARC, and the speed of robot has been reduced to half of what I had it at the last time.
User-inserted image


Here are my current ultrasonic settings, and the only values here that I recognize are the EZB ports into which I've plugged the appropriate servos and ultrasonic sensor.
User-inserted image


What's weird is that I didn't even need to hit the FORWARD command on the servo Movement Panel like I was doing before. As soon as I connected the robot, it was moving on its own.  But it wasn't even MOVING on its own, it was... rocking to the left and right very faintly, and backing up slightly. Yes, I see that I have 'Reverse Before Turn' selected, I wanted to give it some room to clear whatever might be blocking its way.  But now it's just looking back and forth slightly, not going anywhere, but backing away, and then it just STOPS before I tell it to stop.  Hitting the Stop button myself doesn't work, and if the radar scan screen devoid of red dots is any indication, it wasn't detecting anything.
User-inserted image

It seriously looked like it was AFRAID of doing anything, and it couldn't even see any reason TO be afraid of doing anything. :/
#22  
can you take ARC from adventurebot to test your robot movements? ( arrow keys )
you can delete the camera window if you dont use a camera.
#23  
I can't connect my EZB to the Adventurebot, and the arrow key commands were already working fine before.
#24  
any ezbv4 can connect to any ez robot just saying.can you upload a chort video?
what kind of wheels are you using?
does your arrow keys work fine now?
#25  
No, I can't connect to the Adventurebot, the arrow keys work fine when I'm not trying to use the ultrasonic, and the original Robie Sr. wheels that I'm using aren't an issue.
#26  
And now my camera's not connecting... Wtf?...

User-inserted image
#27  
hi bobsheaux

do you save your project on your pc?and maybe you can take a new window ultrasonic.
check the cabke from your camera bolt sides.
#28  
Yes, I save my project constantly.

And as near as I can tell, the connection of the cable on both ends of my camera is perfectly fine.
#29  
maybe its possible you have a bad download .you can remove it and redownload it.
also i read some post about the camera cable.solution is to turn the cable 180 degree.
#31  
can you try another camera window?
#32  
Okay, THAT worked, THANK YOU. lol

And I guess I'll poke around what the other tutorials have to say about the ultrasonic sensor.
#33  
EUREKA haha.try a very slow speed.if you put the ultrasonic on a servo,
to turn left/right its more fun.