Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.

Get Started
Asked — Edited
Resolved Resolved by DJ Sures!

Continuous Servo Movement Panel

I have an ezb3 and am using the Continuous servo Movement Panel window with the old 360 motors but it doesn't seem to do anything. I read the manual and it says that it has to be connected to board#0 I have that,I also checked the port numbers and they are good, but still nothing happens. When I use the Continuous servo window they work well but not with the panel. Is there anything that I can do differently? I have the latest EZ builder and the latest ezb3 firmware

User-inserted image

PRO
Belgium
#2  
A.bautista

did you messure that batteries?
its better to use the lipo batt.
#4  
Never mind... you have tried all my suggestions...

Maybe reboot, reinstall and try again?
#5  
Ok, possible issue ( I don't have my ezb3 handy in order to test this)... I believe the servo values when using the ezb3 should be min 1 and max 100.... centre or stop is 50... When using the ezb4 servo values are min 1 and max 180.... centre is 90...

Have you tried setting the servo values to 1 and 100 instead of 1 and 180? Stop value at 50?
United Kingdom
#6  
1. Check the ports are set correctly in the Movement Panel config.
2. Check the forward and reverse values are set correctly in the Movement Panel config.

If that doesn't work a workaround is to use a custom Movement Panel and use script commands to set the servos moving. Simply use the Servo() commands with the relevant port numbers and positions to suit the direction and speed.

i.e. Forward (assuming servos are opposite each other);

Code:


Servo(D0, 180)
Servo(D1, 1)


Reverse (assuming servos are opposite each other);

Code:


Servo(D0, 1)
Servo(D1, 180)



Stop (taking in to account modified servos may differ);

Code:


Servo(D0, 92)
Servo(D1, 89)
#7  
@Rich... He is using an ezb3, so shouldn't the servo values be min=1 and max=100?
United Kingdom
#8  
Probably:) Although the exact values for straight movements will need to be found regardless of V3 or V4.
PRO
Synthiam
#9  
Okay maybe the Movement Panel is not adjusting the values for the v3. I'm on a plane at the moment, but I'll check at my next lay over.
PRO
Synthiam
#10  
I see, you will have to connect to the ez-b v3 before adding the modified movement panel. The software defaults to the ez-b v4 and therefore only initializes the v3 backward compatibility if you establish a connection first.

1) load ARC

2) connect to your ez-b v3

3) add the modified servo movement panel
#11  
I got them working, thanks everyone for your suggestions. rich I tried the code and it worked, although I wanted to use the Movement Panel and tried out what dj suggested and got it working. Thanks again