Asked — Edited

Can'T Install ARC

I tried to upgrade ARC as I have done hundreds of times. This time it told me that I could not install. But, when I tried to install an older version, it tells me that I already have a newer version installed.

? I even tried uninstalling it and re-installing.


Upgrade to ARC Pro

ARC Pro is your gateway to a community of like-minded robot enthusiasts and professionals, all united by a passion for advanced robot programming.


It says "an older version of EZB cannot be removed.



There was a thread about this issue a few days back. Something to do with windows installer issue and how to fix it. Looking for it.


Steve, I have tried everything. I have an appointment that someone is going to hook up and work with me on Sunday.

Thanks for the info.

United Kingdom

No problem. I saw that Alan is going to help you. Good luck.


I removed your other thread. Please keep your threads limited one per topic.


@MovieMaker, One thing you might try is to "Search" for 'EZ' from the search window at the bottom of the Start window. You may find that you have multiple ARC folders. The referenced program_install_and_uninstall might quit after it finds one ARC folder and not find multiple folders. Just a suggestion.


Thank You, oldBotBuilder. I tried that program about ten times so far with no results. But, thanks for mentioning it.

  1. close ARC if it is running

  2. Load the registry editor by pressing Windows Key -> R and type REGEDIT and press enter

  3. Navigate the register tree to this folder HKEY_LOCAL_MACHINE\HKEY_CLASSES_ROOT\INSTALLER

  4. Now press CTRL-F to display the find window. Enter ARC.

The GUID for the uninstall information of ARC will be displayed and highlighted in the tree. Delete the tree item.

  1. Reboot your computer

Thank you, my friend for going to all this trouble.

I have seen many who have had the same problem. I tried their solutions without results that worked.

I did exactly that you suggested and after I rebooted and tried to install it told me an older version cannot be removed. sorry :-(

I look forward to your next release.


I installed Windows Installer 5 latest version for windows 7. rebooted my machine and then tried to install the program.

Still Failed.

PleasePleasePlease come out with a new release. Thanks.


For this afternoon's working session, go ahead and get TeamViewer re-installed. You don't need to set it to start on boot-up, so it will only run when you need to let me in and start it so won't slow down the computer.

Talk to you later.



I will do this. I am back home now, so you can call when you wish.




Have you deleted the ez-robot folder in c:\Program Files (86) ?

Something is incorrect with your windows installation. Every suggestion should have allowed ARC to be installed over your old copy. Hopefully Alan will get you rock'n:)


We found it. There was a registry entry in the hklm\classes\software\installer\product path that didn't say anything about ARC, but the error log when the install failed said it was missing a parameter. I deleted the whole key and the install went fine after that.



@Alan... Hey it's not his fault then...:) How about his problem getting his ezb4 connected to his network.... To my knowledge he still hasn't been able to use a V4 in client mode....


No, he has EZ-B's on the network, no issue there anymore. Only outstanding problem currently is that his Acer W3 can't see a USB web cam (Microsoft Lifecam). he has the right adapter cable and can see other USB devices, and the camera works on another PC, just not the Acer. I am not sure what the issues is, but I can't find my Logitech USB camera to see if there is a general problem with the W3 and USB cams or if it is environment/equipment specific.



@Alan, I also have a W3 and a lifecam.... I will give it a try... Stay tuned


@Alan... Just checked... My MS Lifecam does work with my acer w3.... I am using a single micro USB to USB adapter, however.... It actually works quite well...


Richard R, I have had the ezb4 and ezb3 at one time. I got all of that figured out. I will use your suggestions to improve my knowledge of the thing. You have proven that it works on the "W3 with windows 10. Alan has also helped. He is an absolute Genius! and a nice man. I will keep being tuned to this location and will make comments on the camera as I have the information.

God Bless You both!