Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.

Get Started
Indonesia
Asked — Edited

Why My Camera Always Disable

I recently received EZ-B , a gift from EZ-Robot Community thanks for it.

when i try for first time, I have a problem with my ez-robot camera whenever I press start to view camera always disable camera message appears, but for control the servo is fine and working except the camera. If Using my laptop cam is working. i try to check the wire and Pin connection all is fine (im use Multy tester for check that) , the blue led camera is blinking when Ez-B is turn on but when i press start to view cam, camera disable message appears. i no have ide for this proble, can somebody help me. Thankyou


User-inserted image

AI Support Bot
Related Content
Synthiam
Based on your post activity, we found some content that may be interesting to you. Explore these other tutorials and community conversations.
#20  
@EricEZ- don't worry! I will take care of you. ;)

I do try and respond as quickly as possible, but sometimes there may be an hour or two between responses during the day! :D
Indonesia
#21  
@Aislinn, Oke no Problem ,:)

im sorry I had to add one job on your *tired*
#22  
I'm having exactly the same issue with the exception and same stack trace EricEZ reported. The camera used to work fine and now it doesn't.

@Aislinn, whenever this issue gets resolved, could you possibly post the resolution here so I (and anyone else who runs into it) can also know what the root cause was and how to overcome it? I would greatly appreciate that.
#23  
@chas9000c Are you trying to connect to AP mode?
#24  
No, I'm connecting using client mode.

FWIW, the connection to the EZBv4 seems to work fine, as I'm able to control servos. Just the camera no longer seems to connect where previously it did. (Of course, I've done all the usual stuff--checking the cable is firmly plugged in, rebooting the controller, etc.)
#25  
What is the ip address in the camera control. If it is 192.168.1.1 and you are in client mode, you will probably get errors. Check to make sure it is using the same ip as you ARC shows in your connection window.

If your in ap mode, 192.168.1.1 will probably work.
#26  
I'm using the same IP for both camera and controller, which is 192.168.1.23 (using port 23 when connecting to controller, of course).
#27  
Okay, I just thought I would mention it because I use my robots in ap mode sometimes and client mode others. I sometimes forget to change the ip in the camera control in ARC and think it may have gone bad but it's because of the ip not being set right when switching wifi modes. Hope you get it fixed.
Indonesia
#28  
User-inserted image


wall e. got a surprise at a time when he was having a bad time... *blush*

Thankyou @Aislinn and All...

next the wall.e upgrade process is continued
Indonesia
#29  
User-inserted image


the new camera working so good now...:) Thanks
#30  
@Aislinn, is the resolution for this to get a new camera?
#31  
@chas9000c Is the LED on your camera functioning?
#32  
@Aislinn, I don't think it's functioning. Would I see it lighting up where the camera lens is? If so, then no, it's not functioning.

Also, previously when the camera was working, I could hear it whenever it was feeding video to the controller. Now it no longer makes any sound when it should be streaming frames (but isn't).
#33  
@chas9000c to clarify, there is no solid blue led you can faintly see through the white plastic shell?
#34  
@Aislinn, correct. No blue LED visible.
#35  
@chas9000c Ok, one last thing you can try if you're up for it... Carefully and I mean carefully remove the white shell.... As mentioned, be very careful sliding the camera out of the lens (upper) portion of the shell. It is very easy to dislodge the black portion of the lens from the camera board. Once you get it out try unplugging the while jst cable and plugging in back in again. If that doesn't work try separating the 2 camera boards (they come apart very easily) and again remount them... Test the camera again. If it comes back to life again be very careful putting it back into the shell....

Other than that you will probably need a new camera....
#36  
@Aislinn, thanks for the info. I tried what you suggested. (Thanks for the warnings about the camera lens.) Still no luck unfortunately, so looks like I'm out a camera. Thanks again.
#37  
@chas9000c,

I don't know how long you have had the camera or how long EZ-Robot's warranties them for, but you should file a warranty request on the Contact Us page.

They have been very good about replacing failed parts so far.

Alan
#38  
@chas9000c It sounds like you have a defective item. Submit your claim through the Contact Us page as @thetechguru suggested please!
#39  
@thetechguru & @Aislinn, thanks for your help. Done.