Welcome to Synthiam!

Program robots using technologies created by industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation, and artificial intelligence easy.

Get Started
Asked — Edited
Resolved Resolved by JustinRatliff!

Trouble With Sound Servo

Hello,

Back after some absence. I'm having trouble with my EZBv4 and getting sound servo to work with the latest version on EZB Builder. Sound servo (PC) crashes the EZB software. with an exception error. I tried on two different laptops and got same error message and crash. If I choose the sound servo (EZB) I get an error message at the bottom of the screen that says sound object is being used elsewhere.I've rebooted the machine thinking that something else was using it. Same thing.

I'm trying to talk live into the microphone and have a servo controlled by my voice. At this point Id be happy to get an mp3 or wav to work with sound servo. Any suggestions?

AI Support Bot
Related Content
Synthiam
#1  
Are you using the Movement Panel also? If so, make sure that the servo you are using for your sound servo isn't specified in there. Also, make sure that you don't have any servos added without specifying which port they are on.

I will dig up a thread from a few days back for you.
#3  
I do have to say that DJ thought it was the computer which is entirely possible and it could be the sound card having the issue. It could also have to do with the software and an update. I don't know for sure if this fixed b.houstons situation or not, but just wanted to share.

I hope it helps.
PRO
USA
#4  
Thanks I will give it a look thru!
PRO
USA
#5  
...hmmm nope. I had the same computer with EZBv3 connected up several months ago and had no problem running wav files and getting the response i was looking for. I no longer have that ability. The hardware has not changed in this computer, I have one servo connected up to sound servo EZB (because it the only one that will not crash the software.), and nothing else open oin a clean new project. I keep getting the error that its in use elsewhere. Any other ideas, how to get it to just work with one wav file and get the servo to move with just the one .wav file.

This pains me when something changes that worked before.
#7  
You could try to upload it, let me open it and see if I get the same error if you want.
PRO
USA
#8  
I've managed to get get it to work with Soundboard and a prerecorded .wav file on the EZB but not the PC. I've also managed to record my voice with EZB microphone and again was able to use that, again using the EZB Soundboard. I want to be able to control the servo live with a microphone or have the ability to use speech synthesis, Pandorabot, etc to make it move. Any ideas on that?
#9  
Sorry, I actually have never used this control. Someone else is going to have to chime in on it. I am interested in this but have no experience at it.
#10  
I get the same error now with version 9.16.14. Never did before. Infact my Bender robot project won't load now. This is for the Sound servo PC:


User-inserted image
#11  
Errors are gone with the newests new version of 9.19.14. DJ's the man! I'd download that version and give it a test again. Did Sound servo (pc) work for you prior to the Sept. updates?

This is how I setup my and it works well a pc MIC. You should see the level change as you speak as well as see the servo move. Keep in mind, you can also select n/a for the port if you want to test to make sure your mic is working. It will still change the volume level as well as the variable value.

Also my update speed is set to 500, I wanted mine slower. For a mouth you may want the fastest setting at 100.
User-inserted image
#12  
I read somewhere that the commands or not the same for the PC and the EZB. Maybe the script doc will tell. There is a command to place the sound out of the PC and another to place the sound out of the EZB. They are not the same commands.
PRO
USA
#13  
Thanks All got it working with the update from DJ
PRO
USA
#14  
Is there a trick to getting speech synth to work with sound servo. Seems to want to only listen to my mic on my computer.
#15  
Sound servo PC will only work with your PC mic. If you don't want to use your mic and you have an EZbv4 you can use Sound servo (ezb) and it won't use the mic output it will use the sound output.

One works only with the mic.
The other works only with v4 and uses the sound output (not the mic).