Welcome to Synthiam!

Program robots using technologies created by industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation, and artificial intelligence easy.

Get Started
Asked — Edited

Thought My Question Was Gone. But It Is Back.

I mean I thought my PROBLEM was gone. . . .

Executing...
Cannot compile assembly. 2 Errors:
Line: 0 - Metadata file 'EZ_B.DLL' could not be found
Line: 0 - Metadata file 'EZ-Builder.exe' could not be found
Done
Error: Cannot compile assembly. 2 Errors:
Line: 0 - Metadata file 'EZ_B.DLL' could not be found
Line: 0 - Metadata file 'EZ-Builder.exe' could not be found

I don't understand it. I placed my RSS stuff at the end of my program. After I go through all of the talking , I ask what time it is? what day of week?What is today's date? what is the crime report? what is the news? what is the weather?

Sometimes i get through the program and most times I don't. It gives me this medadata EZ_B.dll could not be found as well as EZ-Builder. Sort of like it is loosing the path. Strange!

I can start fresh AFTER the program and it will give me this error. But, if I start it up in the morning fresh, I can run the examples and they all work. After I run the program, they don't work anymore. It all started TWO releases ago. It worked FINE before those to releases.

I am stumped! Sorry :-(

Mel

AI Support Bot
Related Content
Synthiam
Canada
#1  
Have you scanned your system for viruses lately?
PRO
Synthiam
#2  
Yeah sounds like something is wrong with your system. We have thousands of users without that issue.:) sometimes you might need to reboot. Windows is important to reboot daily I find.
#3  
You may be right. It does sound a little strange. I have so much installed on my system, I can't have anything wrong with it. It would be too much trouble to redo. It is a win7 16g 2T 7core unit.

Thanks for the observation. But, if one of you could simply run my program and test it on your system, I would be much abliged.

Thanks,

Mel
#4  
Arch nemesis ...Wheaton! ! ! ! , oh wait....... Windows!!! Yea windows gradually caches up errors and visually continues to run but the more time that goes by without a reboot the greater the risk. Try Avg some swear by it if you don't want to give a antivirus company your hard earned money.
PRO
Synthiam
#5  
I don't use any anti virus... But then again I only have like 4 programs installed. I find windows works best without any "helping utilities" that claim to make it better:) I also reboot every day.

The apps I have installed are pretty basic:
Visual studio
Melabs programmer
Picc compiler
Altuim pcb designer
Ms office
Adobe photoshop
Adobe premiere
Tight vnc
Saleae llc logic analyzer
And for watching movies I have shark007 codec pack

Lol pretty basic install!:)

Dunno what else you'd need when u build robotssssssssssssssssss
#6  
Not to jump on a soapbox, but I find required daily reboots to be a sign of unstable hardware or overheating.
My desktop (which is 5yrs old) regularly runs 2-4 weeks straight between reboots & I hammer on it daily (as I type, the taskbar has 41 items on it), & it's running XP Pro! Half the time I only reboot cause of a software install or update. The secret is build it yourself with parts you've well researched as good/stable parts (system OEMs just don't care if there machines are that stable), insure it has great air flow to the right spots (modding the case if needed, I added a top exhaust fan port & fans in the side door blowing fresh air directly at the CPU & vid card, in addition to its factory front intake & rear + PSU exhausts, all 120mm fans with filters on the 3 intakes) then torture test the heck out of it with Prime 95 while watching the temperatures & voltages (I run this for 24hrs minimum). On this build, the video card later failed & some of the PSU voltages were eventually discovered to be off nominal and were replaced with better parts.

ASUS M2N-SLI Deluxe (original)
AMD Athlon 64 X2 6000+ Windsor 3.0GHz (original)
G.SKILL 4GB (2 x 2GB) 240-Pin DDR2 SDRAM DDR2 800 (upgraded from original 2GB (2 x 1GB) few months ago)
Sapphire Radeon HD4550 512 MB DDR3 Vid card (2 yrs old)
CORSAIR Enthusiast Series CMPSU-650TX 650W (3rys old)
2 x Samsung Spinpoint F3 HD502HJ 500GB 7200 RPM SATA (3yrs old, 2 WD 500GB drives in a row failed b4 this)
#7  
Well, guys, Thanks for suggesting the virus scan. I had 12 Infections and it took the scanner 6 hours to find them. They are all gone now. But, my program is still doing the same thing. My computer is realatively brand new and has never had these type of problems before.

Mel
Canada
#8  
Hello I was having the same problem with my copy of ARC the way i fixed it was i put i copy of all the ARC files in to my ARC folder under my documents in where ARC saves the your projects as it seems to look for the program files in the same folder that the project file you are running is in if that makes any sents