Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.

Get Started
Asked — Edited

So Weird : Ezb V4 Ultra Slow / Even On Ap Mode / And Some Really Weird Stuff : I

Just tried to upgrade one of my robots with EZB V4 hopping to get something much faster and also to overcome some serious issues and limitations due to EZB V3 losing Digital ports one after the other.

1) This expensive piece of hardware does something totally unbelievable : it CHANGES MY NETWORK'S GATEWAY to its own client's address... How is it even POSSIBLE ? *confused*

2) Both the EZBs' I got are EXTREMELY SLOW. If I don't disable most of the sensors connected to it, and this EVEN in AP MODE, digital ports will simply take up to 30 seconds to respond. In AP mode N mode it is a little bit faster, but still at a pace that makes running any script useless. I also varied the milisecs for all of them, even at 2 seconds delays I have some little improvement only and no one can seriously hope to use a 2 seconds delay on an IR sensor, right?

I tried from different routers, without routers (AP modes) and the only thing that will make it work properly is turning off almost all sensors (2 ulstrasounds, 3 IRs', 2 currents meters and a lux sensor).

Has anyone met the same 2 problems ? I will try to change the power source, especially the power regulator that I use and see if it does something in terms of transfer rate. For the first SO WEIRD problem, here, I'm stuck... no idea what could do that the EZB takes over the router's address on my network forcing me to set all my computers on fixed ip addesses... . It should not be possible at all.

Thanks for your help,
Elf├Ęge.

#13  
Damn ! I don't need to have all the ARC monitors to run to use the command get(adc) ? Is that right? That would indeed solve the prob!
United Kingdom
#14  
Not really, no. For example, I only really use the actual ADC control monitors to get values when setting up scripts for sensors. After that, I delete the ADC controls.
#15  
@Dj you asked earlier in this thread to communicate the router model(s) I'm unsing, regarding the DHCP bug of EZBV4.

The router which has DHCP server on my network used to be a Linksys E8350 (not really the kind of "cheap router" or "old router" that you and Alan referred to in your posts.

Now I have a brand new Netgear Nighthawk X6 R8000 and STILL THE SAME problem.

Lately, after creating a robotics class, I wanted to order 10 units of EZBV4 but I was asked not to by my School's IT director due to the fact that this issue ALSO HAPPENS ON OUR NETWORKS at school.

EZB is a great product but on that one your manufacturer messed up pretty well. It is not acceptable that such a device takes over our routers the way it does.

Here are the facts :

IF and ONLY IF my DHCP server is on the same subnet and same IP address base (192.168.1.x) THEN no problem. BUT AS SOON AS it is logged on a wifi network that uses a different subnet and/or simply a different address (like 192.168.5.x at work or 192.168.10.x at home) EZB ASSUMES that there's no DHCP server on the network.

Please, try using it on a different subnet, you'll see, the bug is systematic. This is annoying, not counting my wife yelling when she can't get Internet access on her macbook (@Alan knows that I know how to resolve that issue, it's simpler than this dhcp server issue...:):) )

Sorry for the lashing out here... but I've been trying everything for days until I found out today that this is purely due to subnet or address format difference and therefore that there's nothing I can do. I can change my infrastructure at home, but not at work... it's simply and purelly going to be a loss for you. And we are in the center of Manhattan, and a famous school and a lot of people are looking at what we do. You want me to continue using your hardware... really. Sorry to use this stick and carrot here, but this is truly unbelievable that there's still no fix for this.

Thank you for your understanding.
#17  
Thank you. I was waiting all this time for this promised tutorial (previously mentioned in this discussion). Didn't know it was out already. Since it uses a hex file it should be doable from arduino. If I figure it out I can post about it. Thanks again and again sorry for the frustration... currently my smartthings is crashed again because of bad dns. which means that it impacts my entire house... lights, heaters, all sorts of smart outlets and power meters.
PRO
Synthiam
#18  
There is no dns server on the ezb.

The dhcp on the current v4 has an issue with some hardware. The upgraded firmware from the tutorial will fix that: http://synthiam.com/Products/ARC
#19  
And of course new ones are shipping with the new firmware and don't have the issue so ordering new ones for the school is not an issue.

Alan
#20  

Code:


I wanted to order 10 units of EZBV4
We are in the center of Manhattan, and a famous school
I have a sufficient budget


EDIT: I just deleted what I wrote. I struggle with people who do business like this. The American educational system and a lot of the pompous people who work in it are an embarrassment to the American taxpayer. *blush*
#21  
You're right Dave, that sucked a lot... but be sure that this does not represent the American educational system... I can't give details online but if you look into my fb profile you should find out that this ill frustrated talking was not representative of any US institution.
#22  
@Alan

Since when the new ones don't have this issue any longer ? Because I received two more not so long ago, like a month or two ago and they still have that issue.

@DJ thanks for you kind answer and again, sorry for expressing my frustration this way.
#23  
@elfege, Sorry if I came across harsh. Sometimes we say things when we get upset and frustrated. I understand and I'm guilty of the same things many times over. Probably even in this thread. I guess we'er all just human no matter what our ideology is. *blush*

Happy robot building and hope you get your issue resolved. :)
#24  
Did you get them direct from EZ, or a reseller who might have had old stock. I think they have been shipping with the new firmware for at least 6 months. The AdventureBot I got in November had the new firmware.

The PIK tool is cheap and the flashing is pretty simple. You can also give them recognizable default SSID's which is useful. Just be sure to give each a unique MAC address and don't just flash the default firmware from the download.

Alan
PRO
Belgium
#25  
hi all

i just wanted to say ,you are all great and annest people.
and this forum can take the abuse we do sometimes.
one thing i now for sure.i trust people who gets verbal sometimes.
and show there frustrations.ive seen amazing stuff here on forum.
talking about helping people aldo it looks like waisting your time.
when am here on the forum,it feels like comming home.
#26  
@Alan,

Have you eventually made this tuto to connect multiple EZBs together? I tried to make one client to a second one without success.

Thanks.
#27  
I didn't yet. Work got super busy and I hardly have any free time that I want to spend in front of a computer.

All of my EZ-B'S have now been flashed with the latest WiFi firmware, so even if it works for me it is no guarantee it will work on the old firmware, although really the bug you were seeing was the second EZ-B being a client of the first instead of a client of your router. If just using 2 EZ-B, that should work putting one in ap mode and the other as a client to the first. Adding a 3rd in client mode without flashing the WiFi chip could see the same issue.

Alan.
#28  
I have been off these projects for a while so please excuse. Basically what is said here is that we must upgrade the firmware by buying the kit, not directly like V3. I tried on network and access point and both there is too much lag time. Different PC also. No good on the speed.
PRO
Synthiam
#29  
Depends what version of the ez-b v4 you have.
#30  
Tried using interface says unable I guess this early version. I am really have a lag between pc and V4. Run same program on V3 works great. same equipment. Could the problem be the Hbridge?
PRO
Synthiam
#31  
1) The problem is generally 99% user code - meaning, what are you doing with it? Share the project for someone to take a look at

2) Also, how are connecting to the wifi? Is it direct adhoc or client mode through router

3) lastly, you can check what version of wifi you have. There's a the robot program episode that shows or you can READ the ez-b v4 upgrade page here: http://www.ez-robot.com/Shop/AccessoriesDetails.aspx?prevCat=101&productNumber=51
#32  
My code is up on your site called Vetrobot. Tries connecting both modes. Using Win 10 on 2 different machines. latest version of your software. Lag time is between 2- 10 seconds. My laptop which runs nothing else and was ok with V3. I do not believe it is the code. Tried with and without script also. Tried with and without joystick either.