Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.

Get Started
United Kingdom
Asked — Edited
Resolved Resolved by Dunning-Kruger!

Servos Moving Forward

Hi Guys and and Girls,

i have got K9 responding to voice commands, including some responses from him verbally. so things are going great apart from...

when i ask him to move forward his servos respond, but only for a second (or less) and then stops, yet if i ask him to reverse his servo's keep going until i ask him to stop.

originally i thought it was due to the IR sensor interfering, so i disconnected this and repeated to test, with the same results.

any ideas?

*confused*

AI Support Bot
Related Content
Synthiam
#3  
@mgodsell1973 Are you using the servo movement control panel or scripts to control your robot movement?
#4  
Can you upload your forward movement script? And you said you disabled any radar control (Ping and or IR)?
United Kingdom
#5  
HI @Richard R,

i am using the movement panel, with a script to control the speed. (both set to speed 3)

i did have a voice recognition script to play a sound bite to acknowledge the command, but in the interest of fault finding i have removed that and reverted to the two codes above when i ask KP to move forward and reverse
#6  
in the movement panel, are both set to repeat? It is a check box at the top of the list of actions.
United Kingdom
#7  
hi @d.cochran,

i may not be looking correctly, as i cannot see a check box with this option.

can you screen shot it for me? *blush*
#8  
im on my cell phone right now.

Under Actions in the Auto Position Movement panel, there is a check box on the upper right side that says something like "This action repeats". See if it is checked for both the forward and reverse actions.

This is where you set your frames up to be an action.
#9  
He is not using the Auto Position control by the looks of it D.cochan. He said he's using the servo movement panel.

mgodsell, can you upload your project? It will help us because it appears to be a coding issue.
#11  
@d.cochran.... He is using the modified servo Movement Panel which would not have the options (auto repeat) you stated....

@mgodsell1973 You are using the modified servo movement panel, right? Are you getting any error messages like variable not defined or?
#12  
@mgodsell1973 If you upload your project it would be much quicker in solving your problem....
United Kingdom
#13  
Oh thanks found it, i was originally using a modified servo movement panel, i have now moved to the Auto Position Movement Panel - not used this one before.

so i have now added to modified servo panels, and set them up, so that if i click on the arrows, the servo's move.

i have tried to "ask" K9 to move forward ad ARC recognizes the command and then promptly stops it

:(
#14  
we would have to see your project at this point.

you could create a new project and just add the pieces that make the K9 move forward to identify if something else in the project is trying to control the servos or is stopping the movement due to something like a ping sensor stopping movement. It could be something as simple as some other control being setup to the same digital port as the motors.
#15  
lets see you code dude... You need to use the Modified servo Movement Panel for your particular project.... What's in your move forward command script...?

@d.cochran... That's a good idea....
United Kingdom
#16  
If the "move forward" command runs just Forward() then something else must be stopping the movement such as an IR script or Ping control.

Upload your project file and we will take a peek to see what's going on:)
United Kingdom
#17  
Hi all,

Have just shut down the laptop, family time and all.

Will post the project tomorrow, thanks for the intrest and concern :-)
United Kingdom
#18  
HI all,

i finally got my laptop of the kids (homework to do, so can't be mad), i have now uploaded the "K9" file to the cloud, now i have noticed that before i connected my EZ B to Builder, all seemed to be OK (after removing the "auto position servo control" and going back to the "modified servo panel", yet after connecting the EZ B to my network and trying again the same issue occurred.

any ideas?

thanks in advance for your/any assistance

*stress*
#20  
Have you actually paused the sharp collision control or just unplugged the IR sensor? If you just unplug the sensor but not pause the control the robot won't move forward...

***EDIT*** Just tried your project on 2 modified servos.... It works perfectly if you pause the Sharp Collision control...

Is there a reason you are using the sharp radar control and the sharp collision control in the same project? They both control the Movement Panel so it's probably a good idea to use one or the other, but not both...
United Kingdom
#21  
Hi @Richard R,

I had the senor disconnected for the last trail. I used both of the ir control panels as a "sense" check, but will trial later with your suggestions and advise back.
United Kingdom
#22  
Thanks @Richard R.

had a play and swapped the IR sensor over to a ping sensor and the forward movement is now operational.

this has allowed me to understand why K9 is not moving in a straight line, it's due to the weight shift on the front swivel castor. when moving forward the caster has to go 180 degrees before it reaches its driving position, causing K9 to "veer" of track. this is evident as when he reverses, he does so in a straight line as the weight and power are coming from the rear. so a double thanks:)