Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.

Get Started
Asked — Edited

Servo Motors

I need some help on repairing a servo motor. I was programming JD to walk, it was working fine at first, but all of the sudden it jumped like crazy and I did not notice the loose servo motor until I turned it off and picked up JD then the leg just went down.
I opened up the servo to see if there were any loose gears, but I can't seem to find anything wrong. Is there anything that I could do? other than buying another servo motor?

and if possible would somebody please take a look at my script. if there is anything wrong with it I would like to know so I can avoid it on the future.

:walk
servospeed(d16, 10)
servospeed(d17, 10)
servospeed(d12, 10)
servospeed(d13, 10)
servo(d18, 83)
servo(d16, 130)
servo(d17, 45)
servo(d14, 95)
servo(d12, 90)
servo(d13, 90)
sleep(500)
servo(d16, 90)
servo(d17, 90)
servo(d12, 45)
servo(d13, 130)
sleep(500)
goto(walk)




Thank You

AI Support Bot
Related Content
Synthiam
Based on your post activity, we found some content that may be interesting to you. Explore these other tutorials and community conversations.
United Kingdom
#1  
Why not use the Auto Position control to make the frames and put them together as an action? It's much quicker and easier (and I believe the example JD project has walking already in it).
#2  
Most servos won't hold there position once released or if power is removed.... Yes, they do still resist movement (especially large or heavy duty servos), but falling "limp" in itself may not mean the servo is toast....


Test it separately... write a script that has the affected servo sweep it's full range a few times and see how that goes....
If it indeed stripped, I am sure ez robot will mail you out a new one... so I wouldn't worry about it...
#3  
Hello Rich, I was using the Auto Position and it worked like a charm, I also opened DJ's example and made JD do the YMCA dance, but the thing is that I want to start getting used to programming and I tried the program above.
United Kingdom
#4  
There really is no need to do complex scripts for movement when we have the Auto Position control. If you need to use movements as part of a script you can use ControlCommand() to start the action, jump to frame etc. etc. etc.
PRO
Synthiam
#5  
I would avoid using scripts combined with Auto Position - because this will cause a conflict between the servos being used by two controls. Normally it's okay if you're combining a camera and auto position, etc... because they are aware of each other. If you're using scripts then you will need to be cautious of how the servos work.

In your script you specify "servospeed()" before the "servo()" command.

The ServoSpeed() command states that you _must_ specify the Servo() first. You are unable to initialize the speed without initializing the servo first.

You can't hit the gas pedal in your car unless you start it.

Please read the manual for the commands as you use them. If you find a command in the manual, please read how to use it. It's not a lot of work to read because the descriptions are quite short:)
#6  
RIchard R I did your suggestion and this is what happens

#7  
the only script that I had running was only the EZ-Script, but I see where I made my mistake I must of read the instructions backwards cuz I thought you specify the speed first then the position.
PRO
Belgium
#9  
rich do you mean this whit the walk allreddy in?


User-inserted image
PRO
Belgium
#11  
hi bautista

did you find some new thinks whit your jd?
#12  
No, not really just played around with the joints a bit
#13  
@A.Bautista.... Ok, that servo doesn't sound or move right at all, there is definitely something wrong with it... Try your script on another servo to be certain ... However, in the mean time contact EZ Robot using Contact Us and explain what is going on... They will no doubt replace it for you.... Don't forget to quote this thread so they have an idea (see the video themselves) of what is going on...
#14  
Richard R the other leg works just fine. Its like something is wrong with the gears inside as if the motor kept on spinning instead of stopping or resisting movement on the bad one. And will this be consider manufacturer’s defects, if not I could get some lever servo motors with my store credit
#15  
Yeah, I think that servo may have had it. I've seen this happen a time or two when Im
flying my RC airplanes. I then replace the servo and all is good.
PRO
Synthiam
#16  
The servos have metal gears inside, and we have never seen that happen - although I can imagine a gear stripping if it's under too much load or aggressively handled.

Since your robot is brand new, I would assume that to be a manufacturer defect. Contact Us and quote the link to this conversation topic. Aislinn will take care of you:)