Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.

Get Started
Asked — Edited
Resolved Resolved by Dunning-Kruger!

Servo Does Not Move

On ezb 3 i set added one servo to d3 port.I then set min and max values and can move the vertical servo with up/down with mouse.I click save and then i get no response from servo with up/down arrows using mouse.I click on it and is green but doesw not move servo ?

AI Support Bot
Related Content
Synthiam
PRO
USA
#1  
rb550f,
Did you try it on another port?
I purchased a used v3 and found one dead port.
Does that servo work on other EZBv3 boards?
Steve S
#2  
I tried a different port.I can move the servo from the config panel with min/max values and save it..But when I click on box from servo panel it does not move and the values do not change with moving arrow up/down..
United Kingdom
#3  
Does the servo physically move when you set the limits in the config?
PRO
Canada
#4  
Hi @rb550f

Have you by chance made the Max value small (1) and the min value large (180)? I've seen some issues when I've done this in the past.
#5  
As Jeremie is saying... for V3 min and max values for servos should be 1 (min) and 100 (max).... 1 - 180 values are for servos on the V4 board...
#6  
I have a value of 65 to 91 for the servo in config.And yes the servo physically moves in config panel.
United Kingdom
#7  
Are you using the control correctly?

Click and hold the mouse (or hold your finger) while dragging it back and forth as these videos.







Does the box change to green when you click and hold?
Do the numbers increase/decrease as required?
#8  
This is a weird one. Maybe delete the control and reset it up?
#9  
...or re-download ARC, re -nstall it and reboot your PC.... Then try again...
#10  
The box changes to green but the numbers do not change up/down.And yes i do know how to use controls..Works on my other robots.
#11  
I tried a different servo on a different port and i still have the same problem...
United Kingdom
#12  
Can you post your project? From what you have said it should all work but if you post your project we can take a look to make sure there isn't something wrong in any of the set up/config
#13  
It sounds like you got the servo values backwards to me.

Make sure its NOT like this:

User-inserted image


In this photo, the values need to be switched. if they aren't, they with lock up the control. When your setting the values, the servo is working based on the position in the value box, letting it move. When you try to use the control, the values being backwards prevent the servo from moving.
#14  
I was able to get to work with closing ARC and start a new project.Thank you for your support.
#15  
Aewsome... I always subscribe to Occum's Razor.... Usually it's the simplest thing that keeps something from working...;)
United Kingdom
#16  
Can you post the project anyway? While that solution is great knowing the cause is always something which helps too. You wouldn't have wanted to restart a huge project which suffered this issue I'm sure so if anyone else encountered it on a large project it would be great to see what you had done to cause it.
#17  
How do i post my project?
United Kingdom
#18  
On the right of the reply box is a box which says "Attach File". Click browse, select the project file, click upload file and then hit reply.
#19  
@RichR, Right! Never ASSUME anything.