Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.

Get Started
United Kingdom
Asked — Edited
Resolved Resolved by CochranRobotics!

Revolution Roli Rover Robot

Hi, I,am a total novice and I have just purchased the Roli Rover Robot .I have followed all of the tutorials but have the following issues:
(1) I can get all functions to operate except for the tracks and camera picture. I have checked the wiring instructions as in the tutorial which seem ok but the tracks do not move.
(2) One of the three servos moved smoothly for about two minutes but then became juddery when moving and the actual servo was warm
(3) The contents in the box was correct except for two addition wired cables with black end plugs they are about 12" long , the cable colours are white-red-black, they are not mentioned in the box contents tutorials or in any assembly instructions

Can anybody help, I,am located in the U.K.
Regards,
Paul Nicholson

AI Support Bot
Related Content
Synthiam
#1  
Hey Paul,
The long cables would be used to extend the servo wires at the end of the arms. This will prevent binding.

On the camera, do you get a blue light out of the front of the camera when the robot is on and the camera control is started?

On the servo for the arm, was there any binding that was caused by the wire being tight? Are all of the other servos moving without any jitter?

On the tracks, please look at this page to make sure that all of your wires are attached correctly.
#3  
My bad... Thanks Alan. My son was here and I had to help him move some things. My brain got distracted... DOH!
United Kingdom
#4  
Hi, your help is greatly appreciated, I have checked all of the wiring and it seems ok, the rest of the servos are fine I swapped the suspect servo with the other arm and the fault is defineately with the one servo the rest are fine (the servo did run smoothly for the first few operations then started to judder). With regards to the tracks not moving, if the fuse has blown would this cause the servos not to function as well, or is the fuse just for the tracks.
I removed all of the moving servos on the arms and camera and just left the tracks wired and tried again, still the tracks did not work. I have not configured any of the servos could this be the problem with the faulty servo.

Again your help is appreciated,

Regards,

Ian Paul
#5  
@Iannicholson1950 Are you talking about the 20amp (yellow) main fuse in Roli's body? If that blew then your ezb would be completely dead so nothing would work period, including any of the servos. I don't have a Roli so I don't know if there is any other fuse.... Anyway if that fuse blew I would go back and again check all the wiring carefully to make sure they are plugged in correctly to the H-bridge. Then I would go back over the Roli learn section step by step again... Pay attention also to that little button on the H-bridge.... sometimes for what ever reason it needs to be down while other people report it needed to be up in order to get Roli's treads to drive...
#6  
Please check the position of the button on the h-bridge(motor controller) in Rollie. Try changing the position of that and see if it works. I do not think that there is a fuse for the tracks.
United Kingdom
#7  
Hi I have moved the button to the up position and the tracks now move, with regards to the camera a green light is visible when the camera is switched on. You can see a very blared image on the screen so I thing it will need the camera focusing I will look on the tutorials for help with the camera. At least the tracks are now operating, again thank you for all your help it is really appreciated,
Best Regards
Ian Paul Nicholson
United Kingdom
#8  
Hi sorry to bother you again with regards to the camera it looks like it is not a vari focal lens when the camera is switched on you can only see faint shapes, but if I put a cotton bud touching the lens you can actually see the strands of cotton on the picture have you any idea what the problem might be?
Regards
Ian Paul Nicholson.
United Kingdom
#10  
Hi Ed, thankyou for the information, it is hard to tell if there is a protective film on the lens but I will take into my works and look under microscope to see, again thankyou. With regards to the tutorial I have gone though all of the proceedures but it is hard to tell if the camera is vari focal or foxed focal and it seems the method of adjustment seems a bit risky to me if you slip with the pliers and damage the lens. EZ should mark the cameras if they are fixed or vari focal.

Thanks Again,

Best Regards,

Ian Paul Nicholson.
United Kingdom
#11  
Hi Ed, I have solved the problem with the camera, after inspection through a microscope at work there is "no actual lens fitted" what I thought was the lens was the actual microchip. I,am trying to get a warranty replacement from EZ.

Regards,

Ian.