Asked — Edited

Mobile App And Movement Panel(S)

So I have built a mobile app that works great. I have a custom Movement Panel set up in EZ builder that controls my robo claw "h-bridge"for movement of its tracks. For movement of my robots shoulders I have used a second robo claw as I have used wheel chair motors for those as well, and a third robo claw for body up/down using a linear actuator. The second and third roboclaw were easily used by using script commands in speech recognition. So in other words I can say robot raise right arm and his right arm moves.

Now the problem. I would like to add the shoulders, and body up down to my mobile app. It seems as though the mobile app works directly with a Movement Panel and unfortunately it seems I am only allowed one movement panel? I would also like to be able to control his head pan and tilt which operate off of "standard" servos. Any ideas how to get around this?

                                             Thanks          Chris


Upgrade to ARC Pro

ARC Pro is your gateway to a community of like-minded robot enthusiasts and professionals, all united by a passion for advanced robot programming.

United Kingdom

Add a button to your mobile interface and assign it with the script command for movement of the other two robo claws.


Have you watched the video tutorial on making a mobile app? Sounds like you're relying on movement panels and default control views. You can create a custom mobile interface and add scripts to buttons. It's a very powerful and easy to way customize your robot and show off your custom app to friends:)


Hello, and thanks for the replies. I had already created an app. However I deleted it and tried to make a new one and it is not working, and Im not sure what I am doing wrong. It keeps saying saved to Cloud, but it is definitely not there. I named it B2K Mobile. It is not there. I watched the video 10 times today. The first time I watched the video I was able to create the app with no problems. Thanks Chris


Hi @kamaroman68

I'm just wondering if you are browsing to the correct cloud based folder that you saved it into? For example if you've saved to "Robots Incomplete" in ARC's EZ-Cloud are you browsing to the "Robots incomplete folder on your mobile device? Just figured I'd mention it too that you'll need to be connected to the internet with your phone in order to upload any newly saved cloud apps, before you try connecting to your's robot's network.


@Kamaroman68 I am unable to guess what the issue could be with saving to the cloud for you. Perhaps something strange happened to the project file. If you can post it on here, I will take a quick peek? You can use the Attach File and Upload on the right of the forum edit box.


There's nothing on my computer! All that I created yesterday is gone. When using my mobile device it still loads the very first project I created and works, which is weird because I deleted it from the cloud. I don't know. Theres nothing to post. I am going to try one more time creating the UI and saving to cloud. We'll see. Thanks Chris

United Kingdom

I will echo what Richard said, it's always a good idea to save locally too. While nothing has happened that I know of in the past there is always the chance that EZ-Robot's server may go down and cloud files become lost for ever. Personally I have at least 3 copies of all of my ARC projects (4 if it's something on the cloud)... I have a copy locally, a copy on my nas (auto backup my documents to my nas every time it detects a file has changed, been added or removed), a copy on my dropbox and, if shared, a copy on the cloud.

I lost too much stuff from a HDD failure a fair few years ago, now I over compensate for it:)


So I just created another one without coloring and mapping of individual buttons just in case it doesn't work again. I saved it to cloud. Again it said Saved! but nothing there. And yes Richard R this time I did save a copy to my desktop.


My mobile device says cannot open file. I tried to install the most recent ARC mobile. I currently have 2014 .5. 24. Not sure why it wont open this file. Thanks Chris


I keep trying to attach the file too but then this site crashes,weird. I rebuilt it with colors again although still incomplete and yes for sure I now save it on my computer.


There are no errors in our log for the website crashing.

Do you have the latest version of ARC for Windows and ARC for Android?

On your Android Device, are you loading your project from the Cloud or Local projects? If you delete a project from the cloud, it is still saved/cached on your device.


Just as an update.... Although I still cant make the cloud work, I was able to make the GUI on my PC and test it. From my PC all of the buttons work flawlessly. Now to get the mobile working would be great. One other question regarding this subject... As I add to my project, example when I finally add its claws is it possible to go back in and edit the CLoud GUI or do I have to recreate the entre project? Thanks


And my mobile device still says cant open for the newest mobile update! Chris


Still working on this problem... Still cant attach file. Im willing to do a teamview with someone if there willing to help. Otherwise I could try attaching file to a regular email address provided someone is willing to share that also. Thanks guys!


One other question on this. I saved this project to the cloud many times now. From my pc shouldn't I be able to go to EZ-Cloud, OPen and be able to find my project? Its not there when I do this. Thanks again. Chris


There are no errors in the cloud error log. Nor are there any errors in the website for attaching files.

Perhaps you can provide details step by step of the process so we can ensure you're not missing anything. Sometimes simple things can be overlooked:)


Sure. I have my ARC file sitting on my desktop. Its name is B2K mobile. I select the "browse" function located under Attach File, and above upload file. When I press the upload file button after browsing and finding my file the taskbar at the top of my computer says waiting for ez robot, and then says "page cant be displayed".


When saving my project to the cloud it says Saved! but I cant find it anywhere. Im trying to find a way to screen capture this.


Try it within ARC... Open your app in ARC.... Select File at the top of screen... You have the option to save to your PC (left save button) and the option of saving to the cloud (right save button).... I am thinking you might have been saving it all along to your hard drive instead of the cloud?

I just tried the above and it worked for me... I created a sample mobile app, uploaded it to the cloud... Moments later I downloaded it to my Samsung S3... Works great...


Yeah thanks Richard! For whatever reason its not there on the cloud. Ive sent it many many times now. The GUI does work from my laptop PC. And I am glad I saved it. Thanks guys Chris


Can you save regular projects (and retrieve them) to the cloud? When I browse the cloud with my Samsung, I see all my projects saved there, not just my mobile ones... Try saving a test app then download back to your PC... save it again and try to then use your Android to download it....


Another thing I just realized is when I launch ARC mobile from my galaxy 3 tablet there is not an option for EZ cloud app store, only Private apps, public apps, and local library. Again watched the video 10 times and that was the only thing I could come up with. The first app I made worked flawlessly over a month ago. I don't know what could have changed. Chris


Yes, the private apps section is where you would download your app that you created.... Unless you marked it public, that's where your missing app should be... Not sure what you mean by cloud app store.... Your app should be in the private app section of your Android app (along with the public option, that is what we refer to as the cloud)...Are any of your other regular apps there? I have dozens saved and I can access all of them via my PC or Android (all from my private app space)


I have been unable to post my project by attaching the file. I have sent the file to another member who is going to try and post it here so someone can take a look for me. I appreciate all the help!



Here is Chris's project if anyone wants to take a look at it.

The reason he couldn't save as a public file to the cloud is because he hasn't put the digital port descriptions in. I was able to save to the cloud privately, but can't help with the initial issue he was reporting because I don't have an EZ-B v4 yet. (well... I might be able to help. Reading the thread now to see if I have any input).



One suggestion to maybe help with your cloud issues is to temporarily delete the soundboard V4 control. It changes the file size from over 10 meg to just 168k which makes it easier to handle. Once you get your arms around saving and downloading from the cloud, you can edit it to put the sound back in.



I get the same warnings as you Alan... Deleting the soundboard allowed me to save the project to my cloud (private) with no further issues....

@Kamaroman68... Your project may be too big to save? Also, have you changed your user name or email in your EZ Robot profile lately?


Hey Guys thanks for the help.... I will try later on tonight when I get home. I guess what I am missing though is I don't seem to be having a problem saving to the cloud (see post 21). I just cant seem to find it in the cloud. Unless the soundboard is causing that issue I believe the reason the file got so big was due to the addition of a second song I put on that I was fooling around with. I will try, thanks.


I will ask again... can you save anything (project) to the cloud? Or everything you try and save disappears when you want to retrieve it? If you haven't tried... Open ARC, add a few random controls and then save a test project to the cloud with a new name... Are you able to find it later or is your cloud empty of all your projects?...


I am going to walk through the steps showing saving and opening your project to my private cloud.

First, make sure you are running the latest ARC on both your computer and mobile. ARC for Windows was updated today, Mobile on the 8th

Second, with your project open, and on the file tab, click the Save icon over the EZ-Cloud section of the ribbon.

You will get this dialog:

User-inserted image

Make sure "is public" is unchecked, since you haven't filled out the port details.

The category should be Robots-Incomplete (the default)

Click the Save button. If you still have the large MP3's attached, you will get a warning message that you can click through. If you have removed them, like I have in this example, then you will just get the "saved" dialog box. If you already have a file with this name saved, you will get a dialog box asking if you want to overwrite it. Click yes.

OK. Now that it is saved, lets look at downloading. First from your PC.

Close and re-open ARC.

Now, click the Open icon over EZ-Cloud in the ribbon. You should see this screen:

User-inserted image

Make sure the words in the cloud are "your library". If it says "EZCLOUD" click on the Your Library button.

The category should be Robots-Incomplete, and you should see your project on the right hand side like in this screen shot.

Click the Open button on the right, and your project will download and open.

I'll cover downloading to mobile in the next post.


OK. If we have gotten this far, lets go to the mobile device.

On your Android device, open ARC Mobile.

The screen should look like this:

User-inserted image

Click on the "Private Cloud" icon.

You should see this:

User-inserted image

Make sure the category is "Robots Incomplete" and your project should show there.

Click on your project and it will download and load, and you should see this:

User-inserted image

Click the lower right icon labeled B2K Mobile (the one without an image) and your mobile version of the project will open and attempt to connect to your EZ-B.


Thanks again guys, Im sorry but I probably will not be able to re-visit this till the weekend or possibly Friday night. Thanks


I did a teamviewer session with Chris this evening, and we have identified there is definitely a problem with cloud upload.

His Internet speed is not great (although the fastest available in his area) it is only 3meg down and 0.5 meg upload, so it is taking a long time to upload even a small file.

With the soundboard removed so that the file was 186K, we were successful uploading a few times, and failed a few times. We tried logged in as both him, and then I logged into his ARC as me and had the same issue, ruling out a problem with his account.

Neither of us was successful uploading a version of the file with a 10meg soundboard on it.

I am successful 100% of the time with either version of the file from my home, but I have 50/50 meg Internet.

The real problem is not just that the file won't upload, which with the large file and the slow speed is potentially expected (in fact, ARC warns that it might fail), it is that there is no indication in ARC that it failed. The dialog box says "Saved" whether successful or not.

@Dj Sures, Can you look at that dialog and make sure that it correctly reflects the upload status? I suspect it should be showing an "upload timed out" or similar status.

I was also thinking it would be good if you could provide a debug build for Chris to install that would capture some logs of where the upload is failing. I doubt you have ever tested on a 3/0.5 meg connection. You might need to adjust the upload routine to better handle network timeouts.

Chris also said he would be happy to set up a time for you to remote into his computer so you can see the failures yourself if you need more detail than I provided.



I am only posting regarding this again due to the time it was posted the ez-robot server went down. Alan as you can see has helped me out in partially solving the issue but probably needs further attention by the ez-robot team. Thanks


Chris, Have you tried again since the server outage? The outage was caused by something going wrong while DJ was splitting the forum from the cloud database to get better performance. There is some (small) chance that the performance improvement might help the low data-speed timeouts (although obviously not the invalid "saved" message when an upload errors out).



Hey Alan,

Haven't tried again, had a couple things come up. I will try now with this server modification though. Thanks