Asked — Edited

Jd Seem To Nat Be Worck And ARC

I dont know what my JD seems to be stuck and working backwards please help and the ARC keeps saying: Control named 'Auto Position' does not exist. Can not send command 'AutoPositionAction'.


Upgrade to ARC Pro

ARC Pro is more than a tool; it's a creative playground for robot enthusiasts, where you can turn your wildest ideas into reality.

  1. Do you have the latest ARC?

  2. Are you using the most recent JD project included with the latest ARC?


I just recieved jd. I am assuming it is the latest


DJ meant ... do you have the latest version of ARC software downloaded....?

Also, do you have your JD assembled correctly? All servos should be at or close to 90 (as close to as possible) when JD is in a standing position....


I tried unplugging them and turning them around but it only worked for some of them. JD didn't come with the snap on piece for the right knee. They sent me a piece replace it and it never worked or moved. the both elbows and claws do not work as well and the most up to date software.

United Kingdom

Not just the calibration tutorial but all tutorials.

Completing all tutorials will help you enjoy your EZ-Robot.


This is the video of jd not working.


Ah, that's an easy one - you need to Calibrate your servos...:)

When you first loaded ARC, it asked if you wanted to view the Courses to follow the Lessons. You must have accidently pressed DO NOT SHOW AGAIN and the NO button. The Course page can be found under the LEARN button on the website - it's quite easy to find. You will find it on the top menu bar of this website. Press LEARN and now you have some courses and lessons:D

I recommend you read each lesson - however, the ones that are most relevant to you are...

Also, have you verified that the servos are connected to the correct connections on the EZ-B v4? The assembly tutorial might be of help as well

Do not forget to follow the Connecting to JD as well.


salderson, can you confirm that you have read my last reply? Your most recent reply has only the words "jd gripper" in the message. I believe you might have clicked the POST button accidentally.

Let me know if you have read my previous message and we will get things running for you:)


I'm just resurrecting this thread a bit. It's hard for me to contribute since I don't have my stuff yet but I didn't hear that servo power up at all. It seems like either it's plugged in incorrectly or it's a bad servo.

United Kingdom

@Zap nailed it I think. The servo doesn't move when plugged in or when the power was cycled on the EZ-B. Both times it should have moved at least a little.

If looks like it was connected correctly therefore it may be a dead servo. When you set all servos ports to 90 and connect the gripper can you open and close the gripper? Don't put much force on it, if it starts to buzz stop forcing it. If it freely moves (like it did when you opened it in the video) the servo is either not connected properly or it is dead.

If that's the case, make sure you have it connected the correct way around (black to black, white to red and white to white). If you have then the servo is dead.

If the servo is dead use the Contact Us page to file a warranty claim and include a link to this topic. EZ-Robot will sort out a replacement servo and explain what you need to do.


Hey guys,

Just wanted to let you know that our Micro servo actually changed over to digital electronics and won't move when powered up, only when a signal is sent. Also wanted to mention that from values of 0-20 there is a dead zone, but it doesn't really matter as you wouldn't want the grippers to open that far anyway.

@Salderson I couldn't tell if you hit the 90 degree button or not at the end of the video, if you did and the servo still isn't working please Contact Us


User-inserted image

Has anyone come across this problem


It appears you are running an old version of ARC. When you load ARC, an annoying window flashes RED quickly telling you there is a new version available:)

  1. Visit

  2. Press the SOFTWARE button from the top menu

  3. Locate the DOWNLOAD button under the Windows tab

  4. Press the DOWNLOAD button

  5. Save the file and wait for it to complete downloading

  6. Open the file and follow the installation