Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.

Get Started
Asked — Edited
Resolved Resolved by DJ Sures!

Galapagos Bot

I have checked all of my servo alignments and they all appear to be correct. They all have clear movement and are properly aligned but I notice when the bot walks some of Servos jump and skip movement. They sometimes are not fluid. I have held the bot in my hand and tested the movement and they still skip. Is this normal? Should they always be fluid movement as long as nothing obstructs them? Do I have bad servos?

PRO
Belgium
#1  
dodgerrr

can you check your project against the original.to see if you got desame,
amount of frames.also you can test frame by frame in auto possition,
if he does it.
#2  
I just tried to check everything after recharging the bot and I was going to shoot some video of the servos skipping but it seems to run smooth right now. It does it intermittently. I did notice I was close to 7 volts when it was doing it. Could it be low power causing it. Also I am using the Galapagos bot program by DJ.
PRO
Belgium
#3  
dodgerrr

when he does averthing right when batt is charged.then the low batt wil be,
the cause.did you hear warning sound my batterie is low?
#4  
That's what I'm thinking but I need to check it more. Cause I believe the servos skipped on a full charge. I will keep checking the bot
#5  
In other words, if it's not the battery what else could cause certain Serbia to skip and not run fluid. It seems like it's two servos in question.
PRO
Belgium
#6  
you can try re download new ARC.
you can check all wires.
check Auto Position frame by frame
you can mesure the batt after its fully charge to see its really full.
PRO
Synthiam
#7  
Sounds like wifi interference. Try changing the ez-b to a new wifi channel.
#8  
Was the robot working well before this? Is this a new problem?

If so, have you stopped and started the ARC program? I have had some screwy things happen and was sure I had a bad EZ-B or a bad servo. It would usually happen right after a servo would be blocked from moving properly because the robot fell over in a tight spot. I even tried a different port for the servo and it still wasn't working right. Tried a different servo on the original port and still screwy. Turned the robot on and off, that sort of thing. Nothing worked. Finally I shutdown and restarted the ARC program (as well as cycled the power on the robot) and reconnected to the robot and all was fine.
PRO
Synthiam
#9  
It's wifi interference for certain. The commands to move the servos are sent via wifi. The wifi communication will be slower latency if there is interference. Each command is send over a tcp wifi packet. If there is delay in a servo moving or occasional jerky movement, that is wifi interference.

Changing to a different wifi channel should help. Depends on the saturation of wifi in your area.
#10  
Haven't had time to check it. But that must be the problem.