Asked — Edited

Ez-B Iotiny Random Servo Jumps/Activity?

Hello Everyone,

I have an EZB LoTiny (such a great little device) set up with 7 ez-robot HDD servos.

The problem I am having problem is with random servos activating, moving anywhere from 1 to 180 degrees. This will happen when the board is powered up and not connected to WIFI and also when it IS connected to WiFi and to EZ builder.

Once connected to ARC and the servos are moved with either autopoistion or any servo control the servos will act normal and the problem does not come back again until repowered again.

I am using a voltage supply @ 6.5 volts.

I have a couple of EZ-B v4/2 that work without any issues.

Any thoughts would be appreciated or ways of testing?

Skip to comments


Upgrade to ARC Pro

Subscribe to ARC Pro, and your robot will become a canvas for your imagination, limited only by your creativity.


I think those servos are rated at 7.4 volts. There may not be enough voltage, amps or both to keep everything steady.


@Holy1, You might also want to check the current rating on your power supply as the servos Can have a high current draw and affect the IoTiny

Have you tried disconnecting a few servos to see if you still have the problem?

I’d recommend the LiPo battery from EZ-Robot

Regards, Frank


Thank you for the responses, I have tried different voltages and am using 7.4 v @ 15 amp at the moment with no discernible change.

I did not want use a LiPo battery as there will many more servos( with the ezb4/2) being used in the future.


If the servos aren't told where they should be they can move where ever. It's best to have an initialization (init) script that runs when connection is made, that tells the servos where they should be. Then when you shut down the robot, shut it down in this position. You may also want to have the servos and your controller on there own power switch. Then you can power on the controller, connect it and then turn on the servos. The servos will then move to their position as defined in the init script.


I think your servos are suffering from a small manufacturing issue we had with some bad POTs - if those are indeed hdd ezrobot servos.

There was a small batch of servos that had an issue with carbon buildup in the analog potentiometer that monitors the output shaft position.

This is only a maybe - depending on the purchase date and servo model. Contact Us to see if it applies to you. If it does, we'll send replacements.


Thanks for the response everyone.

@DJ - yes, they are hdd ezrobt servos, I got them in august from I don't feel as though they have a bad pot because they don't jitter. They just move all the way from 0 to 180 and back when the board is powered. Once activated by ARC they work fine.

I think I'll try what Bhouston mentioned and use a init script and give that a go.


@Holy1, I don’t think the init script will solve your issue as it runs after the connection is made

As you mentioned you have EZBv4 units, try one of those as a replacement for the IOTiny to isolate the problem to a controller issue

Regards, Frank


@faengelm - yes, as i said the Ezb4v4 worked without issue with the same setup ( i have tried it as a replacement.

Thanks for the suggestion though.


Sorry, I thought you meant you had used then in other setups