Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.

Get Started
Asked

EZB Not Responding

Can't get ECB to connect? I'm getting the EZB Not Responding error. "Unable to connect to 192.168.10.1:23. This PC apperas to be connected to a network with the IP address that was specified. However,, the connect could not be established with the EZB." The EZB Wifi network is running. I turned Norton Anti-Virus on and off. Same problem with both settings. As my Linksys router and the ECB both used 198.168.1, I had to follow the instructions to change the EZB to 192.168.10.1. When I saved and rebooted, the EZB responded. However, when I go into the Connection and change port 0 to 192.168.10.1:23, I get this error.


Related Hardware EZ-Robot EZ-B v4
AI Support Bot
Related Content
Synthiam
Based on your post activity, we found some content that may be interesting to you. Explore these other tutorials and community conversations.
PRO
Canada
#1  
Hello @tbrunson,

I just tested what you had mentioned. I went into the webserver changed the AP mode address to 192.168.10.1 and then connected it in ARC with 192.168.10.1:23 in the connection skill. It worked for me. Please make sure there aren't any spaces or anything when you typed in the new address. It could also be that there is a device on your network that is using 192.168.10.1, maybe try something like 192.168.1.115.

There are a couple of options you could use to troubleshoot further. You could try using the ARC mobile app and connect to the EZ-B to determine if there's any EZ-B hardware trouble going on, and/or you could try an external USB WiFi dongle to connect to see if there's any hardware trouble on the PC/Laptop side.
PRO
Belgium
#2  
hi jeremie&tbrunson

if you try many times to connect it is best to delete your browser history .
PRO
Synthiam
#3   — Edited
Does the EZ-B v4 even work in AP mode? Also, the connection troubleshooting for WiFi EZBs is here: https://synthiam.com/Support/troubleshooting/Troubleshoot%20WiFi%20Connections

Because there are so many places where connection failures could be happening, it is recommended to use the troubleshooting guide that I linked to above. Always make sure the EZB (whether USB or WiFi or Ethernet) works in their default configuration first, in this case it is AP Mode over WiFi. Every time the "unable to connect" message is displayed, it will also bring you to the same guide.
#4  
Thanks to those who answered. However, none of those suggestions or observations worked. And, of course, I had reviewed the trouble shooting guide for WiFi EZBs as well as several other videos and guides on the Synthiam website. The problem was resolved yesterday afternoon. Sunday evening before leaving I turned off JD (again) and closed ARC. Yesterday morning I rebooted this computer where ARC had been running. After looking at all of the same guides and videos, I again reconnected the JD V4 WiFi after turning on JD. I loaded ARC and created a new project. On Sunday once the JD IP address was changed I had manually changed the IP in the Connect dialogue for the Example Project. That did not solve the problem. This time I clicked on the WiFi logo for port 0 and then scanned the IP address for the new project. Once it sensed the exact IP address and port for the JD, the JD responded. I then saved the project to keep the change.

I then proceeded to attempt to do the servo calibration. The head was vibrating. As when I was watching a video earlier in the day I had noticed a chat feature on the right bottom of the screen, I contacted support. Miranda answered. She was very helpful. We diagnosed the problem by checking to make sure that D0 and D1 were properly connected. They were. Then she had me remove each one at a time. Apparently the head servo is bad. They are sending me a replacement for that servo so that I can install it. I informed her of the previous problem and that the troubleshooting guide and excellent connection video had left out some steps -- which took me a few hours to discover. 

Specifically, once the IP address was changed on the JD WiFI settings, there is still a need to change the IP address on the Connection dialogue inside the project. That can be done manually, but that apparently does not work. The only solution was to click on the WiFi icon for that port (i.e. the port for the JD, which was 0) and do a scan. Once that is done, the project has to be saved Note that I did inside a new project as there are problems saving the Example Project. Now when I open up the new project -- provided that I connected to the WiFi using Windows 10 first -- the IP is correct and I merely click on Connect to get started. Attempting to make this changed (scanning and saving) on the Example Project is very cumbersome. The video specifically showed opening up the servo configuration dialogue and then clicking on that dialogue's connect button. That creates an error unless the Connection dialogue was changed first. That was not addressed in the video -- when it comes to correcting an IP duplication problem. When I ran into that problem, I posted the message on the forum. Then I had to go home. 

Note that the default IP address is a standard "out of the box" IP address for most routers. So, this should be a very common problem. (The guide said "disconnect the Internet" not realizing that having the Internet is desirable. I solved that step by unplugging the router and then plugging it back in once I had changed the JD IP address. Also, the guide said that anti-virus software is almost always the problem. That is not true. I attempted this fix with Norton Anti-Virus disabled and enabled. That made no difference.) 

Thanks for the attempts to help. I've been verbose hoping that Synthiam folks can more clearly address this very frustrating problem. The IP conflict is probably very common. And, the steps to resolve this omitted a few critical ones. Otherwise, I believe that the videos and guides are top notch. I'm looking forward to progressing once the new servo is installed.
PRO
Canada
#5  
Thanks for wiring about your experience @tbrunson

I'm a bit confused though, did you try using AP mode out of the box? Were you assuming that Client mode (with a router) needed to be used?

A computer can connect directly to an EZ-Robot without the need for a router. The scan tool is only needed for client mode.
#6  
I received JD Friday and opened it up for the first time on Sunday. I was immediately frustrated because there were two items on the box (one being a sticker on the body) that referenced URL's for which I received "404" errors. Once I turned on the brain, there was a recording that mentioned one of the two not-found URLs. So I used an older YouTube video to construct JD. I had downloaded and installed the ARC software, which in many places is still referred to as EZ-Robot. I eventually found https://www.ez-robot.com/learn-robotics-getting-started-humanoid-robot-kit.html, which contained fantastic videos and information -- although there were some gaps as I've noted. I viewed The JD Introduction and Setup lessons. When I got to the connection bit in lesson 7, that is when I started experiencing the connection errors. Those errors sent me to a variety of pages on the Synthium site. Those were helpful at times although there were the gaps previously noted. The JD Introduction and Setup information did not mentioned the concepts of AP mode and Client mode although they never fully explained what they meant. I am very familiar with networking and computer hardware. However, I am still not sure what "AP Mode" means. I don't recall that AP Mode and Client Mode were discussed in the ten lessons. This is a long way to say that I was not "assuming" anything. I was merely closely following instructions in those 10 lessons. If the guides previously referenced mentioned the scanning step and that was done before the servo configuration dialogue was brought up (or this information included or referenced in the instructions, I would have saved at least a couple of hours of research. Hopefully, that is a helpful suggestion. Obviously, some setting JD up at a home where they did not have a router, this problem would have never happened. But now that is behind me and I'm excited to move on. Thanks for your concern. I've done tech support for a few decades. I always appreciated feedback so that frustrations could be eliminated for future customers.
PRO
Belgium
#7  
hi Tbrunson

maybe its a stupid idea but maybe its good to check the batterie of jd ?
#8  
Nomad,
Sounds like a "no brainer." Again, I followed the instructions step-by-step. One of the first things said in Lesson 7 was to make sure that JD was fully charged. Additionally, as the problem has been solved, that obviously was not the problem. 

I hope that someone of authority sees this post and adds not only the missing information to the troubleshooting guide but also adds "self" to the "This was resolved by" on the dropdown. It is impossible for me to change the status without attributing the resolution incorrectly. 

Again, thanks to everyone for attempting to help or at least chiming in. I am new to this site and it means a lot to know that there are enthusiastic participants. I'm looking forward to communicating with all of you, viewing your contributions, and adding my own.
PRO
Canada
#9  
@tbrunson thank you again for your valuable feedback!

EZ-Robot will fix our links and try to make the onboarding experience more seamless. 

I'm sure you found the JD robot course, but I was curious if you saw this page: 
https://www.ez-robot.com/learn-robotics-connecting-your-humanoid-robot-over-wifi.html

Or this page:
https://www.ez-robot.com/learn-robotics-wifi-modes.html

The first link shows how to connect to the robot via AP mode (it's the default mode that we recommend) and the second link explains the different modes.
I hope that helps, even if it's after the fact.
#10  
Jeremie,
Once I found the learn robotics page (after I discovered that the two recommended URL's did not work), I started on the first video and viewed them in order. Once I got to the lesson on WiFi connect, I closely followed the instructions in the first video. During the process I encountered the error involving two routers with the same IP. Once I received the error using ARC, I followed the instructions, which involved using the trouble shooting guideline. Note that as I followed the lessons and their videos in the order shown to include constructing JD, that path led me to the trouble shooting guide and away from that lessons page. That was Sunday. The information on the pages recommended by the error messages included statements like "turn of Internet on your router" and mentioned that most likely the "problem" was being caused by anti-virus. (I got the same errors regardless of whether my Norton AV was on or off.) I unplugged my router and was able to type the JD router IP into a browser and make the change. Still following the instructions on first WiFi video did not work as steps applicable to my issue had been omitted. The troubleshooting guides that I had been directed I believe did not reference other resources. So I posted the message. The auto response listed resources that I had already viewed. 

On Monday I as I had received no further response, I started with the first tutorial video and again I viewed all of them until the WiFi page. Having a tech background, I tried on my own to find a solution even though I was just starting to get familiar with ARC and the JD. I created a new project and then since the problem involved connection, I started exploring the Connection dialogue box for the new project. The previous day I had attempted to manually change the IP address. That did not work. On Monday I learned more about the WiFi button and the scan feature. As I had connected my computer's WiFi to the JD and had previously plugged in the WiFI2 dongle, and had turned on JD, which has been freshly recharged, once I did the scan, it responded. So I knew I had done something right. It was only after that point that I noticed that others had posted responses -- which did not apply to my situation. 

I've gone through the first set of ten tutorials. Over the next few days I plan to go through the rest of the tutorials that cover how to use the other ARC features. Hopefully, once the replacement servo comes in, I can start developing projects. I'm looking forward to it. Thanks for your help and interest.
#11  
Again, I thank everyone for their input. However, as already posted, I resolved the issue myself. Now I'm getting daily reminders to close out this thread. However, there is no option available that allows me to state that this was self-resolved. On the other hand, the next day I had a problem with JD's head vibrating. I used the chat feature to get help. Together we diagnosed the problem, which was determined to be the servo at the neck location. They sent me a new one, which I installed last week. I still have not tested it due to a very high priority issue at our office -- that required me to work the entire holiday weekend. I hope to test JD and spend more time with him this week.
PRO
Synthiam
#12  
glad you got it resolved. choose someone that helped the most.