Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.
Get Started

Germany
Asked

EZ Script: Servospeed (Servoport, Speed) Without Any Effect

Hi Guys,

coming from My Robotlab iam very happy with the way this software works, awesome.
To start Iam trying to move a few servos with EZ-Robot script and a Arduino Mega. Connecting worked suprisingly well and i can move the servo to any position, however i cant change the speed.
I used pin2 (PWM) and regular digital pin22 both show no interest in servospeed adjustments
i tried it with the initializing script tutorials, with blocky and ez-script. Iam aware of the issue with setting a positions first and then the speed. I tried it in any order. Any idea whats up? Thanks!


Related Hardware Arduino Due/Mega
Related Control Speed
AI Support Bot
Related Content
Synthiam
Synthiam
#1  
That controller doesn’t support servo speed. When ARC is connected to the controller, it’ll display the capabilities list in the log. You won’t see servo speed in the capability list
Germany
#2  
Hi DJ, thanks. Okey so my inital thought of building an inmoov with arduino and ARC wont work out, ha?
Guess i'll need the EZ-B controller? Well, at least i support you then a bit:)
Just for my understanding, i cant reduce the speed on servos connected to arduino on ARC?

thanks
#3  

Quote:

That controller doesn’t support servo speed.
AFAIK servo speed is implemented through software e.g. arduino firmware

DJ's implementation does not implements the servo speed, that does not mean it can't be supported or implemented. 

I'm not sure but servo speed is not a requirement when you use the AutoPosition control, maybe DJ can clarify his statement.
Synthiam
#4  
Ptp is correct - the AutoPosition doesn’t need servo speed capability. So, you’re golden to use Arduino for your inmoov.
#5  
Very Interesting. Im having a lil issue with servo speed myself ( not to hijack this threat but) via EZ script. I want the head servo to move from left to right on command, but cant get it to move it slowly, it just whips around at full servo speed. I did try the recommended idea that the servospeed needs a position first to start per instructions but still doesnt slow it down.  Im sure im missing something.
#6  
@RoboHappy:

Quote:

I want the head servo to move from left to right on command, but cant get it to move it slowly, it just whips around at full servo speed.
Are you using an Arduino Mega ?
Synthiam
#7  
Complimenting ptp’s question - does the controller you’re using support servo speed capability? Look in the debug window after connecting and see
Germany
#8   — Edited
Hi all,

grazie! my problem with the speed is solved. With the delay in the Auto Position I get exactly what i was looking for.
Whats the difference between "delay" and "speed" when setting up frames? i learned already that speed doesnt work on ard mega but isnt delay doing the same for me?

edit: just read the instructions:P i understood that with cheating and using delay i will get jigger at slow movements. guess ill still get the EZ-B/4, once germany seller is back on stock:)