Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.

Get Started
Asked
Resolved Resolved by DJ Sures!

Controlling Speed On Dynamixels.

How would you approach controlling travel speed on a Dynamixel (400 Series) servo when not using Autoposition?
I tried setting ServoSpeed prior to calling a servo move command but it doesnt seem to work.
Does it need to be done manually in a script using for-to loops and pauses?
I could create a loop that takes you from point A to point be in increments rather than a single goto the endpoint command.  That along with a pause between increments should do the job, but since AutoPosition has that built in, I thought maybe there was already a skill available to do it with.
I can also try setting parameters onto the servo itself using the Dynamixel wizard, but was hoping to find a way within ARC.


Related Hardware Robotis OpenCM 9.04
Related Controls Servo Speed Dynamixel
AI Support Bot
Related Content
Synthiam
Based on your post activity, we found some content that may be interesting to you. Explore these other tutorials and community conversations.
PRO
USA
#2  
It took me a bit to get comfortable with the javascript, but I finally got this to work as well as my EZScript version but still no control over speed.
Here is my code:

Code:

function randomNum (min = 0, max = 50) {
let num = Math.random() * (max - min) + min;

return Math.round(num);
};

var randomV1 = 1;
var randomV2 = 1;
var randomV3 = 1;
var sleepyTime = 1;
Servo.setSpeed(V1,10, 0);
Servo.setSpeed(V2,10, 0);
Servo.setSpeed(V3,10, 0);

while (1){
randomV1 =randomNum(80,100);
randomV2 =randomNum(88,95);
randomV3 =randomNum(73,104);
sleepyTime = randomNum(1000,5000);

print(randomV1);

Servo.setPosition(V1, randomV1, 0);
Servo.setPosition(V2, randomV2, 0);
Servo.setPosition(V3, randomV3, 0);

sleep(sleepyTime);
}
I tried moving the set speed lines in and out of the while loop.  I also tried changing the speed value from 10 to 1 but the servos move full speed every time.

I also copied the example code for the init script inside the Connection skill.  I am running 3 dynamixel XH430-W350-R IDs 1,2 & 3 on openCM with expansion board on Port 0...   The servos do move just really fast.

The code in the init script is:

Code:

// This will clear the servo speeds for initialization.
Servo.setSpeed(V1,0, 0);
Servo.setSpeed(V2,0, 0);
Servo.setSpeed(V3,0, 0);

// The following will move the servos into desired starting positions.
Servo.setPosition(V1, 90, 0);
Servo.setPosition(V2, 90, 0);
Servo.setPosition(V3, 90, 0);


// The following will now set the servo speed for these servos which will be
//used from now on.
Servo.setSpeed(V1,0, 9);
Servo.setSpeed(V2,0, 9);
Servo.setSpeed(V3,0, 9);
any ideas?
PRO
Synthiam
#4  
I tested and the servo speed seems to work for me. Try using the latest dynamixel plugin and enable debug mode. Check the log to see if the servo speed commands are being acknowledged.
PRO
USA
#5  
That is very strange... I will try it on Monday and also try doing a factory reboot on the motors just in case...
PRO
USA
#6  
I went ahead and did a few things...
1) I factory reset my dynamixels
2) Installed the Dynamixel Skill update
3) simplified my project so that it only included only one dynamixel and the script to move it from limit to limit.

Sadly nothing changed and the servos continue to move at full speed no matter what number (1-10) servo speed was set to.  The only way I was able to slow them down was by bypassing the Speed function altogether and doing something like this:

Code:

var servoSpeed = 25;

while (1){
for(var servoPos=73; servoPos<104; servoPos++){
Servo.setPosition(V3, servoPos, 0);
sleep(servoSpeed);
}

for(var servoPos=104; servoPos>=73; servoPos--){
Servo.setPosition(V3, servoPos, 0);
sleep(servoSpeed);
}
}
PRO
USA
#7  
David, just saw your email last night and shot you off a reply last night, but looks like you are ontrack now.
PRO
USA
#8  
What is strange is that I also grabbed a couple of XM540 servos and they behaved exactly the same as the others...
Here is a video of the issue
PRO
USA
#9  
That is weird. I've never tried adjusting the servo speed on a dynamixel in a script before, but that is definitely the same speed.
PRO
USA
#10   — Edited
We did find out the hard way that Robotis, changed the protocols on various servo models...not sure why...my results varied from series to series..I.E. some did not function at all using the dynamixel skill. There is a hack night somewhere as you can see DJ working through and showing they changed the protocols.

What dynamixel model servos are you using for the neck? They may have changed the protocol for the speed on the servos.
PRO
USA
#11  
I'm using XH430-W350-R but I tried it with some 500 series as well and got the same results.
I thought the speed command was just creating a delay loop to slow the servos down,  If they are accessing the dynamixel parameters to do so, I would love to see the skill allow for access to acceleration and velocity settings so that we could dampen the servos start and end points.   I do this all of the time outside of ARC and it makes all of the difference in the world....  All of the vibrations and jerkiness can be tuned out and super smooth results can be easily achieved.

DJ, what servos were you using in order to get the speed command to work?
I have almost every type of X series dynamixel here...  I can switch and duplicate your setup
PRO
Portugal
#12   — Edited
I dont have those servos but you could try running without the port setting: servo.SetSpeed(port, speed)
Or try running this code in ezscript just to debug:

Code:

# This will clear the servo speeds for initialization.

ServoSpeed(D1, 0)


# The following will move the servos into desired starting positions.

Servo(D1, 90)


# The following will now set the servo speed for these servos which will be
#used from now on.

ServoSpeed(D1, 10)

PRO
Synthiam
#13  
Use the latest version of the dynamixel robot skill: https://synthiam.com/Support/Skills/Servo/Dynamixel?id=16142

It has new control commands that allow writing directly to the servo's RAM using the control table. Read the manual section for the robot skill that provides a link to view the control tables for each servo.

If you're able to find a control table address that works for servo speed or acceleration, let me know and I'll update the robot skill accordingly.

I'd like to add a global acceleration parameter to ARC so any servos supporting it would be compatible.
PRO
USA
#15  
Calling this one resolved by the latest awesome update to the dynamixel library V43!