Asked — Edited
Resolved Resolved by Zap Brannigan!

Can'T Load ARC

I went to update and during the installation I get a message that the object already exists and it cancels the installation. I tried to uninstall but it is not there anymore. I tried to download ARC again and the same thing happens.


Upgrade to ARC Pro

ARC Pro is your gateway to a community of like-minded robot enthusiasts and professionals, all united by a passion for advanced robot programming.


Sometimes windows does strange things. Have you rebooted?

You may need to manually delete the eZrobot folder in c:\program files(x86)


I deleted the folder and rebooted to no avail. Same message.


Can you screen shot the error?


I would re-download it. My copy is working fine.

wait, you are not trying to put it on xp or vista?

Mine is on Windows7 and Windows8


@Mel... He already did that.... It has nothing to do with his os as the previous version of ARC was working fine for him... For the record, he is not using Vista or XP...


If all else fails, you can try reverting to an old restore point, uninstall ARC and then reinstall the new version....


Is that ever a strange error. Try renaming the ARC folder in my documents to ARC.bak


Or disable any virus scanners


I have seen it suggested that a recent update may cause this issue. KB2918614 corrupts MS installer and creates the problem.Uninstalling KB2918614 and rebooting is supposed to fix it.


I tried Richard's idea with the restore point. No luck. I tried changing the name of the folder as DJ suggested. No luck. I would like to try Zap's idea but I can't find KB2918614 to delete. Can you give me any more information so I can give that a try?


I use WIN 7 so I can tell you how to find it there. Go to Control Panel, then Programs and Features. On the left side should be a link to "View installed updates". You can sort them by date installed. Look in the Microsoft Windows section. For me, it installed on 8/19/2014 but we have a slight delay from release to install here at work. It may have been a week or so sooner for you if your updates are auto downloaded and installed.


Zap is the MAN. Loaded without error. Now if I could just get my file back. I have a feeling it is history.


Did you copy your project to the cloud? You should make a habit of it in case something like this happens again....


I did Richard, and that is what I find unusual. It was corrupted in exactly the same way. At that point I assumed that the cloud was updated automatically. It must not if you say so. Also Rich said there was a audio servo in the project that he saw and I never put one in. These last few days have been very perplexing.


Yay! My first assist! I'm happy to be able to help.


@Zap Brannigan, Again many thanks for without this fix I could not load ARC. As a matter of fact I have to do this (find and delete KB2918614) every time there is an ARC update. Does anyone know how to fix this other than stopping automatic Windows updates?

United Kingdom

You can set windows updates to ignore specific updates.

I'm not 100% sure on the process since I can't test it (as I am up to date) but I think it's along the lines of setting updates as manual, checking the list, right clicking on the update that's available (i.e. KB2918614) and choosing hide update


Thanks Rich, I didn't find exactly what I wanted but now at lease Windows will ask me before it downloads any updates. Great option from where I was. I should have started a new thread so I could give you credit.

United Kingdom

Don't worry about the credit, it wasn't exactly an EZ-Robot question anyway so not quite in line with the terms for the whole credit thing, besides I can let one or two slip by from time to time:)