Asked — Edited
Resolved Resolved by thetechguru!

Can'T Hook Ezb4 To Network

I have an ezb4 that has worked fine for a while. I had took the robot apart and then put it back together using the V4 instead of V3.

My problem is: I go to find the ezb in the internet access window. I have reset it many times.

I have to give it a code 1234 to hook up to bluetooth. well, I found that I lost ports for Com3, and Com4. So I added them back. My device shows up, but I have a hard time getting to the part that says are you ready to pair?

If I enter in the correct number, it goes out a trys to pair it, it times out and I have to start all over again.

The green light is on and it continuously blinks. There is no red, or whatever. Just a blinking green light.

I have taken everything apart and now my time has run out. I will be back Tues CST to work on it again. I have the unit hooked to a separate 12vdc battery so it will have plenty of juice. There is a constant blinking green light.

Also, there is no sound at all.

thanks in advance.


ARC Pro

Upgrade to ARC Pro

Get access to the latest features and updates before they're released. You'll have everything that's needed to unleash your robot's potential!

#1  

@Moviemaker I don't understand, are you trying to connect the V4? V4 is wifi not Bluetooth

#2  

@moviemaker, Perhaps you should write this down and stick it on a wall. It may aid your condition.

The EZ-B V4 uses WiFi. It connects to your network over wifi. Your initial connection to the ez-b V4 will be direct using your computer. You will then type in your browser 192.168.1.1.

Go to the client mode tab, and enter the information for your Routers wifi address(if you have a wifi network in your house). Then press connect and the ez-b will try to connect to your router and DISCONNECT from your computer.

If it worked, your ez-b should be green or blue, or both. Then connect your COMPUTER to the routers wifi network and open ARC. go to the connection control, and press the scan button to scan for the EZ-B which will now be on your network. Once found, click it, and press connect. Done.

#4  

I suspect @Mel is suffering from what my dad is suffering from... Sometimes my dad can't even remember my name... It is sad, but not much you can do about it...

PRO
Synthiam
#5  

That's why we're patient:D

#7  

When I click on the button, there is no webpage that comes up for me to get inside of the ezb settings.

NO IP shows up in the wifi section. and NO sound or bootup. Just a flashing Green light.

#8  

No boot sound is a problem, but I believe it sounds like it is already connected to your or a network. Try pressing the scan button in ARC on the connection control and see if it sees it.

#9  

@Moviemaker Dude I don't have any medical condition going on, but I have terrible memory. I make up for it by making notes. I find that writing something over and over again is how I memorize stuff...I remember and understand better when I see myself writing the words in my head. It may work for you. My 2 cents. :)

#10  

thanks doombot,mho.

scan turns up blank.

#11  

It doesn't boot up properly. I have pulled it out of the robot. When you hook up power, it just flashes the green light. that is it.

I think the firmware has gotten messed up. It has no sound.

#12  

@Moviemaker About the sound, do make sure your speaker is properly seated in there...it has happened to me, when I opened the case and put it back together the speaker just stopped working. Just make sure the springs on the speaker are touching the leads on the board.

#13  

@Moviemaker, you could trying pushing the reset button, find a paper clip or a small pin, push and hold it for about 8 seconds. Release the button and see if itales a chime, if it does it should then flash blue.

If this work,et us know.

#14  

I will do this., , , , ,

No effect . Same.

#15  

When you say same is the light blink green or blue

#16  

Green Light is slowly blinking. No sound, not internet. just blinking green light.

#17  

@moviemaker, try it this way, turn your power off on the ezb4 Press the reset button continue to hold the reset button and power on the ezb4. continuing to hold the reset button for eight seconds then release see if it goes back to blue light blinking

#18  

@mel, did my last post work?

PRO
Belgium
#20  

can you try to connect first with an android or iphone? then pc

#21  

my wife won't let me use her iphone, but I have an android device. I will try to hook up.

. . . . . . Nope. I don't see the device in the list. same way one the desktop. It used to show up as EZB .....something, something, something.

I believe the wifi part of the V4 has gone bad. Or possibly the firmware. I don't have a proper flasher or image.

PRO
Belgium
#22  

do you know how to delete your browser history?

#25  

I was clearing the cache. I had a LOT of stuff.

OK, cache is cleared. Now what?

PRO
Belgium
#26  

did you connect with your phone?

#27  

Nomad, If he can't see the EZ=B network, it has nothing to do with browser history or cache.

I do believe he is correct that the EZ-B WiFi may be broken.

Mel,

Try opening the case, and carefully separate the two boards and push them back together. Sometimes re-seating the boards can help.

I have a firmware flasher if you want to send the board to me for troubleshooting. I think you still have my address. Email me if not.

Alan

PRO
Belgium
#28  

alan

i had a problem long time ago,it also didn connect.some one told me to do this, and he did connect.thats why i ask to try connect with a phone,first steps i believe.

#29  

OK, after that, I will take Sally apart and forget the robot business until I can buy one already factory assembled and with ALL the software.

Thanks! Alan, you are such a nice guy. I already took it apart. But, I did not separate the two boards.

#30  

Mel,

If you do send me the board, also send me your router's SSID and password, and I'll pre-configure it to connect to your network so you don't need to go through that again. Only think we may need to do is log into the router to reserve the IP address because if I determine it is the WiFi and not the main processor board, I will send you one of my other EZ-Bs and when EZ-Robot releases the 4.x/2 com board upgrade I'll replace the WiFi board with that.

Alan

#31  

@Nomad,

That could cause problems connecting to the EZ-B's web page, but would not prevent you from connecting the the WiFi network. Similar problem, but different.

Alan

PRO
Belgium
#32  

thanks for telling.does he dont need to remove the com ports he made with that bluetooth?

#33  

Quote:

thanks for telling.does he dont need to remove the com ports he made with that bluetooth?

No, they won't matter.

Alan

#34  

OK, Alan. I will send you the board. But, I don't have any money for shipping right now so it will wait until I can raise some.

Thank You , my friend!

#35  

I'll go ahead and send you the spare, and I'll include a pre-paid label you can put on the same box and just stick it in the mail to send me the broken one.

Should be on its way tomorrow.

Alan

#36  

Alan, I will need your ship-to address. I will email you with my info. I have your email address and the town, but not the home or ship to address. I have it boxed up but I am looking for a smaller box.

#37  

I'll send you a pre-printed pre-paid label with the spare EZ-B I am sending you. (@Merne covered the shipping cost). You can re-use the box that I am sending the EZ-B to you in, since it is an appropriate size.

See the email I sent you for some information I need to pre-program the EZ-B.

Alan

#38  

ok, I just sent you an email.

thanks!

GOD BLESS YOU!

#39  

You have saved Sally's life. Thanks to the both of you. God Bless You! You have Blessed me and YOU have become the Blessing to me.'

:-)

PRO
Belgium
#40  

alan

thats service at higest level.

User-inserted image

#42  

Sweet, glad it's working again. That was fast, thanks Alan. Funny how grown men love robots:D

PRO
Belgium
#43  

yes i forgot one,sorry about that.

superduo alan&merne then.

#44  

No, no, Alan is the hero here. Alan has help a lot people and has a lot others too. Actually I was hoping my name would not be mentioned but that's OK to.

:)

#45  

-- sorry about that @Merne. Didn't realize you wanted to keep the arrangement just between us.

Anyway, your contribution was appreciated.

Alan

#46  

Hey, Alan. I am hooked up to the network. But, how do I know that I am in the Client Mode?

BuggyEZB is doing fine.

#48  

OK, I have watched the videos and followed the procedures. I have hooked a blue LED to light up on D0 to see if it is connected. It is connected just fine.

But, my question was not answered. I asked "How do you know it is in the Client mode?

I have two concerns. a. My Router usually uses 10.0.0.1. But now , it is using 192.168.x.x

b. The EZB4 did not show up in the scan. But it is hooked up and works.

I was looking for an answer like: Solid Blue = Client mode. Solid Red = AP mode.

Thank You , richr

#49  

Jesus @mel this is just not working for you. It's been nearly 2 years since the ezb4 has been released and you still struggle just getting it even connected... Maybe it's time for a new hobby, man?

One last time... This is not hard and as usual you over analyzing everything... Forget about what your router is doing or not doing...

If your ezb4 is connected through your router you are in "client mode" (Green LED)... if your ezb4 is connected directly to your PC you are in "WP mode" (Blue LED)...

Write this Down and stick it on the wall in front of you..

Flashing blue = WP mode... NOT connected to ARC Solid blue = WP mode... connected to ARC

Flashing green = Client mode... NOT connected to ARC Solid green = Client mode... connected to ARC

Sorry man, not trying to be rude here,.... but this has to stop at some point... We keep going around and around here like the movie Ground Hog Day...

PRO
Belgium
#50  

green led and text in ezb that tels you i have sucsesfull connected to your network

client mode on the web page is just under ap mode.

#51  

OK , right now , I have a solid blue light. That tells me I am in WP mode, right? Now I need to get to client mode. I just have to play with it because I know where to change it. I went through the procedure earlier and it did not change from blue. I just need to go over it again.

richr, thanks for your help.

PRO
Belgium
#52  

do you have a cell phone,go to 192.168.1.1 put in your ssid and password. and connect,you will see message conention will be lost but the led goes to green. blinking.you also hear message am sucsesfull connected to your network. then op ARC and use the scanner,when connected save in cloud.

#53  

@Mel, I assume you have a computer with Wi-Fi right ? Turn on the ebz4 you Will hear a chime and it should be blinking blue. Open up your Wi-Fi icon on your computer you will see the ezb inside there. Click on connect and you should be connected to it now.

wait let's do it this way can you post your email address and I will email you later today with my phone number and I can walk you through on the phone

#54  

Thank You, Merne.

I will not be back until tomorrow because I have a lot of honeydos to do. I will be back from 4-7 am CST.

My email is yhmmc<at>yahoo,dot<dot>com

#55  

@Mel, I just sent you an email talk to you tomorrow

#56  

@merne, it is possible that my wife has my schedule lined up for trips to town. I will be here early (4-7amCST) possibly. I usually work from 4 to 11, then I go eat at 11:00 am , and I am back home at 12:00 noon to do her stuff. But, I think she has plans for me before noon this time. I will send you an email and see when we can meet. Thanks for your help.

#57  

@moviemaker, I replied to your e- mail, if you call At 4 your time would be ok, if not then you would have to call me after 4PM your time. Darn work gets oin the way, but it pays the bills and all:)

#58  

I was talking about 4 AM. I am usually in my office from 4-7am to 11:00 AM. The rest of the day, my wife has me for errands and empty the trash and more.

Here is my status. I have it all hooked and it is working fine. I can control the EZB from my desktop. It is hooked to the router which is hooked to the net.

The only thing, once it is operational, I want to hook it to my desktop and save the program and then install it on my notebook. Once it is there, I want to control the notebook through Teamviewer or such from my desktop and also hook to the net. But, I want to do it all at the same time. I have done this before. But, I believe in order to do both of them at once, I need to be in Client Mode.

Correct me if I am wrong.

oh, BTW, @nomad, Thanks for trying to help me. I forgot to thank you when I thanked the others.

@merne, so, I am not in a rush. I have to wire all the other stuff up first.

PRO
Belgium
#59  

your welkom,all is fine.

#60  

Mel,

If it is hooked to the router, and you can see it from your desktop, you are already in client mode (I shipped it to you in client mode with your router credentials, so if you didn't hit the reset button, that is how it would have come up - assuming you provided the correct SSID and password).

You don't need to do anything additional except save your project to the notebook and start teamviewer. You can either move the project through file sharing on your network, with a thumb drive, or save it to EZ-Cloud from the desktop and download from EZ-Cloud on the notebook.

Alan

#61  

Gotcha. God Bless You for all of your help.

The EZB is working perfect and connecting up automatically. I think I gave it the wrong password and that is why I am not in client mode. But, I have everything but the Hbridge tested. But, I have wired them all up on the robot. So, wish me luck. I will keep you enformed. New Life is brewed into sally.

:-)

PRO
Belgium
#62  

MovieMaker

great work bolt of you.

#63  

Ok, I am very happy to announce that the EZB 4 is working fine. And, I have completely rewired Sally and I am back to where I was at the beginning.

#64  

OOOoops! I think I posted in the wrong place. Please feel free to move it.

#65  

Mel, glad it's now working for you.