EZ-Builder Release 2018.11.06.00

Download and install the latest EZ-Builder robot programming software to experience these updates.

Download EZ-Builder
Changes:

- Includes dpi scaling fix for 4k displays

- uart video support and IR from the IPS

- updated Ribbon Menu renderrer

- upgraded to latest CEF framework for blockly

- Terminal PC/EZB displays in the debug window the index of the character received

- Terminal PC/EZB only readable ascii is displayed in the log window. The debug window displays the hex received

- fixed a bug in camera where transparency trackbar cannot set to min 0

- camera control supports custom tracking types to be built as plugins (tutorial to plugin manual coming soon)
#19  
It WORKED ! :o) Wow, thank you very much !
Synthiam
#20  
You're welcome - thanks for your patience. The issue was with the CEF update. It seems there is a bug with the latest Chromium Embedded Framework. I restored the previous CEF version from nuget. It was a shot in the dark, which I guessed at with the error posted on the previous page about Blockly. Because Blockly in EZ-Builder is the only thing that uses CEF... and the CEF was the only thing changed for Blockly in this build.
#21  
Fixed... Thank you.

Is it possible that you start charging filename to version number so that it is easier for us to archive and go back to another version quickly. having same name all the time makes it difficult to roll back.
#22  
Just loaded on another PC this morning... This one throws an error from program.

Her is what it states.

Version: 2018.11.06.00

System.IO.FileNotFoundException: Could not load file or assembly 'CefSharp.Core.dll' or one of its dependencies. The specified module could not be found.
File name: 'CefSharp.Core.dll'
at EZ_Builder.Blockly.UCBlockly..ctor()
at EZ_Builder.Blockly.UCBlocklyWorkspace..ctor()
at EZ_Builder.Blockly.UCBlocklyVirtualDesktop..ctor()
at EZ_Builder.UCForms.UC.UCControls..ctor()
at EZ_Builder.FormMain..ctor()
at gu3Bi3qOx387oZM2ym.RyJ7GPdtLLwVGBSUKS.ylJiIkMZ9G()

Working fine prior.

It seems these errors this week are related to blocky. Should I just blow off the blocky install?
Synthiam
#23  
I don’t understand the question - what does blow off the Blockly install mean?

I recommend uninstall, delete ezrobot folder, reboot, and install the latest download.

The error you have received is a simple one. The file is actually missing somehow. That’s isolated to your computer and can be resolved by the steps above.
#24  
Fixed thanks. I meant was not install blocky. I saw customization and thought that was a feature. Never actually looked at it before. I guess its all or nothing.
No big deal.