Release 2013.12.18.00

Download and install the latest ARC robot programming software to experience these updates.

Download ARC
Software Information
This latest release of ARC has a pretty big change. We have upgraded to Visual Studio 2013 and a bunch of things have changed from VS 2010. Let me know if you have any installation issues...

Warning: This is a very beta installer. Only upgrade to this version if you are volunteering to help debug the installation issues

*Note: You must uninstall the previous ARC version before installing this
1) Visit Control Panel
2) select Programs and Features
3) Select ARC in the list and uninstall
4) Reboot
5) Install the latest version

Changes:

- Updated GUI with flat buttons

- Connection control has Scan and Web config buttons for EZ-B v4
#20  
I do have Visual Studio 2012 installed as well as VS 2012 Express.
#21  
@DJ Sures... It is installing, I just can not read current projects. I can make a new project and test it, but unable to save it. I have ms visual 10 install. I notice @Rich does not and all is fine with him. I can send install.log if that will help?
j
Synthiam
#22  
The installer is not installing the dependency files. I have isolated the issue - now I need to resolve it.

I'm confused of why Microsoft would have removed the Setup and Deployment feature from Visual Studio 2013. Install Shield is really buggy, bloated and has a confusing setup process. After doing some google searches, it seems there are countless number of people who are upset at Microsoft for removing that feature...

We will get through this guys!:D
#23  
@DJ Sures that is great news. I am here to install the latest, you are the man.

j
#24  
I have always (back as far as vb5) preferred MS Deployment over Installshield even when I had access to an enterprise license of Installshield. The MS tool was simple and effective. Tbe only Installshield feature I thought had any value was the ability to have it pull missing components from a local or Internet server rather than including them in my distribution package, so my packages could be smaller. But, that required Internet acess during the installation and caused problems for some of my enterprise customers, so I wound up always including the components anyway.

Alan
#25  
Cannot load my robot file after update?
I never had to agree to license before an update?
I am not sure how to go back to previous version that worked on my windows 8.1 before?
Can someone tell me how?
I shut down, but no ARC.
I had a big long error message that I could not paste here.
Are things getting too complicated?
I do not have MS Offiice on this PC.
ARC needs a recovery option.
Steve S
United Kingdom
#26  
@Steve, ARC generally works fine after an update however in this instance, as pointed out, it is very much a beta. A "recovery mode" would be pointless to be honest.

ARC is, as always, evolving. If you have a robot that works and you are happy with it and don't plan to make any changes or updates to it then don't update the software.

If you want to roll back to the last version start by uninstalling the current one
Download this version and run it.
#27  
Thank You so much Rich,
You offer great help!
I will try it.
I wanted to do the update to take advantage of faster response mentioned in the release notes.
Steve S
Synthiam
#28  
Steve, the update notes mention a warning that this version may cause issues. We're using the community to resolve the issues. You have no volunteered to help:)

I'm still actively working on a solution to find out why Install Shield won't work.

I have the merge modules all unselected, but it keeps attempting to include 64 bit merge modules even though they are all unselected. I select the 32 bit merge modules but Install Shield continues to force the 64 bit modules.

Also another bug with Install Shield is the "File Extension" is not saving the selected application.

I'm having a hard time believing that there is a world of people using Install Shield with all of these bugs i'm experiencing... *mad*
Synthiam
#29  
Now it keeps crashing when I try to change settings...

User-inserted image


Haha, it's not all fun and games building robots! When you're at the mercy of a company who doesn't make a reliable product...
#30  
So wait. do you need VB installed? I have vb 2012. Does this change anything about installing?
Synthiam
#31  
No you don't need VB installed.

This has to do with 64 bit merge modules being installed for a 32 bit application. Some of you may have the correct 32 bit merge modules from the previous installation - or another software program.
#32  
Sorry DJ,
I should have checked the latest release notes, just opened ARC and chose update. Thought I was downloading 12.16 version.
You will get things resolved, you do awesome work!
Thank you for all your work and patience.
Merry Christmas to everyone @ EZ Robot.
Steve S
Synthiam
#33  
Can someone try this...

1) uninstall all copies of ARC from your Programs and Features in the Control Panel

2) and install this: Trial1Installer.msi
#34  
@DJ Sures... Tried no go, same errors. j
United Kingdom
#38  
This one worked for me on Windows 7 64bit:)

Note: I also installed the latest version of .NET
#39  
okay, this one worked for me on Windows 8.1 64bit.

:):):):)

j