Welcome to Synthiam!

Program robots using technologies created from industry experts. EZ-Builder is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.
Get Started

Australia
Asked — Edited

How 2 Ask A Question, Answer Above Questions,When You Are Told Question Is2 Long

How can I ask a question and answer things like yes connected to wifi and blue light flashing etc when I continually get told question is too long? 
Not sure why but it let me add the question as a comment


Related Hardware EZ-Robot JD Humanoid
Related Control EZ-B v4 Info
Australia
#1   — Edited
i to the ez robot community  I am in need some help it has been a very long time since I purchased the ezb4 controller and sadly not long after, my wife's condition deteriorated badly and as such I was never able to get my 3d printed JD up and running. Fast forward a couple of years or so, and her condition has stabilised somewhat and I am now able to spend some time on JD, but have run into a problem.
I can connect to ez wifi and am able to connect on the main controller screen on laptop, with the message below
EZB 0: EZB 1: EZB 2: EZB 3: EZB 4: Windows version: Microsoft Windows NT 10.0.17134.0WELCOME TUTORIAL disabled by userScreen Resolution: 1280x800 (96x96 dpi)EZ-Builder Version: 2019.03.17.00Attempting connection on 192.168.1.1:23Connected to 192.168.1.1:23Reports EZB v4 OS With Comm 2Firmware 'EZ-B v4.x/2 Native Firmware' on 'EZ-Robot EZ-B v4.x/2' supports the following capabilities: - ADC with 12 bit Resolution - Can stream Audio v4 codec - Reports battery voltage - Reports CPU temperature - Read/Write Digital I/O Ports - Hardware UART TX/RX with DMA buffer and adjustable baud rate - I2C Master - LIPO battery protection & shutdown - PWM Duty on digital ports - PWM servos on digital ports - PWM servos on digital ports can release their position - servo speed for PWM servos on digital ports - Has NVRam configuration and can be restored to default settings - Transmit Uart TX on all digital ports - Adjustable I2C clock speed - Configurable UART TX digital port baud timing - Ultrasonic Ping distance sensor support - 12 Byte Unique Identifier - Can stream video v4 codec - Native UART Connectivity from EZ-Builder - Native WiFi Connectivity from EZ-Builder - Broadcasts to EZ-Builder's PnP network scannerEZ-B v4.x/2 Native Firmware ID: 78-54-0-0-220-255-57-56-57-37-38-38Setting battery monitor voltage: 7Setting battery protection: TrueSetting i2c rate: 100000EZ-B voltage is 7.906402398EZ-B temperature is 25.49855289310493472CConnected
As soon as I try to do any actions, zip, nadar nuffin, with the following message
Comm Err: System.IO.IOException: Unable to write data to the transport connection: An existing connection was forcibly closed by the remote host. ---> System.Net.Sockets.SocketException: An existing connection was forcibly closed by the remote host   at System.Net.Sockets.Socket.Send(Byte[] buffer, Int32 offset, Int32 size, SocketFlags socketFlags)   at System.Net.Sockets.NetworkStream.Write(Byte[] buffer, Int32 offset, Int32 size)   --- End of inner exception stack trace ---   at System.Net.Sockets.NetworkStream.Write(Byte[] buffer, Int32 offset, Int32 size)   at EZ_B.EZB.PXAOIqM9W7(Int32  , Byte[] cmdData)BbytesToExpect: 0?Z?Z?t?Z?Z?Z?Z?Z?Z?Z?Z?Z?Z?Z?Z?ZReceived: Disconnected
I have a laptop with windows 10, all connection sounds are correct, wifi symbol on right bottom corner of laptop says connected to the ezb4.....with all numbers and letters, on JD back the bottom board has blue steady light top board has blue flashing light. When I first connect the ezb4 I see a red led flash ever so briefly at top left corner of ezb4  then the blue led goes a purply colour before resuming the blue flashing colourany help will be most appreciated, but be mindful of the fact that I am an older person who takes a hell of a lot of pain medication due to an accident in 2011 and am a newbie to software so please be kind.
Portugal
#2  
Hello Bazza59, have you tryed to disable the antivirus?
Australia
#3  
yes I have disabled anivirus
Australia
#5   — Edited
I did not know I double posted as when I first tried to post I got the "question is too long" I then spent almost 1/2 hour shortening my question bit by bit and continuously kept getting the same message every time I hit the button to post my question ,  and therefore I tried posting again,and again, and shortening my post every time until finally I deleted everything I was trying to ask and then write what I did about asking question at 2 lines long, and nothing posted until I was down to those 2 lines . Even when I logged out of community and logged back in, I only saw one post by me . When that did post, I then then posted my original question as a comment and then edited my question to add the 3rd line

But I apologise for not adding the part about, my program is for JD No Eyes,  and therefore my problem cannot be the rgb animator 
So I am still in need of assistance
Tomorrow I will repost my problem and make it with a new header and the moderators of the website can delete this question
#6  
User-inserted image

User-inserted image



if your connected to your wifi,the led on the ezbv4 chould be steddy green.an easy way to connect,use a iphone,.
i am not sure if its relevant but i see some setting that include an rgb in ez builder jd no eyes.
if you dont use it maybe best to delete them.see pics. i see in the init script and in the mobile config.