Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.

Get Started
United Kingdom
Asked — Edited

Wireless Camera / Bluetooth

I've been trying to use the EZRobot wireless camera but whenever it is turned on, I lose bluetooth connection at a really low range (1-2m). With the camera off, the range is vastly increased. Is there an easy solution to this?

- Bill.

AI Support Bot
Related Content
Synthiam
Based on your post activity, we found some content that may be interesting to you. Explore these other tutorials and community conversations.
PRO
Synthiam
#1  
I don't think anyone has ever experienced that. Can you try the USB dongle in a different port?

On one of our demo setups, we have a USB Bluetooth dongle right next to the camera dongle - with no interference. You can see the demo live at events such as maker faire and comic expo.

It's very strange to hear that you're having an issue. I do not have any suggestions - other than perhaps a different USB port, or a USB Bluetooth dongle
#2  
@bill is that a internal Bluetooth on a laptop? - Josh S
United Kingdom
#3  
Thanks for the responses, guys!

@Jstarne: nope, using the Bluetooth dongle sold on the EzRobot store.

@DJ: Not having heard of this before is, in itself, helpful! Knowing that this is an oddity means there must be a specific cause.

For historical purposes, and incase it helps;

All physical structure removed. EzB, battery pack, 1 servo, ezrobot wireless camera next 15cm away.

Ezboard is the other side of the room (About 5m), I can connect and operate servo fine, without issue.

After turning the camera on, the connection to the EzB drops within a few seconds. (No dialogs show, disconnects in the same manner as if you pull the power).

Attempts to connect result in a could not connect dialogue. Tried powering off/on the ezb, still no connection. If I unpair the bluetooth, it then fails to pair (the device shows in the available devices, but pairing fails (timeout) before entering the bluetooth pin code).

Turn camera off, bluetooth pairs straight away, connection to ezb completes without problem.

(Batteries on the ezb were new and fully charged and the camera was charged fully overnight)

I repeated the same basic process with both the bluetooth and camera dongles in different ports with the same result.

---

Now, given that this isn't the first issue I've had with this bluetooth dongle (
McLinky Burger)) and that I now know this is an out-of-the-ordinary problem, I'm going to try replacing the BT dongle first. I have a laptop with bluetooth, but it has backtrack (linux) on it, so that's no good:D
#4  
If each item works individually but not at the same time the basics of troubleshooting does point a finger at your computers hardware. Are your USB 1 or USB 2.0? I know some older laptops had a very small current threshold around 100ma to 250ma where modern usb provides 500ma to 2000ma ( that's 2 amps at 5v). I would try using a powered USB hub that has a modern amperage rating and see if this resolves the issue. I'm 99 percent sure its not intereference as I can run a few together... - Josh S
United Kingdom
#5  
@jstarne: The PC is relatively new, Alienware Andromeda, quadcore 64bit. 10 USB2.0 ports running at 500ma, 4 USB3.0 ports running at 900ma each. Only two ports in use. The camera and BT dongle are in two of the USB 2 ports (One in the 4 port hub, one in the 6). All other USB devices have always worked flawlessly (Everything from joypads, mice, my wacom, webcams, peavy xport guitar interface, tablets, phones, keyboards, x52 etc etc etc).
#6  
Darn bill, I hate to see this problem. I did get a different Bluetooth that I noticed had a bit better range and cheap on eBay. Here's the pic as there is no branding...
User-inserted image

Maybe that Bluetooth happens to be finicky.
United Kingdom
#7  
It all points to the bluetooth as far as I can make out. Replace the dongle and see what happens.

Bill, where in the UK are you? I have a spare bluetooth dongle I got from farnell when I placed an order and needed to get above the minimum order value, I'll gladly send it your way (although I am useless at finding time to get to the post office so if you are close enough you could pick it up otherwise it could be a bit of a wait for the postman).
United Kingdom
#9  
Morning, folks!

Thanks to you both for your replies, too!

@jstarne: It's one of those frustrating issues, because sometimes (Close range) everything works, and I'm all like, woo 'n stuff. Then it moves a few metres away and it all goes to pot.

@Rich: Yeah, I'm leaning toward the bluetooth dongle at this stage. The camera had (Note, past tense) worked without issue, although I've now got the dreaded blue-light-wont-go-off-and-all-I-get-is-a-black-screen
Eternal-Blue-Light problem. I notice you post a solution in that thread, Rich, but do you know of one that doesn't restrict the camera to working only when the EZB is on?

Additionally, thanks for the offer of a new dongle! I've got to head to a Maplin in the next few days for some unrelated supplies, though, so I'll see if I can't snag one up while I'm there. For reference, though, I'm not far from Northampton.

Thanks again! Let's see if a new dongle will make all my gremlins go away!
United Kingdom
#10  
I believe the camera has issues when the battery is not charged but when charged it's fine, so I would suggest keeping the battery attached, giving it a good charge and then trying it. I also read that using PWM control on the camera signal can get it working but I forget the percentage that does it.
United Kingdom
#11  
Thanks, Rich. I've left it plugged in charging while I'm at work, so I'll see what happens this evening!
#12  
I have the exact same problem. 100%. However, the configuration is different. I am using my macbook with parallels with Win8. Built-in bluetooth. I know EZ-Robot clearly states no support for ARC running in virtual machine. So, I am going to try few options of powering the camera USB with the powered USB hub and/or with an external blueetooth dongle.
United Kingdom
#13  
Update:

Well, this is an odd update. As mentioned before, I ended up with a Blue-light-of-death problem. Even when fully charged (Left for 24 hours) the light wouldn't go out. I was considering getting a new camera - it's something I had considered following previous problems. Before that, though, decided to try one more thing. I popped the case open, located the + and - pins that connect the battery to the board and shorted them briefly. (I do like to live risky!). My assumption was that this would interrupt the power completely, perhaps resetting the device. It did indeed work, the light went out. A few seconds later, I powered it back up and it worked correctly.

More curiously, and I cannot fathom this one for the life of me, my interference problem was also resolved. No ports were changed, no drivers re-installed. Just this one act and I no longer suffer connection drops with the camera on. I have absolutely no idea why, but for me, this seems to have done the job.

Any takers on explaining this?

Disclaimer: I do not recommend trying this! Shorting a battery could have consequences, so don't come blaming me (Or EzB) if you let out the magic smoke!
United Kingdom
#14  
A safer way would be to disconnect the battery and reconnect it... but shorting it sounds like it works for those thrill seekers amongst us:)

Not a clue why it fixed it. I will put it down to the old "turn it off and back on again" fix that works on pretty much everything.
United Kingdom
#15  
I considered the safe option, but there was solder, wires, chickens and a giraffe called Simon, so I figured quick 'n easy was the way to go:D
#16  
In my configuration (Macbook, Parallels, Win 8 and Built-in bluetooth), I could make it run w/o disconnecting by reducing the resolution of the camera (I chose the lowest resolution in the pull-down menu).