Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.

Get Started
United Kingdom
Asked — Edited

Why Isn't My Servo Working

As the title says. It's an EZ robot micro lever servo. When I try to move it with a script or "H" or "V" servo control... Nothing.

It's not released

Ezb is connected

7.4 LiPo battery is fully charged

Ezb has been power cycled

Doesn't work on different digital ports

It's connected correctly (and always has been)

It worked up until yesterday

It's not under any strain in any way

It's been calibrated correctly (it used to work ok as mentioned above)

Other servos work on the same ports

Wires have freedom of movement

Tried a new project with just a vertical servo control

Moves freely when I turn it by hand (connected or not).

Any ideas?

United Kingdom
#2  
It's a bit difficault to get to at the moment unless I do a major disassembly of the robot. I don't want to do that just yet until all other avenues for remedies are exhausted.

Thanks anyway Patrick.
#3  
Looks like you've done as thorough a diagnostic as possible. It appears to be an electrical failure within the servo. A continuity test of the 3 leads might locate something or point to an internal issue.
#4  
@Steve G,

Did you try the old stand by for any Windows computer? Reset everything.
Close EZARC, reset the computer, re-install ARC, start your Project, re-establish the WiFi connection, finish that beer, cross your fingers, then try out the servo control.
United Kingdom
#7  
Great *eyeroll*. It's connected as seen in the photo...

User-inserted image


The head weighs about the same as a JD head so weight should not have been an issue.
PRO
Synthiam
#8  
It looks much larger, and has a metal speaker with magnet, and more plastic... visually it appears to weight more. I would assume your servo is not working because it is damaged. Easily replaceable:D Although I do recommend a larger servo. Those little guys are only good for a small amount of weight.
United Kingdom
#9  
@DJ.

I take it you havn't seen my showcase then. The speakers (with magnets), battery, some of the internal plastic, and circuitry had all been removed, and speakers placed in to the robot body (as seen in my "making of" video in the project showcase). It's just an empty lightweight plastic shell now with the exception of two LED's, two sound sensors and camera added. I only had the thing working for two weeks before this happened. It may look bigger, but I assure you it's is about the same weight as a JD head.
User-inserted image


User-inserted image
United Kingdom
#10  
I needed to use the micro servos because of space restraints so made sure of the weight as I knew that are not that powerful do using larger servos is not an option. These servos may be easily replaced, but I don't see why I should have to purchase another one when the one I have was used within its tolerance range and is faulty through no fault of my own. Besides, I'd have to pay extra due to overseas shipping on top of that.
PRO
Belgium
#11  
hi steve G

are you using longer wires to get from the ezb4 to the head?
are these wires all good.
United Kingdom
#12  
@nomad.

Thanks for the reply. It does have one extention lead which I did check and replace (just in case) so I know that's not the issue.

@Doc and @oldrobotbuilder.

Thanks for the advice. I did what you both said but unfortunatly made no difference.

@DJ.

So could this be a manafacturing issue? Like I mentioned, I havn't used it that much, but the few times I did it, was working fine.
United Kingdom
#13  
So after stripping the robot down to get to the servo and trying another to see if there were any issues, the test servo worked. I opened up the micro servo but couldn't see any visible burn marks on the PCB and all wires attached. I reassembled it to test it, but still dead.