Asked — Edited
Resolved Resolved by DJ Sures!

Unable To Install ARC

I just upgraded to Windows 10 and now upgrading Ez-robot is not possible. The software attempts to uninstall my old installation but tells me I have an invalid install package. I have attempted to download the installer in multiple locations and attempt to install in different directories to no avail. I have also attempted to remove the old installation with geekuninstaller, but there must be traces left in the registry somewhere. Any ideas would be greatly appreciated. Thanks.

Skip to comments


Upgrade to ARC Pro

Elevate your robot's capabilities to the next level with Synthiam ARC Pro, unlocking a world of possibilities in robot programming.


Stupid question but have tried a reboot of windows?... Sometimes Occum's Razor rules....


Actually I have. Also have run the antivirus to rule out simple problems.


Finally got through all those registry keys, but still cannot install. The geekuninstaller seems to have gotten everything. Any other ideas besides uninstalling Windows 10?


What errors do you receive while attempting to install?

Have you followed the instructions per the link i provided? The only way a computer knows software is installed is by the registry key in the above link. I cannot vouch for the software that you are using.

United Kingdom

Maybe try a reinstall of Windows 10. Perhaps something didn't take properly the first time around. I made the change from 8.1 on my laptop a couple of weeks ago with no trouble... so far.


Can you send a screen shot of the error message. I believe it is just a message telling you that the software is not from a trusted source and you can bypass and still install but wont know until I see the error message. I run windows 10 and have no issues.


I appreciate all the help so far. I have uninstalled windows 10. Attempted to uninstall ARC again and reinstall but its a no go. Here is a picture of the errors I get. User-inserted image

User-inserted image

User-inserted image


The last one shows that you need to uninstall the previous version of ARC, if you have it installed. Also, make sure you didn't rename the download file name, as that might be a problem.


I couldn't uninstall the normal way so I used geekuninstaller to remove all traces of the software. It still must have something somewhere but I have checked all the registries in the link posted by DJ. I feel like the only way to get this to install is to format the computer and start over.


If you can wait until morning, I have one other thing for you to try, but I need to be sitting in front of my computer to get the right commands for you, and I won't be there again tonight. (answering from my phone now).



Alan, I would happily wait till morning if it means a sliver of hope in trying to install ARC in my main system. I appreciate the effort everyone is giving me. Thanks.


looks like the file didn't download correctly. have you tried re-downloading the installation package and trying again?


i just tried again after downloading in a new location with internet explorer instead of firefox this time. Still the same message.


After I downgraded back to Windows 8.1, I was able to use Microsoft fixit to check registry keys and that fixed the problem. Thank you to everyone that helped me on this. Can't wait to build my next robot with the ARC!


Thanks DJ for all the suggestions. It led me to my answer.


I'll still post my suggestion in a little while because it might help others. Basically it is instructions on running the installer wirh elevated system privileges. I habe found that gets past a lot of strange windows errors.



The following instructions may help others having install issues. It absolutely helps if you are on a work computer and have admin rights but your group policy prevents .MSI files from installing if not called by a setup.exe - like mine:(

These instructions are for Windows 10, but the same concept works on all Windows versions, just getting to an administrative command prompt differs by OS.

Right click on the Start button and select Command Prompt (Admin) from the menu.

In the command prompt that opens, type:

msiexec /i "C:\Users<em>your windows user name\Downloads\ARC.msi"

This will run the MSI with elevated privileges allowing it to over-write files and registry entries that otherwise may be locked.

replace your windows user name with your actual windows user name.

If you didn't download ARC to the default downloads directory, change the path as needed.