Asked — Edited
Resolved Resolved by Antron007!

The Mobile App Freezes Up In A Please Wait Screen After An Apparent Bluetooth Co

I am using the app for the first time. I have a V3 board on my robot. No other Bluetooth devices are active.

My phone sees EZ-Robot Bluetooth and successfully pairs with it.

When I download my project from the cloud, tap the Connect window, select EZ-Robot Bluetooth on the WiFi/Bluetooth screen that appears, and tap the Connect button on that screen, the red LED on the V3 board stops blinking, indicating successful connection. But the phone screen freezes up on a "Please Wait" screen. If I try to get back to my project screen I get a message saying "EZ-Builder isn't responding. Do you want to close it?" The only choices are Wait and OK.

Any suggestions?


ARC Pro

Upgrade to ARC Pro

Don't limit your robot's potential – subscribe to ARC Pro and transform it into a dynamic, intelligent machine.

United Kingdom
#1  

What phone is it? Which version of Android? Is the project public? If not can you share it?

#2  

Chinese Android 4.2.2 phone. $50 on Everbuy but surprisingly good.

Robot is a voice-commanded glyph tracker. Not ready to go public yet.

PRO
Synthiam
#3  

Apparently not that good:)

#4  

Odds are it can't run the ARC app. It must be to weak(not enough ram) and therefore cant run the app. I know that my tablet froze a couple times but it wasn't bad. Make sure all other apps are closed. maybe restart it too. Then run ARC. If it still freezes try reinstalling the app.

PRO
Synthiam
#5  

You can share your app and I can take a look to see if there's something I can help with

#6  

Technopro,

Good answer, thanks! Do you know what the RAM requirement is? I only have 227MB max available. I will try your suggestions. I did try a very simple project with no luck.

Dick

#7  

Your ram requirements would depend on your project, I'd think.

You may try uninstalling and re-installing the app. Also, In the ARC PC program, load up your project and then re-save it. Then re-upload it to the cloud. Then re-download the project from within EZ Mobile. Then connect to the device. If it locks up again, hit your home button on your phone to get back to your phones home screen. Not sure about your phone but on most Android phones holding the home button will bring up your recent apps. You should be able to swipe away or remove the instance of EZ Mobile. Then load a new instance of EZ Mobile on your phone and try again.

I've have even simple projects lock up the first time I've used them in EZ Mobile. I believe it's my phone (Droid 4. It's about a year old so, it's a dinosaur now) so I never posted or complained about it but it happens pretty often. I'm not sure if it may be saving some of it in memory even though I ended the old instance and the combination of stored data and new data manage to make a complete "package" in the memory or if I just will it to work. But eventually it starts working.

If that don't work then, I got nothin':)

United Kingdom
#8  

The reason for asking if it was public was so we could load up the project and see what happens on connection and check out the project for anything that may be causing the issue. Without it there isn't a lot that can be done other than a whole lot of guess work.

#9  

By the sounds it could your device overloading. I could be wrong. Let these guys check the file to see.

#10  

To: Antron007

Thanks for a very good response. I carefully did everything you said, but the result is the same. My available RAM with everything reasonable to delete is 131MB.

To: All

I used a very simple test project: only a Modified servo Movement Panel. It's on the Cloud as "Simple Mobile App Test" in my "dicka" folder.

United Kingdom
#11  

What happened when you run the simple test project? I presume you did run it? You didn't say if you did or not hence the question.

Posting a different project really wont help us since the simple project you posted should work on any android device capable of running ARC Mobile. If even that app doesn't work for you then your android device isn't up to the job of running ARC Mobile (it should run on any android device capable of running ARC - if it doesn't then I doubt any other app will run). If it does then we really need to see the project that is causing you problems otherwise it's like taking a different car to the garage to be fixed...

#12  

dicka,

My idea is for you to try it on another phone. If it works on another phone, you have solved your issue. Steve S

#13  

Yoir simple mobile app opens fine on my HTC One M8.

Alan

#14  

Same on my Samsung Galaxy Tab 3... opens no problem...

#15  

Just to be clear, opened and connected to my EZ-B v3. Did not lock up.

Alan

United Kingdom
#16  

It shouldn't lock up on any device capable of running ARC Android, it's a very simple project. If it does lock up then the device used isn't capable of running any ARC app and the solution would be to use a more powerful Android device.

The Acer B7 is a cheap android tablet which is capable of running everything I have thrown at it so far. The older Nexus 7 has dropped in price too. That's just 2 which are more than capable.

#17  

To: Rich

Reply to your 2:54 PM post:

My response to Antron007 says that I used the simple project stated and that the results were the same; i.e. I'm still getting the "Please Wait" screen, even with an exceedingly simple project. so there is no reason at this point to be concerned about my larger project.

Will any Android phone run regular ARC as you seem to indicate?

By the way my phone came loaded with apps and so far it doesn't seem to have problems running any.

Reply to your 3:49 PM post:

It's good to know that the referenced Android tablets WILL run the ARC Mobile app.

#18  

To thetechguru and Richard R:

Thanks for the very useful feedback on your two phones. My son has a recent Galaxy. I will have to try it.

United Kingdom
#19  

I can only really speak for the Samsung S5 and HTC One X phones since they are the only ones I've used ARC with, both of which will connect fine and run the simple projects I've used with them (H-Bridge control, camera, EZ-B V4 info & a couple of small scripts).

While the tablets and phones I've mentioned will run ARC Mobile it may not necessarily run a large project which does a lot of fast calculations, pulling a lot of data and controlling a lot of accessories. The weight of your project will always be a factor in if it'll run on the phone/tablet. The more it needs to do the better the device needs to be.

If you plan to do anything more than run ARC I wouldn't advice the B7 though, I was disappointed in the tablet overall as, if running multiple apps it would struggle and also has low disk space and low memory which was a big issue for what I was using it for.

If I'm totally honest I would recommend the Acer W3 810 Windows 8.1 tablet. Other than the on-screen keyboard being less than ideal and the fact it's difficult to use without a mouse on a lot of applications (ARC not included since EZ-Robots have given us nice sized buttons) it's a really good Windows tablet which runs the full blown Windows version of ARC without issue, it'll happily run my Ping Roam scripts (which the newest unreleased version does a lot of calculations and pulls a lot of data from the Ping sensors and IR sensors).

Back to the problem you are having though, I would check that the EZ-B and phone are paired correctly and that both are well powered and close enough to each other with no interference before I ruled out the phone.

#20  

Further, I just tested it on my girlfriends Galaxy S4 phone and your app also works on it as well...

#21  

Thanks guys for all the info.

Rich:

I achieve a solid connection, according to the red LED on the V3 Bluetooth module. So I believe this proves pairing and a good signal (the robot and phone were quite close). Of course the phone setting data also show the pairing (and for my car Bluetooth as well).

#22  

What am I missing here folks? Bluetooth has nothing to do with this process of downloading an app from the EZ-Cloud to the Android device.

#23  

I personally think its the devices low quality. It must be loaded up slowing the performance of ARC.

#24  

@robot-doc

If you go back to the original post, the issue is that ARC for Android is locking up when he connects to his EZ-B v3, thus the discussion of BT pairing.

Alan

#25  

The simple project and my full robot project run OK on my son's Galaxy S3. I investigated storage and available RAM for each of the two projects loaded up. My phone seems to have plenty available. So I continue to be at a loss explaining why the Mobile app will not run on my phone.

#26  

This is the one real problem with Android vs iPhone. If you develop for iOS, you have just a few OS versions, and a very limited number of hardware models you need to develop for. With Android, you have hundreds of hardware combinations, modifications of the OS by the various carriers, custom roms from independent developers, rooted devices that may have users modifying core components, etc...

Any developer can test with the emulator, and however many devices they can afford, but there will likely be some that have a quirk that makes the software not work.

Given your symptoms, I would say it is probably something in the Bluetooth implementation, but whether it is software, and finding a custom rom for your device might fix it, or hardware is hard to say.

I don't know how involved DJ would want to get in troubleshooting for a $50 Chinese phone, but he could probably give you a debug version that captures more logging that he could analyse. Given how busy he is with Revolution release, I suspect you would need to wait a while.

Alternatively, If you are interested, I have an HTC Rezound I am not using. I'll test to make sure it works with ARC first, but if so, I could let it go for a very reasonable price. It is a Verizon LTE device, but it accepts GSM Sims and is SIM unlocked (might still be rooted too. Been a while since I powered it up), so you should be able to activate on any carrier, or you could just use it on WiFi/Bluetooth as a robot controller. Let me know if you are interested. Email address is alan at thetechguru dot net.

Alan

#27  

Alan has a good idea there. If you just want to use a phone for your ez projects you don't even need it to be activated. I have an old Droid 1 that I used to take advantage of the http server to move a project I had. I have every intention of keeping my current phone just for ez projects after my next upgrade. Assuming it will still be adequate.

Also, Alan is safe to deal with and a trustworthy guy. He has mailed me some things and I've yet to see him looking through my windows. (I got my eye out for you buddy:) )

#28  

Alan is a stand up guy... I bought an ez3 board from him a while back...:)

PRO
Canada
#29  

I've had the pleasure of meeting @thetechguru in person and can also say that he an upstanding guy!:D

#30  

At least when I am not falling down;)

Alan

#31  

TheTeechGuru,

Thanks for another nice response. I will think about your phone offer,but I don't know if I want to invest in another phone. I bought the cheap one for my wife (it does everything and more that she wants). I just thought the Mobile app was a neat capability and so I gave it a try. But honestly, I really don't need it.

#32  

Antron007

When you say you use the http server to move your projects around, I'm not sure I understand the full meaning of that. Would you care to elucidate?

I have used it to get my ARC project window on my iPad and operate my robot around my house using my WiFi network.

PRO
Synthiam
#33  

Dicka, if you want to send your phone to us, I can have a look to see if it's repairable in software - or determine if it indeed is incompatible.

The title is phrased "apparent Bluetooth"... Can you be clearer? Are you certain you are attempting the connection over Bluetooth or what is apparent about it? There is the ability to connect to EZ-B v4 over WiFi, which requires an ip address. I'm wondering if you specifying the WiFi and not Bluetooth - and that is why you are phrasing "apparent".

If you are unsure, let us know and we can walk you through how to use the connection page

#34  

DJ,

Thank you for the reply, but I don't think making a $50 Chinese phone work with the Mobile app is a good use of your valuable time. Frankly, I'm astounded that you would even offer!

My use of "apparent" means that I see Bluetooth connection achieved because the blinking red LED on the Bluetooth module goes to steady red, but the phone does not register the connection and actually just freezes up on the "Please Wait" screen.

I have no problem making other Bluetooth connections with the phone. It connects to my car Bluetooth and functions as a hands-off car phone. I also downloaded an app ("Android Meets Robots - Voice) that lets me use phone Bluetooth to voice control an Arduino Uno with the EZ-Robot Bluetooth module interfaced to the Uno. (A neat capability that works very well! Your HTTP Server Control and Mobile app are also great capabilities! )

Sooner or later I will get a good Android phone or tablet for my own use and then be able to have fun playing with your Mobile app.

PRO
Synthiam
#35  

Okay:) I offer to help everyone. I live by the rule of: when you know nothing, you know everything. Because the power of knowledge is knowing there is always something more to learn. Who knows, maybe your $50 phone exposed an issue with the connection control. Or, it's just a $50 phone:) I never decline the opportunity to learn

#36  

Thanks again DJ, but my wife doesn't want to give up her new phone (she hated the old one).

#37  

My email from EZ-Robot keeps insisting I choose one name that resolved my problem, even though the forum instructions say not to choose if problem not resolved, which it is not.

So I selected Antron007 for his nice suggestions, but I am grateful to all for your replies. Thanks for sharing.

#38  

I meant that I would log into the http server via wifii and use the modified servo Movement Panel web page provided by the host. (i think there's a couple camera views, a view desktop page and modified Movement Panel that are available links once you'ved logged into the web server.) based on what you said you've done that on your i-pad so it's the same thing just usingnthe android browser on your phone or tablet... sorry for the delayed response. Oh, and thanks for the credit.

#39  

Antron,

I tried going the WiFi route without success. In the following I have tried to define where I stand now. Please understand that this network business is all new to me, but i have been googling to gain understanding. Please correct any misunderstandings you see and feel free to make suggestions.

Presently, I need to have my ARC project window running on my computer monitor to have its HTTP server available for remote WiFi contact. Then, when I am within range of my home WiFi network, I easily pull up that screen on my iPad browser by entering my computer's local network IP address (the first one listed in the on-screen HTTP control window). However, the EZB V3 board on my robot has to have Bluetooth connection to my computer, and this means that I can't generally take my robot very far from the computer. So remote operation with my iPad is very limited.

If I had the V4 board on my robot it could connect to my computer on my WiFi network and range would improve, although my network range isn't all that good. But I could also go to a remote location WiFi with my robot and control it with my iPad. But if I wanted to use V3 Bluetooth robot connection I would have to use the Mobile app that integrates Bluetooth capability and doesn't even require ARC running on my computer prior to use.

However, at this point I'm confused about how to get computer control on WiFi with my iPad. I have tried the second IP address given in the HTTP control window with no success, using my WiFi network. I thought that address was the external IP address of my computer and would work. I tried port forwarding to open a port in my firewall for EZ-Robot, but despite carefully following instructions on setuprouter.com I can't get a port to open.

#40  

your 2nd paragraph is correct, even if you connect to the software via wifii, your bot will still need to be connected to the pc via blu tooth.

as for paragraph 3, i dont have my v4 yet but it is to my understanding that the server is on the board itself so you can take it anywhere and connect to it with whatever device you'd like.

paragraph 4, hmm, if your ipad and pc are on the same network, you shouldn't need the external ip address. it should just be 192.168.x.x where the first x is usually 1 or 0 and the 2nd will be any number between 2-254. im at work now so nothings in front of me but if you still have problems i'll see if I can walk you through it. it really was a super simple process for me so im not sure where the problem is.

#41  

In the last paragraph of my previous post I was trying to test remote WiFi operation using my home WiFi. I already knew that I could operate on my home WiFi by using my computer's address on that network (the first address in the HTTP server window. I thought that I could use the second address to demonstrate remote WiFi capability.

#42  

To use it remotly you'll need to open a port on your router to access your PC or put it into the DMZ. I have yet to test remote opperation because I have a router connected to another router connected to my ISP. The modem/router my cable company provided had poor, at best, wifi range so I had to add my old router to it so I'd get siganl on most of my property. I'm asuming you already know the ip you have from your ISP.