Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.

Get Started
Germany
Asked — Edited
Resolved Resolved by Jeremie!

Soundboard Ticking-Noise Scriptcode - Energy Pulse

Dear Synthiam Crew and Friends,

its an old problem since the beginning of EZB.

The Ticking/ Clicking-Noise from the EZB and various speaker.
you can hear the noise non stop. I dont mean a click noise at the beginnig or end of a sound!

If you turn off all sounds from the EZB-startup and network connection you can use 24 Servos and all sensors without a clicking or ticking noise in the speaker. but if you use the "EZB-Soundboard" or a Startup-Sound and one time the speaker you hear the clicking/ ticking noise the whole time. the noise is non stop.

So I want to ask for a code to get the "speaker status" from the beginning/ startup without any sound. sound conenction off.
is it possible? so I can simple use the code after a sound to terminate the clicking or ticking noise from the energy.

I say "the energy", because the clicking changes if I use different batteries or an power unit. from fast to slow, noisy to soft.

cheers
Smarty


Related Hardware EZ-Robot EZ-B v4
Related Control SoundBoard (EZB)
AI Support Bot
Related Content
Synthiam
PRO
Synthiam
#1  
That’s the rf interference from WiFi. There’s no energy being used. It was a compromise for the size constraints of the hardware design.
Germany
#2   — Edited
@DJ Sures

thanks for the fast response.

I dont mean a click noise at the beginnig or end of a sound.
I mean: After I use a speaker the noise starts. the whole time the clicking-noise is active and never stops. I can delete all sounds and the soundboard.. but the noise is active. 

but If I not use a sound on ezb but the speaker is connected to the ezb I hear nothing, never. I can make what ever I want with the robot, its noiseless.
so its beginning with the first sound and never stops. this is really the wireless lan? I can disconnect it and the pulse sound is active.
PRO
USA
#3  
@Smarty:

Quote:

so its beginning with the first sound and never stops.
To help troubleshoot... can you try the steps bellow and answer the questions: 

Q1) Do you have EZB4 v1 or EZB4 v2 (new top part) ?

Q2) You power on the EZB, EZB plays the WIFI connection message,  does the clicking-noise starts immediately after the message ?

Q3) You connect ARC to EZB, EZB plays the connected beep, you don't do (run) anything else, does the clicking-noise starts or is active ?

Q4) You disconnect ARC from EZB, does the clicking-noise starts or stops after ARC being disconnected ?
PRO
Canada
#4   — Edited
@Smarty what you are experiencing is normal. Once the DAC becomes active on the EZ-Bv4 (the first sound) the speaker starts producing sound, what you hear at first is the noise floor. As @DJ explained there was a concession made in the hardware design. Trust me when I say this, I actually spent many weeks and several hardware revisions trying to solve this. I did a ton of research, purchased and read a few books on the subject, but I still couldn't get rid of that noise. In the end, we had to accept that having an RF transmitter so close to an audio circuit was going to produce an unwanted noise floor. You may not be connected to WiFi but the RF transmitter is always transmitting and getting picked up by the audio amplifier (when it's active).

I will say this though, there are some EZ-Bv4s that all of a sudden produce much more noise than usual, that is because a magnet may have come loose from the enclosure and got stuck to the PCB under the audio amplifier.
Germany
#5  
Thank you so much @Jeremie.
Yes, that issue was for me normal the last years. my hope was: there is 2020 a code to stop that noise.
but I understand at the moment there is no chance to fix it.
today was the first time I had the sound off completely and was amazed at the quiet EZB :D.

@ptp
there is still no solution Jeremie said. but thank your for your time.
nevertheless my answers for you: 

Q1 EZB4 v2
Q2 yes immediately
Q3 yes
Q4 nope


have a good time and stay healthy
Marty
PRO
USA
#6   — Edited

Quote:

there is still no solution Jeremie said. but thank your for your time.
You should not give up so quickly. When I posted I was not aware if it was a design, software, or your setup.
Jeremie post is very helpful, he is the mastermind behind the EZB PCB, so it's very clear where the problem lies.

Fortunately most problems are not new, this problem exists in other designs, sometimes software can help, for example one of the linux sound drivers, ramps the volume to avoid the pop sounds when you start outputting the sound, and shutdowns the sound amplifier when is done. 
I was expecting to exist similar control on the EZB, to enable / shutdown the amp when the DAC output is not in use, but, like DJ said before you need to make a compromise.

Good news, we can improve and gain control over the sound amplifier please take look:


Let me know if the above solution can help you minimize your problem.

I run out of time, I can create another video demoing the EZB side, you need only a soldering iron.
Germany
#7  
Dear ptp,

thank you for the video!
I will test it in the next days. what Im not understand:
where does the cable go? from digital D23 to ? Can you show the wired connection or explain.

thanks a lot
PRO
USA
#8   — Edited
Before the "improvement" i.e. orange cable to control the amplifier:
User-inserted image


relevant area:

User-inserted image


after:
User-inserted image


I soldered the orange cable to the sound amplifier pin 1 that is connected to resistor R7 (bottom leg). 

Later I can use this cable to shutdown / enable the sound amplifier.
PRO
USA
#9  
Sound Amplifier amp datasheet:
https://www.ti.com/lit/ds/symlink/lm4902.pdf

this is the amp pinout:
User-inserted image

this is a typical application:
User-inserted image



As you can see the pin Shutdown is activated when a GND is applied to the sound amplifier Pin 1.
So applying 0 shutdowns the amplifier, 1 (3.3v) OR floating (not connected)  enables the amplifier.
Germany
#10  
@ptp

perfect. I will try it tomorrow :-)
#11   — Edited
Such an elegant solution.  

So if I'm following you, you simply just run one wire from the bottom of R7 straight to any white signal pin of a digital port. Then to shut off the amp you run a script to turn off the connected digital port?

Thanks PTP. You've done it again!
PRO
USA
#12  

Quote:

Then to shut off the amp you run a script to turn off the connected digital port?
Dave, that is correct. You pick the port:)
PRO
USA
#13  
Regarding the WIFI interference:

https://www.ispreview.co.uk/index.php/2015/04/10-top-tips-boosting-home-wi-fi-wireless-network-speeds.html

Quote:

Beacon Interval (milliseconds)

WiFi routers use these beacon signals to help keep the network synchronized and many default to 100ms. Setting a lower (e.g. 50 or 75ms) interval might help your WiFi network to hold its connection with other devices, albeit at a cost to some battery life on other devices. By contrast raising the setting above 100ms could save power but the likelihood of connectivity problems may increase.
I believe this beacon signal in a short period generates/adds up the interference.

Maybe is worth to try changing the EZB to client mode (if not already)
PRO
Canada
#14  
That's a smart solution to silence the amplifier @PTP, I like it!