Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.

Get Started
Asked — Edited

Servo Failure

Morning All

Today I upgraded to the latest software but now all my servos have stopped working. I rebooted both EZ and my laptop and rebuilt my servo controls but I get no response from any of my boards.

Has anyone encountered something similar?

Thanks,

D. Scott

PRO
Synthiam
#5  
Here's a video on connecting the servos. The darkest wire is GND - on the revolution servos, it's black. On your servos, it may be brown. The brown or black would connect to the black on the ez-b.

Hope this solves the issue:D

#6  
Sorry for the delay.

The servo connection was never broken (the same as when it was working last night). I think I'm going to delete the application and re-install.

Thanks for catching the anchor strap Nomad *eek*

D. Scott
PRO
Synthiam
#7  
Let us know what you find:)
PRO
Synthiam
#9  
@TechnoPro, there's no issues with ARC. From the image it appears the servo is connected backward.
#10  
Maybe @Mulberry changed board #s, so maybe that's why the servo isn't working? Just a guess...
PRO
Synthiam
#11  
Or, the servo is plugged in backward as the photo shows:)
#12  
@DJ, I agree it does really look like it from the pic... But he does claim he never unplugged the servo between tests..... I was thinking he may of connected from another board # than he did the night before.... ?
#13  
Part of my problem has been resolved. I was using two, 3 foot long servo cables to connect my claws to the board. I tried playing with the connections but no signal. So then I decided to try a direct connection without them and voila it worked. These were EBay purchases so lesson learned. Now I just need to find extended cables that are compatible because I need about 3 feet to accommodate my actuator arm movement.

My heavy duty servo still isn't working. I've tried turning the connector as well as different ports but nada. Could be I've damaged this one as well (3 and counting). :P

D. Scott
#15  

Quote:

My heavy duty servo still isn't working. I've tried turning the connector as well as different ports but nad


If you had it plugged in backwards, very likely the servo circuit board is fried. Most do not have diodes to protect from reverse polarity.

Alan
PRO
Belgium
#16  
alan

i did one time same fault and indeed the servo was fried.
good thing they dont cost much.better a servo then a ezbv4.
#17  
Thanks Nomad. I'll check them out. The ones I originally used had a funny insulated block mid-way down. No idea why and they worked previously. I'm notorious for blowing circuits. An expensive hobby but I'm learning.

Alan I have a growing pile of dead servos I plan on using for an art project :-)

D. Scott
#18  
In general, when servos blow, it is the circuit board but not the motor, so you might be able to re-use the motors with cheap H-bridges, or as replacement parts on the rare occasions when a motor rather than a circuit board blows out.

But yeah, I have seen my share of expensive blue magic smoke in this hobby....

Alan
PRO
Belgium
#19  
i only by here my parts.then am sure i got the wright ones,
and warenty just incase.

my first bioloid i burn 10 servo's in one download,so your not alone.
but it was also the fault off the seller,he was not annest man,
and i say this whithout saying what he really was.

i always say,the more you break the more you learn.
PRO
Synthiam
#20  
The three wire cable if servos prevents them from blowing when plugged in backwards. You'll never damage a servo by connecting it backward. The ezb also has isolation resistors on the io to prevent backward servos from damaging the ezb.:)

If the servo doesn't work, it's been used and abused. Which is quite common for custom built robots. We're always trying to lift too much weight:)
#21  
DJ, that statement contradicts real life experience. I have two blown servos and the only abuse was plugging them in wrong.
#22  
Problem resolved on the servo. I severed the wiring close to the servo, replaced it and the signal connected. I must have damaged it.

D. Scott
#24  
Nice work! Little things like that are hard to find. When trouble shooting i always start with a simple voltage or continuity check to see it the power is getting from point A to B. You would be amazed how often that this is the problem.