Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.

Get Started
Hong Kong
Asked — Edited
Resolved Resolved by JustinRatliff!

Sayezb Does Not Work With Surface Pro

Hi DJ,

I changed my platform to Microsoft surface pro recently. I don't know why the sayezb script does not work with ez-b. Even updated and re-install!

And I have already doubled checked within that forum, but I found nothing to mention about this!

Do you have any ideas be able to solve this issue?

Thanks a lot

B. Regards
Ricky Ma

#1  
Sorry! This is my mistake!

I found that the "sayezb" script was worked with AP mode.
But how to write "sayezb" script to connect ez-b in client mode?

B. Regards
Ricky Ma
#2  
Ricky, "Sayezb" will work if your EZB is connected in either mode. There is not an alternative way to script it. It sounds like your EZB may not actually be connecting in client mode.

Don't forget there are a ton of resources EZ-Robot provides in way of tutorials from the Learn section of the website. I go there often of find things I forget and to help myself trouble shoot. "The Robot Program" Wi-Fi Modes lesson discusses Client and AP modes.

Can you see if those directions helps trouble shoot your client mode connection?

Regards,
-Justin
#3  
Hi Justin,

My fault! I did not write the question clearly!

I have not connection problems. The question is that I use the AP mode to connect the product EZ-B v4 and I write the script "SayEZB ("testing")". The voice will come from the EZ-B v4's speaker.

But it doesn't work when I connected by client mode. Their is no sound from the EZ-B v4's speaker as same script!

Moreover, my robot will connect 3 x EZ-B v4. How can I do to order the script to specific EZ-B v4 to speak out?

Sorry for your misunderstanding;)

B. Regards
Ricky Ma
#4  
Hi Ricky, the additional information helps a lot.

With 3 EZB, I assume everything else works in client mode and client mode is not a problem for you.

The code "SayEZB" will by default attempt to speak out of the first or "0" device. Reviewing the Script Cheat Sheet for SayEZB I found the following for dealing with multiple EZBs in a project, Optionally, the EZB index to speak out can be added as the second parameter. This can be empty as well. The value is between 0 and 4:

Code:


#Example
SayEZB(Speaking out of second EZB, 1)


So the ,1 is what you would adjust for the specific EZB that you want.
PRO
Synthiam
#5  
Ricky, continue the conversation on this thread, not new threads. Do not create new threads on same topic. This is your final warning. Now, good luck and it’s an easy solution once you listen to the help and read the manual. have fun!
#6  
@DJ, If I'm incorrect I apologize, I thought Ricky's threads were all unique not duplicates. He started one for AIMLbot working with BING which I helped him with. This thread is related to specifically how SayEZB works when you have multiple EZBs in a project. Ricky's other thread that is gone now with the video I thought it was related to his servos aliments going wonky in all different directions and Patrick seemed to be giving him advice for that issue.
PRO
Synthiam
#8  
Duplicate threads are deleted. You don’t see them. You only see threads that have not been deleted. The topic on this conversation and remain in this thread. Have fun!
#9  
Hi all,

I made threads in these few days, as below:

Thread 1) Aimlbot Setting
> This topic was finished.

Thread 2) Sayezb Does Not Work With Surface Pro (for Technical Assistant)
> This one is my fault. I typed the wrong subject and can’t modify because it is no Subject Edit function on forum.

So, I made a new thread for Open Conversational as Sayezb does not work (Thread 3).

Thread 3) Sayezb does not work
> This one has been deleted.

Thread 4) Trouble with the program
> This one is talking about the servo goes to wrong angle. But why this one has been deleted as well?

@DJ, I apologise that I don't know that forum has terms between technical assistant and open conversational under same topic. I misunderstand that is between internal and public!

Hope @Justin and @Patrick please don’t mind, I grouped the talking function (Sayezb) and servo with program these two topics into one thread. If both are ok, I will keep continuing to discuss over there.

Actually, there is no any script program for learning for 40 years ago. I would like to make and finish my childhood dream for robot making. So I start to learn how to write script within these two years. My knowledge of this field just in basic level. Hope all experts could forgive and understand!
By the way, ez-b is great product for starters, but these two years this knowledge is going very fast and complicate. I love to learn more in person if any course at EZ-Robot in Calgary, I am willing to fly come for learning!

B. Regards
Ricky Ma
PRO
Belgium
#10  
hi ricky ma

so all comes here now?
#11  
Hi Patrick,

Yes, if you don't mind:D and thanks for your help!
PRO
Belgium
#12  
ok thats good for me.did you calibrate all servo's as in video?


#13  
Hi Justin,

Thanks for your video:)

I followed your instruction twice, but the problem is still here. Pls. see my video as below:
PRO
Belgium
#14  
no need to reboot after set all ports to 90,just save.
do not connect the wire from servo before hit the set all ports to 90.
also use connection 0,your servo is not set to 90 cause green led of ezbv is stil flikkering,so its not connected to ARC.also you need to adjust the screen resolution,to be able to see the save button.



1 connect ezb
2 go to web page
3 set all ports to 90
4connect wire
5get the wire out
6do all 18 servo's
7then save (do not reboot)
#15  
Hi Patrick,

I tried to your instruction again. I found out the problems that I used connection 0 could become normally in Client Mode (WiFi mode). But to use connection 1 in client mode, the trouble problem is appeared!

Pls. see the below pictures & video for your reference:

User-inserted image


User-inserted image



User-inserted image

PRO
Belgium
#16  
good find.indeed you calibrated on connection 1,so if you used connection 0
it will be different.best is to use connection0.
your servo is not an original ezb servo.each servo has its own adres and so on.

best for now is to set your screen resolution,so you can see the save button.
then we do all over again but with connection0
can you make screenchot from the webpage ?
#17  
Hi Patrick,

Here is the screenshot as below:
User-inserted image


User-inserted image


I will use the (connection 0) for my robot first!

Appreciated for your patience and help!

B. Regards
Ricky Ma
:D
PRO
Belgium
#18  
use for every robot another ARC and always use connection0

i wonder why the pic is shown on your web page from ezbv4

can you try this see pic.


User-inserted image
PRO
Belgium
#19  
do you have a screenchot from this button on the webpage?


User-inserted image
#20  
It is because I used client mode (multiple connection) to control my robot and it has an unique IP that is provided by wifi router.

192.168.1.1 is provided by ez-b for "AP mode" user. So, the difference of IP is between the AP Mode (single) and Client Mode (multiple) user.
PRO
Belgium
#21  
great i learn something too.we need to find the save button on the webpage.
PRO
Belgium
#24  
hi

the tablet is ? win8 or 10 ?
#27  
Hi Patrick,

Actually, I have reviewed "screen resolution" before. My screen setting is adjusted for tablet resolution. So, I think that the EZ-b webpage save button may change a little bit different between old and new version.

Anyway, thanks for your solution and help:)
PRO
Belgium
#28  
i didn find a tutorial for win10 so,i think there must be a save button always.
i see you have two buttons more on your web page.so indeed there are some,
changes between win8 and win10.


User-inserted image
#29  
@rickymahk2013... The ezb4 webserver was updated in version x/2 of the ezb4... It has more options available over the original ezb4... Nomad is incorrect... this has nothing to do with whether you are using Windows 8 or 10 or any other version of windows... Screen resolution likewise has nothing to do with what version of windows you are using...
#31  
The save buttons are inside these folders ... in places where you make changes... Click on anyone and you will see a save button...
User-inserted image
PRO
Belgium
#32  
but for saving your servo's.in diagnostics?
#33  
What servo settings do you need to save?... The webserver just controls the digital IO ports without using ARC... It just controls things like servos and digital IO to test them... there is nothing to save so that's why there is no save button...
PRO
Belgium
#34  
now i dont get it.look save button for servo's


User-inserted image
#35  
You have an old ezb. You should update the comm board to version 2.... The save button you are pointing to with the red arrow only saves the low battery warning option and nothing else... The blue arrow is pointing to controlling the servos only in real time... setting them to 90deg without using ARC that's all... just setting the servos not saving any servo info about tem... Get it now?

As I mentioned the new webserver for the ezb4 x/2 is completely different with more options...
PRO
Belgium
#37  
RR

ah yes i get it now.thanks for helping.is it possible that the problem ricky ma has,
is become he has no original ez servo's?
PRO
Belgium
#38  
am happy with the old version.
#39  
Thanks for Justin, Patrick and Richard help:)
PRO
Belgium
#40  
hows going with the robot head?