Asked — Edited

Running Into A Question With Iotiny Using Rotational Servos

I have built several Adventure Bots and have not had any issues, but when I tried to build a custom 2 WD robot using IoTiny I've run into a strange problem.

Using the same "continuous rotation servo with Wheel" set from my Adventure Bot I found that they worked for about a minute before refusing to run any more.

I thought it might be just a coincidence, so I took another working set and first tried that with a EZ-B v4 controller in a Power Shell with the same "LiPo Robot battery" (after a full recharge) that I was using on IoTiny ... and those wheels worked fine

But, when I connected the wheels back to the IoTiny, the servos worked for a little while and then stopped working!

What's worse, is that I reconnected the servos back into the Adventure Bot and NONE of then worked anymore.

Any ideas?



Upgrade to ARC Pro

Experience the transformation – subscribe to Synthiam ARC Pro and watch your robot evolve into a marvel of innovation and intelligence.


The IoTiny is a smaller ezb. There are no differences. The situation you experienced was coincidental to something ubrrlated to the IoTiny. Answer these please

how was it wired?

Was it mounted on a conductive surface?

What other devices were connected to it?

What is the weight difference of the custom robot vs adventurebot?

Where the continuous rotation servos the older discontinued plastic gear ones?


@DJ, Sorry about the slow response, as I was waiting for my 2nd IoTiny and new servos to confirm the issue

here is a pic of my testbed User-inserted image

No load on servos, IoTiny temporarily mounted on a Power Shell with 3M Command tape and using AdventureBot Bare example. The servos have metal gears. Nothing else is connected. The firmware was left as shipped as its later than the version in the current release package

The test with the 2nd IoTiny and servos had the same result... please see videos below

I tested an HDD lever arm servo and that works fine.

I could ship you the IoTinys and servos if that would help

Regards, Frank


There's no need to ship us anything. The IoTiny isn't a problem. It is a smaller ezb. It's identical in that fashion. As you can see from the videos, I use IoTiny in lots of robots.

Regarding the servos, I'm guessing power or short in the connector? The video zooms in onto the servo and loses focus of the IoTiny, so I can't see the status led.

Does the IoTiny lose connection?

Also, you state the servos no longer work at all after they're used on the IoTiny? To clarify, the servos are broken after the IoTiny?

Show us your battery and power configuration.

What's on the bottom of the IoTiny?


@Frank... I downloaded the Adventure Bot project and duplicated your setup... I had no issues with using an iOTiny... Mine worked perfectly... I even tried a second ioTiny and it also had no issues...

EDIT FYI I used a 7.4V Li-Ion battery in my test...


I think the question about your power source becomes critical for further troubleshooting. Note: the picture of your test bed which may have answered that question apparently didn't upload. It is a dead link.



Testbed picture: User-inserted image

My bet is on the power source being the problem.



What commands/controls where you using to test the 360° Servos? Were you using the Adventurebot program with the analog joystick?

Are the servos the new metal gear 360° Servos? (Just use a phillips screwdriver to remove screw on the wheel to see if the output gear is metal or plastic)

*Edit I just noticed you mentioned that they are metal gears already, sorry about that


First, I want to thank everyone for the great responses.. I'm impressed with the level of support and I'll try to answer all the questions. I know this is a very unusual problem and really can't believe it myself.

I have improved the test bed to make it clearer, just a 2*4 with the gear connected with 3M Command strips

@DJ I don't think is a problem with the power connector as I'm using the same battery and connector with the the EZB-v4 tests

The servos which worked on the V4 no longer work on the same V4 aftera test run on the IoTiny

The battery is the standard EZB battery

@Richard_R Thanks for taking the time to duplicate my setup. I am using the 7.4 Li-Po battery

@thetechguru The new videos below will show the layout

@PTP, I'm using the same power setup on the V4 and IoTiny

@Jeremie I'm just using the standard Movement Panel that is part of the AdventureBot bare example

Here all the new videos. The servos are first tested on the v4 setup, then I replace the v4 for the IoTiny and use the same battery and cable with connector

My new test bed only tests one servo at a time as I was ruining too many of them

Regards, Frank



Can you post your project.

And the actions to replicate the issue.


i really don't have a saved project. I just use AdventureBot Bare

The only action is to click forward, stop and reverse on the servo movement panel

I try this with. V4 controller and then Iotiny. Servers work until IoTiny runs them


Have you put a meter on the voltage and ground of the servo ports to check the voltage there. It sure seems like head scratcher!


I'll do some testing on this today. I'll let you know what I find.


FYI My test was with the old resin gear 360 servos... Maybe there is a difference between the old resin gear servos and the new metal gear 360 servos? Anyway, I just ordered 2 developer's kits so I will test again when I get the new 360 metal gear servos...


@JustinRatliff That was a great idea!

I connected a voltmeter to the power and ground pins on a servo port.

During my v4 tests and found the readings to be stable, but very unstable when using the IoTiny

Here are some videos showing what I experienced using same battery and cable I used with the v4

Any ideas what could be causing this?

Regards, Frank


@Frank, That is head scratcher! One more test idea, what about meter testing it under no load? Scripting wise, still send the control signals, just don't connect a servo on the port.

And then maybe try a metered test on another I/0 port, again sending control signals to the port with no servo connected.

@Jeremie, is there a check list to check the I/o tiny with a meter for proper voltagages or continuity like there is for EZbv3? EZBv3 Diagnostics If not do you think you might be able to help us come up with one?


Hey guys,

I figured it out, but I gotta run. I'll let @DJ fill you guys in!

Oh and the IoTiny Datasheet is almost complete, it's just being edited and reviewed before release. It'll definitely help with diagnostics.


My IO Tiny runs the servos with no problems. Could the tape be a problem?


@Frank... You're not crazy man... I just tested with the metal geared servos from my developer's kit I just got... Same thing happened to mine as it did to yours... Actually after running them at different speeds with the iOtiny trying to figure this out they no longer work period.. When I plug them back into the ezb4 they are dead, no worky..... I don't really care as I don't use 360 servos in my projects... My old resin 360 servos still however work fine with the iotiny and ezb4...

Anyway lets hope @Jeremie and @DJ will look into this...


It's not the IoTiny. There's a minor change in the latest revision of the continuous rotation servo pcb. It took Jeremie a loooong time to identify what was happening, and its such a rare situation for the IoTiny and these servo combination.

Contact us to warranty the continuous rotation servos.

However, in the meantime we are looking to see if there's a possible firmware solution, or if the servo pcb revision needs to be reverted.

Stay tuned.


@DJ... Thanks... I appreciate you guys efforts on stuff like this... Not to get off topic or anything. This is also the first time using the new HDD servos ... Not sure if anyone else noticed as the "no buzz feature" has been all the buzz :) lately but these new servos position so accurately as well. Way better than the old HD servos. They are very smooth indeed... Simply fantastic to say the least... :)

P.S. I broke those 360 servos and I would never use them anyway... Thanks for the warranty offer but I am good... No need... :)


@Richard_R Thanks for confirming this...

@Dj, Thanks for the great support on your products. I did ruin a few in my testing as I couldn't believe what was happening as others didn't see the issue.

I will contact warrentee support

I agree that the new HDD servos are amazing

Regards, Frank


I'm expecting two new HDD rotation servos.

DJ mentioned the possibility of reverting the servo's PCB.

Is there away to know if is the old(good) or new(pcb) before i connect them to the Iotiny ?


@ptp I know the lever arm and 180 degree servos are now HDD but I haven't seen any mention of HDD for 360 degree servos

@Jeremie mentioned that the plastic gear 360 degree servos work with IoTiny

Regards, Frank


I finally got around to testing all the servos from my HDD upgrade order, and sure enough, the 5 360 servos all died when tested with an ioTiny.


The old 360 servos all work great with the ioTiny. Not sure what the problem is, but I wouldn't try anymore new ones with the ioTiny until something is fixed.


both are fixed with latest hardware revisions. Using the old revisions together will cause this scenario. Contact Us if you used the old revision and experienced issues.




and sure enough, the 5 360 servos all died when tested with an ioTiny.
... Hind sight in all I personally I would have quit after burning up the first servo... But hey I was dumb... :P You burned 5 of them before stopping? LOL:) One has to ask what made you keep going after say the second servo gave up the ghost? LOL:D Did you run out of 360 servos to test or something? :)


I'm guessing @Alan may have been using an Adventurebot to test. That would take out 2 at a time. :(


I burned up several too in my initial testing because I couldn’t believe the results I was getting.

I just assumed I had bad parts as others were saying the didn’t have the issue

Thankfully, Jeremie confirmed the problem


I burned 4 using this setup:

User-inserted image

I had only 4 .... now i have 0 :)


Fellow Builders, we are gather here today to pay our respects to ptp’s full rotation servos and thus his robot platform. Though his platform was not with us long, it left a memorable impression on all of those who saw it because it looked cool. Indeed, many wish his servos worked even at this moment so he could finish his project and post videos!

The life of a servo at times may seem short but for ptp these servos never matured to warrenty expectations. When one servo dies, another is manufactured and perhaps even will go on sale. We must remember to keep our part stocks up, so that we may never say we have zero servos!

Please, a moment of silence for ptp’s servos.;) lol



Hind sight in all I personally I would have quit after burning up the first servo

Yeah, well. I so go big or go home :), and hindsight is always 20/20.

Was the end of a long day, and the first time in many months I have had any time to spend with my robots. Decided I should test all of the servos I got in my HDD upgrade box (SIX, Roli, and Dev Kit upgrade) before the warranty ran out. I had already rebuilt Six, and was running through the rest of the servos. First one died, and I recalled there was a problem mentioned on the forum, but didn't go look it up. Seemed to recall that it was just some of 360's, not all of them (whoops) so tested all 5, and all 5 died. They sort of worked setting the port between 90 and 180 (movement was jerky, but working) and then as soon as I went in reverse, they stopped responding.



30 years ago I was working as a bench tech fixing computers. My boss walked in and I had 5 * 20mb Hard drives on the table that were over $1000 each (st-225) I had one more plugged in and I said this hard drive is faulty. I plugged it in and it burnt out. He said, did you try another hard drive? I responded, yes all of them are faulty. Turned out the power supply had an extension cable that was wired back to front 12v on 5v rail and I had spent the past hour destroying half a dozen hard drives.

Anyway my lesson learned that day was, always test 1 at a time and if you try 1 and it burns out you don’t just keep plugging new ones in.