Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.

Get Started
Asked — Edited
Resolved Resolved by DJ Sures!

Roomba 535 Movement Panel

Hi Again

I have a roomba 535 and I hooked up my EZB v4 to it per the instructions on the website and started the EZ Builder software with the Roomba Movement Panel. I took the PS/2 wire and connected to servo wires at 3 & 7 ports mentioned in the instructions. Also, I have the EZB v4 connected to my existing Wi-fi network as a client. As I clicked on init in the roomba movement panel, nothing happened on my roomba and I am unable to move it using the controls. I checked the connections and everything seems to be connected ok. Can someone please help me diagnose this and help get my roomba working on the EZB?

Thanks!

User-inserted image

#1  
Other than making sure you wired it up correctly, did you set the Roomba control panel in settings to use the new 500 series protocol (115200 baud)? By default it is set to use with the 400 series...
#2  
Hi Richard,

Yes I checked the 115,200 baud box also in the settings. Does the other option "use old protocol" also apply in this case? I tried checking and un-checking, but nothing happened *mad*

There is a green light on my EZB v4. Just wondering when you press the init button, is there any notification that signals whether the Roomba is successfully connected to EZB? I do not hear anything when I click on the Init button.
#3  
Is it a solid green light on your ezb? If it is flashing you are not connected to ARC in which case might be your problem... The old protocol is for the old 400 series, you have the 500 series. Not sure if the roomba will indicate a connection... Hopefully Robot-Doc will chime in as he is the Roomba expert around here...
#4  
This may sound weird, but after you initialize the Roomba try clicking on clean button before using the forward, reverse, left and right directional arrows....
#5  
Thanks Richard. Its actually a solid green light on the EZB. I tried the clean button but no success! I hope Robot-Doc comes to my rescue! :)
#6  
Have you downloaded the latest version of Ez B ?
#7  
I've not had much success using the 500 series Roombas and the Pre-defined Movement Panel of ARC.

Once in a while clicking a button will generate an action but it is not consistent. I switched over to sending commands to the 500 Roomba using Serial port 0 with much better success.

If you want to keep using D0 for Roomba control you might want to consider switching to the 4XX, 4XXX, Dirt Dog, or Create robots.
#8  
@Doc... I guess if you throw your serial commands in the custom Movement Panel you would at least have a working movement panel...? This way you would have keyboard and joystick control as well....
#9  
Good idea R.R. However I'm wired up and committed to a Dirt Dog for now and quite happy with the results so far. Further tests will reveal what is really going on with the higher baud rate and TTL interface in the 500 and up series Roombas.
#10  

Quote:

I switched over to sending commands to the 500 Roomba using Serial port 0 with much better success.


@Robot-Doc - Can you please let me know how do I manually change the port in the roomba Movement Panel to the Serial Port? It shows D0 and does not allow me to change it in ARC. Would I have to create a brand new Movement Panel and if so, I would then loose the ARC. automatic buttons for clean, dock etc?


*tired*

@DJ - Appreciate your guidance on this as well.
#11  
@SarajG... You can send serial on all of the 24 ezb4 ports... If you want to send and receive you can use the UART ports... There is a black dedicated UART Port (0) on the ezb already (see the learn section for it's location) or you can send on D5 and receive on D6 (UART port 1) or (UART port 2) send on D18, receive on D19....


***Edit*** Never mind, I thought he might want use the custom Movement Panel where he can change the post designations to anything he wants...
#12  
@SarajG, presently there is no option to change the Roomba pre-defined Movement Panel port that the commands are sent over.

What can be done (I think) is to use the UARTWrite commands with the right values to perform similar actions like the present Roomba movement panel.
#13  
Richard & Robot-Doc,

Thanks for the feedback. I was just wondering if there is a tutorial on the UART Write commands I can go through to familiarize myself. I would have to modify my servo wiring cable (as in my picture on post#1) is currently on D0 and I wasn't sure how to wire it to the black UART port on the EZBv4. It would be nice to have a snapshot of the wiring diagram :)