Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.

Get Started
Asked — Edited

Robot Does Not Work

Something is wrong. when i connect ez-b to computer it gives me two ports COM3 and COM4. But on tutorial video shown COM3 and COM7.
I connect to COM3 as it is shown in video. When i try to open examples botton it does not give same window as shown in video. (picture attached) In this window i cannot open calibration example project. It just not there.
If i just go to Add-servo-modified servo Movement Panel and start to modify servos it works (sometimes) or led on ez-b and bluetooth turns of and servos start shaking. sometimes one arm goes up in the air,sometimes head while leds are off. and it goes up or down not smooth, it shaking, like moving mm by mm and i have to disconnect all servo leads from ez-b to stop them shaking. if i just reconect power it keeps shaking.
what is going on?!

#5  
If you have ever connected a Bluetooth device your computer may show completely different com ports but there are usually two only one port apart. Choose the lower of the two ports to connect.

Can you take pics of your setup and tell us about your equipment you have hooked up. I hate to hear you are having strange issues with things freaking out.
#6  
Thank you guys for your help. i will make video today or tomorrow of all proceses that going on when "this" happens. So you can see how Walle is shaking and ez-b LEDs go off
#7  
Today i tried to deleted ez-b bluetooth connection and reconnected it again. I open ez-b softwear and start adding and configuring servos. so first i do with left and right wheels. they work fine. i can control them with arrows on my pc. (but if i press arrows too fast, LEDs on ez-b go off and one of the wheel servo starts shaking. when i reconnect servos leads to ez-b and start configuration again-it works).
Then i configure vertical and horisontal servos. and they work fine too till some point. then ez-b LEDs go off and one of the arm's servo starts shaking (but i have not even configured them yet, but they are connected to ez-b board).
And how do i add arms servos? I dont see them in that section where the rest of servos controls are.


This is video where Walle is shaking:
http://www.youtube.com/watch?v=j_Ysjfx6kik&feature=youtu.be

I use Sony laptop and external bluetooth device because this pc does not have one buit in.
#8  
It could be your power supply. have you tried using batteries yet? If your P.S. is not 12 volt 5 amp, you'll have problems. No lights and slow motion leads me to believe its not getting enough power.
#9  
I have everything working first. But at some point lights go off. Ok. I will try batteries and i will post another video.
Thank you!
PRO
Synthiam
#10  
Post a pic of the voltage and amperage of the power adapter you are using please:)
#11  
I am using batteries now. So far everything is ok.
But how do i configure his left and right arms? When i go to add-servo i have auto release, auto position,auto position movement panel,horizontal servo,modified servo,modified servo movement panel,relative servos,servo speed,sound servo,vertical servo,servo summary.
I used horizontal and vertical for his head movements and modified servo Movement Panel for his wheels.
And i dont see here anything that can be configured for arms.
Please someone. I am brand new in robotics. I need help.
Thank you!
#13  
Dj Sures! I got MP3 trigger and i found some Wall-e sounds online> but i still did not find that sound when he gets upset when ball is taken away. Could you please email me that sound. It is small so it will be easy to email it. Please!
#15  
@alexbjj I'm glad the batteries are working. I'm pretty sure you just need a different power supply. I use vertical servo controls for my arms. gotta run.
#17  
OK Dj. I am watching your video about MP3 trriger when you are typing in new voice recognition command. But quality of the video is poor and since i am new in programming i cannot do anything because i dont see what you do in that video. Dont see what are you typing, is it , between words or . ?
Please!
#19  
this is crazy. i dont know what to do.
please,somebody explain what is going on? *confused*
Canada
#20  
There is a lil switch next to your head phone jack on the MP3 trigger. Switch it to USB. And see if that helps.
#21  
And i was wondering what is that switch for? thank you! I will try
Canada
#22  
Let me know if that works for you.
#23  
yes.thank you. it worked. omg,so easy things,but if you are new they are not easy at all.
thank you very much.
Canada
#24  
Anytime. In glad to help.