Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.

Get Started
Singapore
Asked — Edited
Resolved Resolved by Steve G!

Question With Build

Hi,

We built JD according to the instructions and his left side does not work except for the claw. We double checked the wiring and all seems fine. At the moment we are at a stand still to make him function.

Thanks

AI Support Bot
Related Content
Synthiam
United Kingdom
#1  
Is it the whole left side, or just an arm or a leg or one joint?
United Kingdom
#2  
You say the whole of the left side (except the claw)? Ok, here's a few thing to look at first. How are you controlling JD? Are you using the JD project within ARC, or have you set up your own ARC project?

You might want to double check that the ports that the servos are connected to are configured correctly within your servo control in ARC.

Are the servo cables connected to the EZ-B correctly (the right way around)?

What are you using to power JD? If it is a battery, is it fully charged?

I know you mentioned checking the instructions, but have you had a look at the Learn section for JD to make sure you have done everything correctly?
Singapore
#3  
Thanks. It was the way the wires were plugged in. Not obvious in the instructions but the black side of the wires was on the wrong side. All servos are now connected but JD does sit ups and head stand like he has been up all night drinking. I am using the downloaded profile that DJ built. Seems off balance and some of the actions are happening in reverse or something.
United Kingdom
#4  
If actions are not performing as programmed then you need to check the orientation of servos and calibration. Pay attention to the instructions, they show the correct orientation for the servos.

User-inserted image


If it seems off balance you need to check and recalibrate and then possibly fine tune the servo profile.

Follow all lessons for JD in the Learn section, this will tell you the correct polarity for the servo wires, how to calibrate and how to enjoy your robot.

Also, all digital ports on the EZ-B are colour coded for ease of use. The black wire from any accessory needs to connect to the black pin on the EZ-B. This is also covered on many tutorial videos and lessons.
United Kingdom
#5  
I'm glad you got the servos working now. As you're using the JD project and a servo turns in the opposite direction, it could be how the servo is fixed to another servo or EZ Bit. Simply unclip the servo that's causing the problem, turn it 180 degrees and re-clip it back in to place.

If things seem a little of balance, then like Rich mentioned you will need to fine tune the servos by calibrating them. The calibration links for JD are in the learn section but I have linked them for you below. Hopefully this will help sober JD up a bit.:P

Lever servo

Shoulder

Head

Feet

Hand/gripper
Singapore
#6  
User-inserted image


User-inserted image


Thanks for the feed back. All of the servos were fine except for one foot. Turns out you can only calibrate the plate on the servo not the servo in the foot. I attached an image. Also I tried to re-built bur the instructions in the ARC software don't let me restart the instructions, When I try to go back I get an error message as in pic attached. I can't get back to see what port each wire gets connected to.
#8  
You can't, only ez robot can... However, you can edit your post...
United Kingdom
#9  
As Richard mentioned, you cannot delete a post, only edit it. You can click edit and delete what you wrote and write something else like "I deleted this post ad it's not relevent" or whatever you like.

In regards to the foot servo, can you not remove it from the foot casing to calibrate it? I though that you may be able to incase, for example, the servo ever needs replacing.

Also, have you tried closing the project and restarting it to get rid of the error message? If not You could also start a new project and get the assembly instructions up again.
#10  
@Steve... good point... There are screws in the bottom of JD's feet for that very purpose... Besides they had to get the servo in there in the first place, right?
United Kingdom
#11  
My thoughts exactly. By the way Fry... I mean Richard, loving the new avatar :P.
Singapore
#12  
It's better but it still doesn't work properly. Thks anyway. Seems defective.
United Kingdom
#13  
@mpelletier

No problem. Just to confirm, did you manage to remove the servo from the foot and calibrate it then? The only thing I can suggest then is change the servo position values for the unaligned foot servo for its standing, walking, dancing scripts ect, so that it straightens up and does what it should.

Or if you really do think it's deffevtive, maybe use the Contact us link and file a warrenty claim for a replacement foot.