Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.

Get Started
Asked — Edited

Question Editing Frames

I get a "unhandled exception" error whenever I try to edit frames. I am using a six with claw robot. I can see all the servos in the settings but error occurs when I select any frame to edit. I can see servo positions for all legs but no claw servos. The actions I already had such as arm up/arm down still work but I can't edit or add new frames involving the claw. Tried rebooting and updating windows 8, no luck

I did recently reformat PC and fresh install of ez robot, then loaded robot from EZ cloud. I also added many actions from the regular six robot to my six with claw using import/export function and I suspect this is where the error occurred. Any suggestions?

#1  
Can you add a screen shot of the error?

Screen Shot Directions:
Pressing the Function and PrintScreen button the keyboard together will take a screen shot. You can then open Paint and paste the screen shot in, crop the image as needed (if needed) and save the image to attach it.
#3  
Nice protect is it from windows or ARC
#4  
SYMPTOMS
Some valid C code may compile correctly, and then may not run correctly. When you run the application, you may receive the following error message:
Unhandled Exception: System.InvalidProgramException:


Is this your problem
:D:D
#6  
Again saying it is a guess
#7  
I don't think it is .net issue. It does the same thing on two computers. If I load old six with claw project I can edit all servo frames normally. It is specific error related to importing all the frames from regular six project (which has a lot more movements) to six with claw. It actually works great....because doing it like this it behaves how I want. For example, movements ignore the servo arm leaving it in the position I already had it in. The problem is can never change it without reverting back to just basic frames/actions of generic six with claw project.
PRO
Synthiam
#8  
You can't import the frames from a six project because it's a different number of servos. Either modify the six project or modify the claw project. Cannot merge the two with different number of servos.
#9  
The importation itself was OK and the robot movements all work well....I can just never change it because I get the error message when I select the frame. I made it as far as trying to edit the autopositon file. I could see the frames looking for the extra servos and thought maybe I could try to add them manually....using notepad? It was all I had to work with:) At that point I realized that I was in over my head and figured it would be better to just add new frames/actions for six with claw. It is just that so much of the work was already done for the six, like the dance actions, I would hate to manually add everything for six with claw. I'm probably just getting way ahead of myself....again.
PRO
Synthiam
#10  
Nah not at all - you're on the right track. Just load the default six project and edit the auto position. Add the servos for the arm and voila:)

It'll be quite easy. Just add servos, drag them on the screen and select the ports.

If you need help, after you attempt on your own, let me know:)
#11  
Aha! I followed your advice and I was getting the same error after many times trying to import/export between projects. Finally I realized that although I added servos in the design I had not clicked the "snapshot" button. I guess I should have clicked the question mark earlier...the one that explains that that was how AutoPosition was updated, I thought it was just to update the picture. All seems to be working now, Thanks!:)