Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.

Get Started
Asked — Edited
Resolved Resolved by Rich!

Mp3 Trigger And Servos

Is there anyway to make the sparkfun mp3 trigger play WHILE a servo or servos move? It seems when I play a track and move a servo, the mp3 trigger stops and then refuses to play again for a few seconds. Another weird thing I cant seem to figure out is. The board will play fine for a couple tracks. Then suddenly refuse to play but will attempt to move another servo on the board. The light on the trigger comes on when it does this and i have to power it off to get it to work again

#1  
It's possible your not supplying the board with enough power. That can cause bugs in the ez-b. if your using the aa battery pack put new ones in and try. If it's still happening make sure the port the mp3 and the servo are on different parts of the board. Aka d14 servo, d11 mp3, just in case there's interference. Let me know.

Tech.
#2  
@Technopro Yep, tried all of that and still getting the same issue. Made sure all the batteries were charged and that they were not close together ( mp3 trigger on d2 1st servo on d8)
United Kingdom
#3  
It should work fine.

It may depend on the model of the MP3 trigger but most are Serial. How are you controlling the trigger? With the MP3 trigger control or with EZ-Script? It may be an incompatible board with the control, which looks like it works but in reality it's just luck that it shares some of the same commands.

Do you have the datasheet for the trigger? Or the model number, i.e. WIG-11029

Also, have you updated to the latest version of ARC and upgraded the EZ-B V3 firmware to the latest OS?
If it's serial, what Baud Rate is being used?
What power supply are you using? Quantity of batteries, type of batteries, voltages and capacity. Is it charged? What else is running from the batteries? What servos are they? Some servos can draw too much current which may cause the EZ-B to brown out even if you have the worlds best batteries attached.
#4  
@Rich Yes, it should but it been a huge pain in my side. I am controlling the trigger through the EZ B board. I have tried controlling it through scripting and single action commands. I still get the same results either way. The board will work a few times but as soon as I use the servo the board stops making sounds and tries to move the servo instead.

I am using the sparkfun WIG-11029. I have it on digital port d2 and the rest of my servos on d7 and up ( Just 3 MG995 servos ) on the EZ B. I also have 2 6v led lights. Also have a H bridge. All this is running of brand new Duracel AA batteries ( tested with a volt meter ). The trigger is running on the default baud rate ( 38400 ) I am running the 2nd to last firmware , havent updated yet. Running the lastest ARC and tested on Windows 8.1 and Windows 7. When testing I just have the single servo and mp3 running. No leds and not moving any other servos.
PRO
Synthiam
#6  
What size-model-type servo are you using? It sounds like a power issue for sure. What size speaker is connected to the mp3 trigger? How many batteries? Do you have a multi meter to verify the voltage?

The video you posted is set for private. You can set it for unlisted and it'll work on here:)
#7  
@DJ Sures Im using 3 http://www.servodatabase.com/servo/towerpro/mg995. The speaker is one from Omnibot either 2000 or 5401. 6 batteries. I do have a multi meter and used it to the and made sure the batteries were full and good. I do have a 12v 7ah battery but the ezb seems to get really hot using it so i have avoided it for now. Fixed the video. Going to keep at it until I figure this out
United Kingdom
#8  
3 MG995s will brown out the EZ-B. 2 MG995s were browning out Melvin with some other stuff running.

Power the servos (the Vcc) direct from the battery (if the battery is no more than 6V)
#9  
@Rich Could you point me towards a visual picture of how this would be done? I thought that might be the issue, but wasn't sure about setting up the voltage regulators and a seperate battery etc
United Kingdom
#10  
From my Melvin topic;

Quote:

A small piece of strip board (not sure if that's what it's called over that side of the pond), 0.1" spacing with a copper strip from one end to the other on each row.
I took a few servo extensions and cut the red and black from the male end, soldered these to the strip board and left the other end so the servo can plug in.
Male end plugs in to EZB to give only the signal wire.
Power board supplies both +6V and Ground to the servo (or female end)
I soldered the +6V and Ground from the 6V regulator to the strip board which gave one row +6V and the other Ground. And viola, basic break out board for 6V.


Along with a later explanation including some photos
User-inserted image


User-inserted image


User-inserted image


Quote:

Snip off the red & black from the servo extension which plugs in to the EZB.
Solder them to 2 tracks on the strip board.
Solder the 6V supply to the strip board (not shown)
Viola... 6V power distribution.
#11  
I saw this and was kinda confused. Do I need any volatge regulators, capacitors or resistors for this setup? Also im amusing I need a separate battery for the board and servos?
United Kingdom
#12  
Depends on the voltage of the battery.

I run it from a 5A 6V regulator and power two MG995s from that (3 circuits total).

If your battery is 6V (I have read MG995s can take 7.3v+ but I've not been brave enough to test it out) then you wont need a regulator.

If you run the servos from their own battery just make sure you give it a common ground (i.e. join all grounds together).

Unfortunately I have no time at the moment, I should have been in bed half an hour ago as it is. I may have time Monday if you need a better explanation however hopefully the above is clear enough. I have described what I did with Melvin in Melvin's topic, it's around page 16, 17, 18, somewhere around there anyway.
#13  
@Rich thanks for all the info you have been a huge help! You were correct, the board wasn't getting enough power. I hooked up a 6v 7a battery and had no problem getting both the board to run and the mp3 trigger to play!
#14  
I was having a similar problem with my Sparkfun MP3 trigger on my Wall-e project. All the sounds play fine, except the Wall-e dance song which would always cut off after a couple of seconds. When the trigger is not connected to the EZ-B, the dance song plays all the way through to the end. But when it is connected to the EZ-B and the dance script is started the song will cut off. After reading this thread, I flipped the switch on MP3 trigger to external power and plugged another battery back to just the MP3 trigger. Now the song plays perfectly, this was the last item on my "to-do list for this project. Thanks!
United Kingdom
#15  
Unfortunately this is a limitation on the V3 boards. They can only deal with 5A maximum and when some servos can draw over 2A start up current (MG995s for instance) the board browns out and causes issues. It's an issue that's been noted and addressed by EZ-Robots on the V4 though which is great news.

@Chrisb66, it may work better if you powered the servos externally rather than the MP3 Trigger, if you were looking to make any improvements. If it works fine as is and you are happy then why fix what isn't broken, but if you are looking to improve it in the future that's the path I would take personally.

Glad to be of help:)