Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.

Get Started
Canada
Asked — Edited

Missing String Quotes Bug

I have found a little bug that is in many of the EZ-Script Functions Examples
If i use the Examples from the list i get the following error message

Error on line 1: Missing String Quotes or Invalid Expression:

Example: ("") dont work
Example: ("") does work

The quotes that are in the Examples don't work and i cant seem to find them on my key board at all
But the ones that are on my key board do work

AI Support Bot
Related Content
Synthiam
Based on your post activity, we found some content that may be interesting to you. Explore these other tutorials and community conversations.
Canada
#1  
On my screen before I hit post
look completely different
but after I hit post they look the same :S
Canada
#3  
oh soo its the font that's doing it lol
I hate fonts some days lol
United Kingdom
#4  
I don't quite follow what you are saying doesn't work.

Which EZ-Script command are you using?

The font should be irrelevant... There are no fonts in EZ-Script...
PRO
Synthiam
#5  
I don't understand. Are you having issues copy and paste from the website?

When posting code, always wrap the code in the code tag. You can see the code tag to the right of the edit form when writing a post.
#6  
You could have hit a language key combo. The French one is ctrl and shift. try and see.

It could also be a bug in the font settings.

TRY THIS FIRST:
go to control panel.
Click language.
make sure it says "English (Canada)" or English(US). If not change it.
Canada
#7  
Its in ARC that's the problem
when I copy the examples from the list of EZ-Script Functions Examples and paste into a script they don't work it seems all the quotes are different and don't work on till I replace them.
But when I paste them into here they look the same
#8  
No,.... It's the examples you provide to illustrate how the use each command in ARC scripting.. The example's use a different font it seems... The quotes look like little 99s and 66s... My keyboard uses " which works of course... So if you copy and paste one of your examples into a script line, you get an error until you use the quotes on your keyboard... Again, no biggie either way...
Canada
#9  
Yes what @Richard R said:)
United Kingdom
#10  
Seems to work just fine for me.

As far as I know, the font is irrelevant since the EZ-Script dialogue uses plain text not formatted text. Copying and pasting simply copies and pastes the ascii characters without formatting.

Which examples are doing this? If you let me know one or two of them I can try those and double check but I just tried the

Code:

SayWait("Hello, I am a robot")
example and it worked fine.

Also, where are you copying from? The forum posts? The EZ-Script help page? The EZ-Script help within ARC?

Whatever I try I cannot replicate this error.
#11  
If I run this (copy and pasted example) it gives me a missing sting function error

Code:


$value = WaitForSpeech(30, "Yes", "No") # quotes are little 66s and 99s



... however if I change the quotes to these " (keyboard quotes) it then works..

Code:


$value = WaitForSpeech(30, "Yes", "No") # hard to see but the quotes have been changed

Canada
#12  
It was this one
Exec( EXE/Bat File, [parameters] )
that I clued into it on but seen it on others the other day that I cant remember what ones that was

The saywait was the one I did not have a problem with as I did not copy that one I typed it

I was coping the post because I seen that it was not posting it as I pasted it and was trying to see what was going on with it
#13  
ok the different quotes do not show up in my above example... If you don't believe me try it... Copy and paste the same example from the code sample in ARC script under the WaitForSpeech command... then run it...
#14  
Your example worked... Try this one Rich $value = WaitForSpeech(30, "Yes", "No")

You must copy and paste it into a script, though (do not type it)
Canada
#15  
Yes it don't show the different quotes in the posts at all and when I seen that in my first post it really confused me so I had to copy the post to see if I was loosing my mind :S lol
Canada
#16  
One thing I have learned in my many years of scripting and "trying" to teach people to script is that most will copy and paste instead of type so I can see many having problems with it and getting discouraged when the examples don't work
United Kingdom
#17  
This is the first time I've seen anyone report a problem with copying and pasting and hundreds of users have copied and pasted my ping roam script from pastebin, quite a few more direct from the forum.

Use the code tags to enclose code when posting code. Of course copying and pasting the example outside of the code tag will not work since it ends with a;) which is invalid syntax.

Again, where is the example you are copying? Is it a forum post? Is it on the EZ-Script Manual page?
United Kingdom
#19  
I wasn't aware you could even select the text in that version of the manual, I know you didn't used to be able to I guess DJ changed it.

To be honest though, you shouldn't need to copy and paste any of the examples, they will largely be useless to your project. If you want examples to use or adapt in your project check the examples folder in ARC. The EZ-Script manual is meant for reference not for copying and pasting.

Now it's clear where you are copying from it's likely DJ can solve the small bug however I wouldn't feel right without pointing out that you should always check for correct formatting when copying from anywhere. Copying from the forums can sometimes result in "SmileyFace" being inserted into code, copying from anywhere can also insert line breaks into code which should not be there but whatever you are copying from has placed in there for formatting.
Canada
#20  
You can select and copy any thing from most any where
Ctrl C
Ctrl A
Ctrl V
Works every time
Right clicks don't always work but ctrl keys do
United Kingdom
#21  
I am aware of the shortcut keys. I was saying that you couldn't select the text previously but that has changed in one of the updates.

but as previously mentioned, when copying and pasting from different environments it's wise to check for formatting differences to ensure correct syntax. When printing the EZ-Script manual to PDF (before it was available online) I noticed a lot of line breaks were present rather than word wrapping which broke some examples if you were to copy & paste.

I'm sure DJ will look in to a solution to stop the confusion over this but I must also stress that the EZ-Script reference is a reference not a group of examples to be copied. Examples are in the examples folder for all commands.
Canada
#22  
Yes I know that my point is that many users will copy them to try them before they start playing with them and if they don't work many users will get discouraged
I've seen it happen far to often and some that gave up could have been great scripters now if they did not get discouraged







One good thing about me posting on here so much is my spelling is getting a lot better:D
I did not see any red underlines in this post at all:D:D:D lol
Love it:D