Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.

Get Started
Asked — Edited

Installation Questions

The MSI for the ARC is failing. I run the installation as administrator and get this error.

Quote:

The cabinet file 'Microsoft_VC120_CRT_x86.cab' required for this installation is corrupt and cannot be used.

United Kingdom
#1  
Check you have .net framework installed.
If so, re-download it and try again.

The ARC installer works fine.
PRO
Belgium
#2  
see that it is unblocked before installing.
and dont change the name off the download.
PRO
Belgium
#4  
moviemaker thats correct.remove-reboot-download-deblock-install
#5  
@Alexs, are you downloading and installing the latest version of ARC? Are you installing this on a PC with Windows 7 or higher? Do you have the Microsoft .Net version 4.5 installed? If not you'll want to install it. If you do have it installed already I would recommend reinstalling it and trying the install of ARC again.
#6  
I repaired the .NET framework as I already had version 4.5.1 installed. Then I removed it completely and re-installed it. Then I downloaded the installer again and this time encountered a different error. I am installing on a Windows 7 64-bit Lenovo X1 Carbon.

Nomad18.08 what do you mean by unblock, did your antivirus prevent installation?
PRO
Belgium
#7  
i mean the download is blocked when you have win7.
go to the download from ARC and click right mous and see below.
avery download comes always from another pc.and carry another name.
thats why your pc blocks it.dont change any names from download.
just unblock it before installing.
User-inserted image


User-inserted image
#8  
So it's still not working. Nomad18.08 its strange, I never even knew that "blocking" existed and I have been a Windows user for many many years. I followed your advice and unblocked the download and made sure that the name was the default name "ARC Installer", mine did not have a strange name.

I am still getting errors ranging from the cabinet file error to an ixoFileCopy that was called out of sequence.

I have removed and reinstalled the .NET framework for a second time after unblocking the download. It did not help.

As of today 7/26/14 approximately 8 PM, the Windows client download link seems to be broken. When it is fixed I will re-download the program again and try once more.
PRO
Belgium
#9  
where do your pc put the downloads?
and also see previous downloads are unblocked from other program.
can you unzip it whit for excample winzip and download to c;/ make there a folder,
before doing anything els.
#10  
Nomad, I don't really understand. There is no need to unzip the download because it it just an .MSI installer file. It is not a zip file that needs to be extracted. My Windows 7 installation saves downloads to the "Downloads" directory by default. Are you saying I should save it to the C drive?
PRO
Belgium
#11  
on you c; (your name) make a new folder gif it a name so you can find it back.
after that reboot pc,this will make the folder useble .


download a new copie ARC and save in the folder you just made.
i will make a pic in a moment.
User-inserted image


User-inserted image


User-inserted image


reboot after making a new folder.averything you put in that folldergets auto your name.
#12  
Alexs, I don't want to insult him, but I think Nomad is barking up wrong tree here. I have never had ti do any of the things he is recommending to get anything to install.

Is your computer a personal computer, or do you connect to a corporate network that could be applying group policies? I have to take some extra steps to install any MSI file on my work laptop due to group policies.

If you want to set up a time that is good for you, we can set up a TeamViewer screen sharing session, give me temporary control of your PC, and I can try to determine what is wrong.

Email me at alan@thetechguru.net to set up a time. I can be free pretty much any time today (nees to go to thw hardware and grocery srore, but timing is flexible) , or after 8pm ET Monday - Wednesday this week.

Alan
PRO
Belgium
#13  
am not insulted,glad someone chimm in.love to see whats the problem.
#14  
I'd keep an eye on Alan when he's in your computer mucking around. He seems like a shady character to me. He knows way too much about this sort of thing for my comfort level. ;):P
United Kingdom
#15  
Haha, Don't go scaring the new people off Dave:)

For the record, Dave wasn't being serious and I can vouch for the safety of Alan having remote access.

I think Alan may be right with the whole group policy thing. I remember you mentioned you wanted to control a Roomba from school, is it at school you are getting this problem?
#16  
If you do give Alan the keys to your computer... make sure you delete all "those" pictures you have on there.... you know the ones I am talking about....:P
PRO
Synthiam
#17  
I wonder if there is a virus scanner running that prevents the installer from loading correctly.
PRO
Belgium
#18  
thats what i mean whit put it in a folder c: (your name).
sometimes a file cant left behind whit remove cause another program use it to.
so you can keep removing and installing,it will not work.
i learn this trick from a programmer whit my earlier robot programs.
#19  
No this is my personal network and there aren't any restrictions in place. Though I do want to control my Roomba from school to do my chores eventually, when my WiFi board arrives :). I think I'm going to take a look and see if there's something mucked up with my OS. Going to try running it on a different machine.
PRO
Belgium
#20  
you have a network problem to open ARC?