Asked — Edited
Resolved Resolved by CardboardHacker!

I Powered Up And Tried To Use The Movement Panel And Nothing Worked As Far As Th

I now have the ezb v3 connected via bluetooth. Now , I made my Movement Panel and setup for D14-D11. I hooked the red and black cable to the voltage from ex power.

I powered up and tried to use the Movement Panel and nothing worked as far as the movement panel. I have power and four wires. How should I handle this problem?


Upgrade to ARC Pro

Get access to the latest features and updates before they're released. You'll have everything that's needed to unleash your robot's potential!


NOTE: the movement script and the script to turn the ports on seems to work fine< but motor movement is missing.

I was wondering. Does the Movement Panel motors have to be on ports D0-D3? I have them on ports D14-D11. Is this my error?


Of course you can't.... what Movement Panel are you using? Are you using continous rotating servos? Or ....What kind of motors and what kind of motor controller are you using? Your help posts always lack information.... you never properly explain your problems so it's very hard to help you..... Lots more information is needed....


RR must be in his cranky place today. He is correct though. We'll need more info to help you figure this out. As far as the settings, you set them in the Movement Panel to the ports your attached to.

Tell us about your setup. Maybe you have something hooked up wrong or miss wired. Go over all your connections and settings.


OK, let me see. . .

The base is an old omnibot2000 base. It has four wires coming off of it for control. It has the two power wires which I have pulled from the expower on the ezb to operate. It was all setup and worked fine before I had a problem with the W3 and pulled everthing apart. I have the power going to expower and four wires. I have already sealed the box that the standard H-Bridge is in bringing the four wires up to the ezb. It is on my Sally robot .

So , you feel I should put them on the D0-D3 ports? I can do that if that is what you are saying.

Thank You!


Hey, DAVE! It is good to talk to you.

I am using the H-bridge movement panel 2 Amps. It is the one to the far left when you select it from the project menu.

Any more questions, let me know. Is this enough info?


OK, I had to take Sally ALL apart to find out where the problem was. I finally found I had a plug unplugged going to the power for the H-Bridge. Now, I assembled Sally and I noticed I have four wires plus power connected. One wire was loose and came unplugged. Now Sally goes in a circle. But, I am sure when I get that wire back in tightly, Sally will operate. Wish me luck!


Great! Just as I said above; the first thing to do in troubleshooting a problem is to see if you have proper power. Second is to check all connections. Then recheck a third time. ;);)

Good luck and let us know how it turns out. :)


ok I have power now. But, The directions are all screwed up.


I feel that I am close. It now goes in the general direction. My ports are"

LTA = 13 LTB = 12 RTA =11 RTB = 10

When I hit forward, it goes forward with a slight tilt to the left. When I hit reverse, it goes pretty much reverse. when I hit right, it goes pretty much right. when I hit left, it goes Left.

any ideas?

If I have made two threads on a similar subject, I am sorry. One was getting the machine to have some power to the ports. The OTHER was adjusting the ports. I felt like it was a new thread. Anyway, sorry.


LOL, Mel. Personally I don't see any problems with the other thread. It happens. Don't sweat it.

I'm not sure what you mean about it "pretty much" go in the expected direction. Could you explain what is happening? It almost sounds like the outside wheels aren't turning properly. You may have swap two more ports in the movement panel.

Sorry, this is just a guess. It's been years since I tried using a movement panel. I haven't built a wheeled robot yet and I script all my motor movements. I do remember that I needed to keep reassigning the ports till I had it right though. tired


What I mean by going in that direction sort of is that the wheels go in the general direction but veer off to the right or left slightly.

The robot was working properly before I took it apart. All of the motors where turning properly in the right directions. I have no labels on the wires or from the points I took the wires off of. so it is a guessing game. I have four wire. I know that some go on the Right and some go on the Left. I tried all sorts of settings and the ones I have above worked the best for me. Right now, I am stumped! I can't think of anything I can do to make them work better. :-(


Mel, to make the robot track straight, you'll need to make a custom Movement Panel and add a set() command to trigger the needed enable pins. You will also have to add the 2 signal wires to the enA and enB, and use a PWM command to slow or speed up the faster motor.


Thanks, Maze. That would be AMAZING! could you point me to tutorial on this?



Go to Rich's tutorial to the"Alternative wiring for a simpler method" portion.

It is very simple to wire. Simply remove the jumpers(little plastic things) on the pins behind the "In" lines(if you have them, mine didn't)

Then take 2 more jumper cables. Attach one to each of the En pins(EnA and EnB), connect the other ends to the signal pins on the ez-b. Done!

Once done that report back and I'll help you with the custom movement panel.


Thank You! I'm not sure that I have extra jumpers, but I will see.


OK, I installed the PWM Movement panel. I did not put the jumper as I have to take the robot apart. I was hoping to be able to just work with the cables. It worked before with only four wires.

here's what I have so far:

Reverse works =Perfect. Left turn works=Perfect Right turn works b=but with a wide curve using reverse added to it. Forward works= but with a wide left turn added to it.

I feel I have it halfway there.

Please don't tell me I have to disassemble.

:-) Thank You!


I wanted to say, when I adjust the panels for PWM, I only get ONE slider to work at a time. I switched ports and the other slider works. If that helps any.

Before I took Sally apart, It was working perfect without any PWM controls. No jumper changes and no extra ports and cables. Why would it change all of a sudden? There are only four wires, but there are SOOOO many combinations that you can put them.

Thanks! :-)


I'll have to wait. Sally is running hot. The EZB And the port is not seen by the computer and I burned my hand on the heat Sink.


You didn't need to touch the existing cables at all. Yes, you would have to open the robot up and access the motor controller. If you had any change it was pure luck. If you simply added a PWM control nothing should have happened.


If you did in fact touch the wires and wired it wrong, you could have been feeding 5vs into the ez-bs signal line, which is bad.


Ok, It will be Tues before I can try it again. OK, so it is take apart again. I should have left a place to access the wires. I may have burned up the port on the ezb because I can not find it anymore. If push comes to shove, I will us V4 and keep on truckin'.

Thank You SSOOOOOOOOooooooo much for your help! :-)


For the scripting, for example Forward,

Use this, and modify the speed until the faster motor is the same speed as the other.

set(d13, on)
set(d12, off)
set(d11, on)
set(d10, off)

#Change the port to the one you pluged EnA into.
Pwm(d15, 90)

#Change the port to the one you pluged EnB into.
Pwm(d16, 100)

#Change these speeds until the robot drives straight.
#Remember you want to slow down the faster motor
#which is the one on the far to the way it turns.
#I.E. It turns right, left motor is faster.


Thank You, Maze.

I have got to take a quick break. My EZB just went out and got very hot. I may have to graduate to the V4. I am sure that you gave me the right answer, so I am awarding you the credit.

Thanks for your help. I will probably make another thread if I come up with a problem. If no problems then I will post results to this thread.



@Mel Please stopping making threads of the same thing... Just use this one...


I will do my best for you. This one is ended because my second V3 went out. I found out what was happening. I had only the signal wire plugged into the digital ports. The plastic was sticking out. It bent the +5vdc line onto ground. I had a little trouble plugging it in because my printed case was not completely straight on the place you plugged in. (all my fault)

I am sure that I can use this info obtained. I will start a new thread on the V4. It will be almost from scratch put back together. See you there.