Asked
Resolved Resolved by EzAng!

I/O Ports Not Responding To The ARC UI Servo Control

I have an ezb v4 that has been on the shelf for several years. (worked when last used). I was on the shelf too so we are both a little dusty so bare with me. When I set up an I/O port in ARC for a servo there is no signal present on the signal pins. I have a scope on them. If i go to the diagnostics page of the ezb's web server and hit the "center all servos" button the pins come to life. I think its something simple but ...?


Related Hardware EZ-B v4
Related Control Horizontal Servo

ARC Pro

Upgrade to ARC Pro

ARC Pro is your gateway to a community of like-minded robot enthusiasts and professionals, all united by a passion for advanced robot programming.

PRO
USA
#1  

First, Did you download the latest software?

#2  

I have tried ARC beta on a older machine running 7 and the latest ARC on a win 10 machine both behaved the same.

PRO
USA
#3   — Edited

both behaved the same?

make sure your anti virus is off or turned down  to connect

ARC / ARC will not connect with the anti virus

#4   — Edited

Yeah they both act the same. And they both can communicate with the ezb just fine. The camera works on both as well. I disabled defender firewall rules on the win 10 machine...no joy!

PRO
USA
#5   — Edited

So, if I got you straight, they both can communicate with the ezb 4 just fine. The camera works on both as well.

just the servos don't connect?

Is the polarity correct when you plug in a servo to a port? like ports D0 to D23

ground - brown / blk vcc - red signal - orange / yellow

or

check this: https://synthiam.com/Community/Questions/EZ-B-v4-servo-issue-18090

or

https://synthiam.com/Community/Questions/Camera-works-but-no-servo-movement-18213

Camera Works But No servo Movement

We assembled the jd robot exactly as in the instructions, including servo alignment. When we turn it on, the camera works but there is no servo twitch. No actions from the app are executed. How can we figure out what is wrong?

please let me know if any of this helps thanks

#6  

I can plug the servo in and power up the unit and the servo will "twitch" it is not one of the new digital servos. When the servo didn't work, i broke out the o-scope and tried several i/Os and none of them showed any pulses until i went into the diagnostic page on ezb,s web server page and clicked on the button that says "Center All Servos" at that point I get the pulses on the scope that i would expect. If nobody knows what is wrong, my next try will be a script directly into the command line.

PRO
USA
#7   — Edited

none of those linkes helped?

then Sounds like a question for DJ when he shows up again

good luck

#8  

I really appreciate your time. Thankyou!

PRO
USA
#9  

from on of DJ posts

  1. Did you disable the low voltage monitor? I'm guessing you must have because the "My battery is low" on 6v would have been annoying And the servos won't move at all with power below the threshold

  2. What servos are you using at 6v? Depending on the servo, it might not be able to accept 6v and it's behaving strangely

  3. Do you have a volt meter to ensure the voltage coming from the power supply is indeed 6v? If not, you can add the EZ-B Info control to see. Check here: https://synthiam.com/Software/Manual/EZ-B-v4-Info-16059

PRO
USA
#10   — Edited

What servos are you using?

You can connect to the WIFI right?

if not re set the network on the ezb4 unit

connect to the ezb network on your WIFI settings

make sure your battery is charged

I am trying all things, lol

#11  

I'm using a bench supply running 7.4 volts . The servos are tower hobby... i think mg 995? generic at any rate.

PRO
Synthiam
#12   — Edited

Hey Steve - we can get you up and running ...

  1. do you hear a startup chime when power is applied to the ezb?

  2. do you hear a welcome message when the ezb is reset with the reset button?

  3. do you hear the connection chime when ARC connects to the ezb?

  4. did you select the port using the configuration button on the servo control that matches where the servo is connected?

  5. did you set min and max values of the servo control in the configuration screen?

#13  

Yes to questions 1, 3, 4 and 5. I didn't pay attention when I reset it. I can try that tomorrow. If i access the web server diagnostics page I can play all of the chimes and messages there.

PRO
Synthiam
#14   — Edited

Okay - next questions

  1. Are you connecting to the ezb on the index #0?

  2. does the ezb repeat my battery is low

#15   — Edited

Yes, I just have the one ezb. No its not giving me a low battery message.

#17  

Thanks DJ My bench supply is a variable voltage/current unit . The ezb was drawing a little over 300 milliamps.  I will dig into this tomorrow.

PRO
USA
#18  

Here we are another day,

what was the latest on your situation?

#19  

I will generate a diagnostic log for Mr. Sures today. I've got some "honey dos" to get done first...before I can play:D

PRO
USA
#20  

I understand that

#22  

From bad to worse... I reset the EZB and then put it back in client mode. Then I re-downloaded and reinstalled ARC. Now when I choose connect, I get a single chime and then the disconnect chimes. The debug window show the following;

at System.Net.Sockets.NetworkStream.Read(Byte[] buffer, Int32 offset, Int32 size) --- End of inner exception stack trace --- at System.Net.Sockets.NetworkStream.Read(Byte[] buffer, Int32 offset, Int32 size) at EZ_B.EZB.jESW1h4BHX(Int32 , Byte[] cmdData) 2020/02/07 11:53:56 -08:00 - BbytesToExpect: 1 2020/02/07 11:53:56 -08:00 - U Received: 0 2020/02/07 11:53:56 -08:00 - Disconnected 2020/02/07 11:53:56 -08:00 - Connection Failed: System.Exception: Controller Not Responding at EZ_B.EZB.zJtWXYC09V() at EZ_B.EZB.Connect(String hostname, Int32 baudRate) 2020/02/07 11:53:56 -08:00 - Disconnected

#23  

Got it! You (Ezang) were right on with your comment about antivirus. I added exceptions to my antivirus and to my firewall but that wasn't good enough. I completely uninstalled the dumb thing and we have controls!

PRO
USA
#24   — Edited

Congratulations!

I knew it, thanks I could help

Ant virus was always my problem

all the best!

#25  

At work we always blame the the firewall group...now who do i blame?:( Thanks again to both you and DJ

PRO
USA
#26  

You are welcome

One last thing: remember, when ever you re-boot your computer, the fire-wall - anti virus will "reload again" - you will need to shut it off again

be well!

EzAng