Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.

Get Started
Asked — Edited
Resolved Resolved by Dunning-Kruger!

Help Getting Started With Ez Robot Jd

Hey All,

Just got my EZ Robot JD! I am not a robots expert - actually bought the JD to do a review of it for our viewers on our YouTube Channel. Need a little help...

Watched the videos, but some things don't match up. Trying to power it, but video shows battery pack and I have AC Adapter. So, I think I plugged it in the best way I could - see the photo. Red and Green light go on the balance charger. Left it for a few hours. Unplugged balance charger, flipped switch on and nothing.

Video says a light will come on and play a sound. Also says a WiFi network should appear on PC. None of that happens. Really seems like no power to the unit at all.

Anyway to test if the unit has any power?
Is there really a light on the body when you power it up? I don't see one
Should the Red and Green light ever go off when charging? Mine doesn't
Should initial charge take more than 2 hours?

Would love some help so I could get started.

Thanks in advanced!




User-inserted image

AI Support Bot
Related Content
Synthiam
Based on your post activity, we found some content that may be interesting to you. Explore these other tutorials and community conversations.
#3  
Hey,

Thanks so much for the quick replies...

DJ - if more coming soon, happy to wait to do the review. For now just want to make sure I can get the robot up and running.

Answered most of my questions, just a few follow-ups...

1. Is there a light or sound on the power pack that should go on when you turn it on? As I think I have been charging it correctly, just looking for an easy way to see if it is working.

2. How long does it take to charge the battery?

If the answer to Question 1 is no - then I will follow the instructions to assemble the robot and test him that way.

Thanks again.
#4  
When charging the battery there will be 2 lights on while charging. When it is finished charging only one light will be on.

When you flip the switch after the battery is charged on the robot, you will hear "Welcome to EZ-robot revolution" with some other stuff that is kind of important. You will see a light go on on the EZ-B which is where all of the cables will plug into from the servos.

It takes about 1.3 hours to charge the battery from dead to full charge.
#5  
Hey D.Cochran,

Thanks for the info. Unfortunately think I have a problem with my power pack. I have had it plugged in for hours - both red and green lights stay on. The green charge light never goes off. After a few hours, have tried unplugging the charger and turning it on - nothing happens. No lights, no sounds, no Wi-Fi network.

Any ideas how to test if it is the battery?

Thanks for all the help.
#6  
without removing it from the body, I dont know. Is the charger (blue part) getting warm?
United Kingdom
#7  
If you have a multimeter you can check the voltage on the balance plug of the battery. Positive probe on one side, negative probe on the other (nothing on the middle pin) and it should give you a voltage of something over 7v (hopefully).

If you don't mind spending a few $ you could always pick up one of these, plug it in the balance port on the JD and it should tell you the voltage of the batteries cells.


Additionally, when you switch the switch on the EZ-B itself should make some noise, a light should come on on it and it should welcome you to the EZ-Robot Revolution. It's unlikely but the speaker may have become disconnected on the EZ-B, if you get no sounds you can try and test the voltage across a VCC and Ground Pin on the top (red and black pins down the side), look in the small gap by it and check it is a digital port (it'll say D0 or D1 or something up to D24), it should give a voltage of over 7v.

I know my Six battery seemed to take forever to charge, the green light never went out until I switched Six on while charging. Not sure why this was but it's worked flawlessly ever since.

There are other things we can also check too but start with the above and we will take it from there:)
#8  
I think @Rich has something here... I have a few so called "smart chargers" that once in a while will fail to switch to trickle charging mode once the battery is fully charged.... Disconnecting and unplugging the charger seems to fix it (a reboot or recalibration in a sense I guess)....
#9  
Hey Guys,

Thanks for the tips, still can't get it to power on. Here is where we are at...

1. Have left the powerpack charging for 7 hours straight. Green and Red Light stay on.
2. Have tried plugging and unplugging AC Adapter.
3. Tried shorter charges of 1-2 hours
4. Have tried multiple outlets in my home
5. Have used a pin to click the reset on the EV4.
6. Tried wearing my lucky socks and kissing a leprechaun

Still no luck. Flick the power on, no light, no sounds.

I then opened the powerpack to make sure a cable had not come lose in shipping, see attached photo. All looks fine.

Once upon a time had a voltmeter...for the life of me can't find it now. If I can get my hands on one, will test to see if any power in the battery.

Unless anyone has other ideas, I am thinking I have either...
A. A Bad Battery
B. A Bad EV4 Controller pack

Thanks,
Dan


User-inserted image
#10  
What do the lights on the charge do when you unplug the battery? Do the green and red leds remain on? Yep, next step is a voltmeter to test the battery.....
#11  
Hey Richard R,

When I plug the balance charger into the wall, the red light goes on. When I hook up the battery pack, the red and green light go on...and stay on forever. If I disconnect the battery pack, the green light goes off and red light stays on.

The fact that the green light goes on has me believing some connection is being made to the battery pack - right?

Will try to dig up a voltmeter

Thanks.
PRO
Synthiam
#12  
Have you turned the ezb on yet?

Maybe the battery was fully charged and it just needs to charge a battery first to learn? The micros in those things are pretty smart - but again, we haven't had a report of a damaged charger yet. And we have been using them for over a year.

There's always the chance of a manufacture defect in your case. Would you like a replacement? If so, quite the URL to this thread and contact us.
#13  
Hey DJ,

Sorry not sure I understand this...

"Have you turned the ezb on yet?"

This is what I am trying to do. Have the EZ-B4 plugged into the power pack, flip the power switch and nothing happens.

Would love to get it working, but at this point not sure what needs to be replaced. Seems it could be -

1. AC Adapter
2. Balance Charger
3. Power Pack (chest of my humanoid)
4. EZ-B4 Controller.

1 and 2 seem unlikely as lights on balance charger go on. To me toss up between 3 and 4. So what would you replace...or do you just replace the whole thing?

Thanks!
#14  
Do you have a generic 7 - 16v power supply from something else lying around the house? If it has the same barrel end plug and the centre pin is positive then you can use it to at least test the ezb4... Also check the 20amp main fuse in the ezb to see if it isn't blown....
#15  
Ok, I don't see a barrel jack socket on your JD, so the generic power supply idea probably won't work... Find a way to test the battery and see if the fuse isn't blown....
#16  
Hi,

Did buy a voltmeter. Power out of Balance Charger is 8.4 volts - so charger seems to be working.

Testing power on EVB4 and nothing. Then opened power pack, disconnected the battery and tested the power coming off the battery directly - nothing. So, seems like battery is defective. I guess could be some scenario where the charger is bad, but since it is putting out 8.4 volts, I guess it is working.

At this point would seem like the best course of action is to contact support and get a replacement. Bummed the robot is not working, was very excited when I got the box...but looks like I will have to wait longer.

One other piece of info in case anyone else has this problem. A really weird smell when I opened the box. Can't describe it...just weird. Maybe that was the sign that the battery had gone bad?

Thanks for the input and ideas.
PRO
Synthiam
#17  
That does sound like the batter - sorry to hear that. Contact Us and quote this thread URL and we'll get one out to you right away.
#18  
Hey,

I keep getting emails I should change the status of my question if it was resolved. So, did contact support and they say they will send a new battery. Have not gotten the battery yet...really hope it does not have to ship from China! Will the battery resolve the problem? Don't know - but I hope so.

So, should I mark this resolved because I contacted Customer Service or wait until I get the battery and see if that fixes the problem?

Sorry, just let me know the right protocol and I will update accordingly.

Thanks.
#19  
@DadDoes... Yes, if resolved then respond and select the person who helped you the most... It will put the thread to bed so to speak...
#20  
Hey Richard R,

Sorry to be so dense, clearly someone switched my coffee for decaf this morning...

Wait until I get the battery, see if it works and then marked resolved? Or mark resolved now?

Thanks.
#21  
I know what you mean... Had to skip my coffee this morning because of a stupid blood test... Couldn't have coffee in my veins to screw up the test now could we...:P

Whenever you want to mark the thread closed is up to you... now or later when you get the battery is fine.... Just let us know (as we're a curious bunch) if the new battery solved your problem...
#22  
Thanks all - got a new battery today and all is working. So issue was a bad battery.