Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.

Get Started
Asked — Edited
Resolved Resolved by Steve G!

H-Bridges Stop Working After Ez Updated

Afternoon All

I just upgraded to the latest EZ software and now all of my H-Bridges no longer work. None of the ports or settings were changed and I've checked and current no longer flows to the motors (12 volt) when direction is activated. This has happened before when I've updated. My ultimate solution was to disconnect everything and rebuild. I really hate to do this each time.

Has anyone encountered this and if so what were you solutions?

Thanks,

Daniel

AI Support Bot
Related Content
Synthiam
Based on your post activity, we found some content that may be interesting to you. Explore these other tutorials and community conversations.
#1  
It wasn't the update that caused the problem.... When was the last time you worked on your project? Have you checked the battery to see if it is charged? Assuming you are using batteries that is.... Fuses, wiring etc....
#2  
This is a life size B9 robot and these controls are for his waist and radar movement. The motors are 12 volt Dewerts (I'm running two EZ since I'm not up to speed on coding). All fuses check out and I read current flowing into the H-Bridges but nothing coming out when I activate the controls. The odd thing is this has happened to both systems but the servos that control my claws and bubble lifter are fine.

Daniel
#3  
I'll rephrase my comment.... There would have been no software changes in the new update that would account for your H-bridges to stop working.... If it were true then a boat load of Roli's would also not be working....

Re download and re install ARC... reboot and then reload your project... Still, my guess it is a connection or power problem since you have had these type of issues a few times previously....
United Kingdom
#4  
Do you h-bridges have the LED indicators on them to show the logic? If so, are they illuminating correctly?

No current flow to motors is usually caused by the EnA and EnB pins not receiving a signal (PWM/On/High).

Check the power supply to the H-Bridge(s) and confirm correct voltages
If used, check the +5v to the H-Bridge is receiving 5v or if using the on board regulator check the button is pushed.
Check both EnA and EnB are being set to high before trying any movement logic.
Check In1, In2, In3 and In4 are correctly receiving logic (easily test this with an LED between In1 and Ground, In2 and Ground etc. it should illuminate when set to high).
Check the motors are connected to Out1, Out2, Out3 and Out4
Check voltages at the Out terminals to eliminate any wiring faults.
#5  
Sorry. I should have been more specific. I'm running multiple EZs in my build but I'll discuss the simplest one.

I'm running one 12 volt motor with a Pololu H-bridge (I'm not using the ones sold by EZ because of the heavy load so no LEDs) on a single EZ board in my leg section. I used an H-Bridge control with built-in PWM. I'm pretty confident the Pololu is wired correctly because it worked earlier.

I'm betting I somehow screwed up my port settings although I can't imagine how. I'm attaching an image.

Daniel

User-inserted image
#6  
Your port layout looks screwed up. On a regular h-bridge i use 2 different logic pins on ezb to control right/left motor directions and use 2 logic pins for pwm for e na and en b . are you using custom movement panels ? On your left trigger ports you have the same logic pins d1 for left trigger a and left trigger b. This will not allow motor direction to be set...
United Kingdom
#7  
I'm using a non EZ-Robot motor controller/H-Bridge and have had no trouble with the new update.

If your sure you didn't change any settings, it might be worth trying something which is not too hard to do. Start a new project and import all of your controls/scripts ect from your existing project in to the new one. I had an issue with something not working correctly with something a while back (not H-Bridge related), and it did the trick. Like I say, it's worth giving it a shot and you have nothing to lose by doing so. Or open a new project, confirm your wiring is correct and there are no lose connections, and just add what you need to test the motors and H-Bridges. As has been said though, the update should not have effected anything like what your currently facing.

Also, did you try an ARC re-instal that Richard suggested?

And I agree with rb550f that something doesn't look quite right with the setup. Also curious why you have left and right channels if you're only using one motor.

EDIT:

One last thing to check. You say you use multiple v4's in your B9 build. If you haven't done so already, check to make sure all the boards are connected and make sure one is not disconnecting for some reason.
#8  
Thanks for the response:

I'm not using custom code but totally relying on the EZ controls (I'm a newbie so coding is in the future).

Haven't tried a re-install. I'd like to save that as a last resort because I have other components set up and running successfully.

So that choice of a two motor H-Bridge controller was a fluke. I happen to choose that one when I first set up the system. Ironically I was able to get it working with the help of other board members. I did try setting up the standard H-Bridge with independent PWM but was never able to figure out the appropriate port settings.

I'm now thinking rather than try and fix this perhaps I should start from scratch on this motor control and go with the regular H-Bridge controller. Taking that approach:

If my wiring of the Polulu H-Bridge should be valid given it worked before.
And if my connections on the EZ board are appropriate (in the image attached).

What should my port settings be?






What port settings


User-inserted image
United Kingdom
#9  
If your project is saved, either to your computers hard drive or the cloud, reinstalling ARC is not much different to updating it. With a fresh instal, you can then load your saved project with all of your settings still in place. Saving it to the cloud, doing a reinstall, then opening the project from the cloud, you can then save it back in to your project folder.

As for the wiring, as you are only using one motor in your example mentioned above, I'd say use ports D0, D1 for triggers and D2 for PWM on either the left or right triggers and PWM (maybe someone could confirm that), as you don't need to use both left and right triggers and PWM's to control one motor (left triggers for left motor, right triggers for right motor).

And make sure you are using board 0 for your H-Bridge movement panel, as it won't work on another board (shouldn't be a problem though as you said you didn't change anything). Go brought all of the suggestions one by one to eliminate possible causes, and report back with what you have tried and with what results.

Can I ask, what model pololu H-Bridge are you using?
United Kingdom
#10  
Your port settings most definitely look wrong. You should be using a different digital port for each trigger and PWM. Both PWMs can use the same digital port (or no digital port if PWM isn't required) but triggers and PWMs shouldn't be sharing the same digital port.
#11  
That is correct.You can use 1 or 2 two motors with h-bridge..You could use D0 (right trigger) for motor #1 forward direction,D1(right trigger) for reverse direction and D2 for pwm for motor #1 . Use D3 (left trigger)for for motor #2 forward direction,D4 (left trigger)for reverse and D5 for pwm for motor#2 . Of course you can use any digital ports you need. You can use 1 or two motors as needed.
#12  
Hi Daniel, Sorry I'm late to this question.

I was using this combination before I switched over to Sabertooth/Kangaroo and it worked great for me.

If your still considering replacing the Pololu H-Bridge with the standard one sold by EZ Robot I think that would be a mistake. While the one sold here is good the Pololu is much more robust. If I remember correctly the Pololu your using is protected from fly back voltage and will handle the higher amp load your waist motor is puling. Could you let me know again what model H-Bridge you have and what waist motor your using? Is it a single motor h-bridge or double? Are you sure there are no LED's to show you have a direction signal? I know there are a couple Pololu models that don't have them.

If all you did was upgrade your ARC software there should be no reason why the motor controller you were using shouldn't keep working. Did you change anything else, add anything or move any wiring or connections around? Please, before you start taking everything apart and rebuilding:

Triple check all your connections and trace out all your wiring to see they go to the proper places or haven't come loose or disconnected or broken somehow.

Use your multi meter and Make sure you have continuity from contention to connection on each wire.

Make sure you have a common ground between the EZB controller and the H-Bridge.

Make sure all your ports you have your enable pins on the H-Bridge attached to on the EZB correspond to the ports you have set in the controls or scripts in ARC.

Make sure you set a PWM speed in ARC for the port you want to enable on the H-Bridge before you enable it. Without a PWM speed set the H-Bridge will think you want zero speed and not send the proper voltage pulse to the motor.

Use your volt meter to monitor the voltages to make sure your getting the proper voltages where they should be. Disconnect the motor from the H-bridge and measure voltage on the motor output to see if you have voltage there when you enable PWM Speed and the movement command. This voltage is measured between the output pin and ground and will vary depending on the PWM speed setting you choose. Then measure for voltage (between this pin and ground) on the enable pin on the H-Bridge to see if your even getting a signal from the EZB. You should get somewhere above 3 vdc or 5 vdc depending on the version EZB your using. If nothing there measure the voltage on the EZB digital port your connected to when you send a command. All this will tell you if you are getting the signals to the proper places.

Please keep me posted on your progress. If possable post some good pics of your connections, wiring and a link to your ARC project.

Good luck. *cool*
#13  
Thanks everyone. Looks like its been resolved. I tossed the H-Bridge control with PWM and just did the regular one using Steve's recommendation on which ports to use. Worked fine. That previous control was a nightmare. I suppose I chose it first and just continued to wrestle with it. :P

Again I appreciate all the help. Someday this behemoth will come to life.

D. Scott