Asked — Edited

Ezb Firmware Update Failure Help

ok all was working fine with ARC until i decided to upgrade to 12 26 version. down loaded ok then tried to run firmware update program. failure program reported io exception and no com ports are visable in pull down. ARC has no problem displaying corect com port just firmware utility. bluetooth device com port is correct. help as i am locked out now since my pc is one version newer then control pcb.


ARC Pro

Upgrade to ARC Pro

Unlock the true power of automation and robotics by becoming a proud subscriber of Synthiam ARC Pro.

PRO
Synthiam
#1  

Reboot your computer. Sounds like a windows related issue.

#2  

Rebooting the computer does not help. I have attached the error message and the image of the file directory. Please help as I am still locked out from using EZB. The PC has the latest software, but the controller is one verison behind. I do not know how to go back to the old verison or solve this problem. PLEASE HELP!

User-inserted image

#3  

I dont know if this will help but this is what I would try. -Uninstall EZ-B software.

-Run windows update and make sure any optional .net stuff is downloaded. (restart if necessary)

-Install EZ-B

-Make sure bluetooth is recognizing and connects to EZ-B

-Run firmware update

:/ You probably already tried that.

GL

-Troy

PRO
Synthiam
#4  

That error message says you have 2011.12.05.00 and not the most current version. Something has confused your windows installation. I agree with Glick in that you will need to uninstall - reboot - reinstall

I can't explain why. If I could, I would have written windows, and it would be much more reliable :)

#5  

Success! Back building robots! I had to manually clean the registry then reload EZB Thanks for tips

#6  

hi i have the problem that I can not update firmware I've uninstalled the builder with cc clean cleans up the registry rebooted pc builder reinstalled but still the same problem

after 4 hours still updating ..... see picture what is the problem I do not understand it help

User-inserted image

#7  

ARC says firmware version 12 stress

User-inserted image

#8  

bluetooth reinstalled and now works! confused but Sharp IR Radar not working? mad

PRO
Synthiam
#9  

@mitchmen, we are not responsible for the bluetooth configuration of your computer. Do not be upset at us for your computer. You re-installed bluetooth and it works - be happy, not angry.

Second, if the sharp IR does not work, is it connected correctly? Is the EZ-B being disconnected from the computer? Are you receiving an error?

You will need to take a deep breath and provide more information so we can help you.

#10  

with the v12 firmware, the IR radar worked very well for me. after the Firmware update v15.2 no functional

again a bluetooth error?

Sharp Collision works very good Sharp IR Radar looks bad confused

User-inserted image

User-inserted image

I'll try later with my old laptop order to exclude errors

have a nice day eyeroll

PRO
Synthiam
#11  

Does it work on another ADC port? I tested it just now and works great. Maybe your ADC port is damaged from a short?

United Kingdom
#12  

Hi Mitchmen14

Not a good idea to grip the EZB with the Robot Arm (as your pic shows) on the Bluetooth reciever it has delicate electronics and you may have damaged it??

#13  

The last time I got a reading like that it was a bad connector. When checking the voltage with a VOM it read low. Changed it out and tadaa!

#14  

okay so on the laptop I get the same results and I have the plug replaced I tested ADC 0-4 and 7, but unfortunately without success Perhaps the sensor is defective thanks for the help User-inserted image

User-inserted image

PRO
Synthiam
#15  

@mitchmen14 when you disconnect the sensor, and add a regular ADC control, do you see any values change while you touch your finger lightly on the Signal line of the ADC header on the EZ-B?

Also, putting a jumper between Signal and +5 on the ADC should show you a value. That will test your port to see if it is functional

#16  

and I noticed something the ARC can not save projects on the pc I then tested the cloud and got an error (picture) I tried again to save a project on the pc and it worked crazy thing

save to the cloud does not work (on my pc) normal save works again I'm just happy that I can save again and hope it may help

User-inserted image

PRO
Synthiam
#17  

@mitchmen14 i wonder if there is an issue with encoding from your language. can you post your EZB file here?

PRO
Synthiam
#18  

@mitchmen14 I just looked at your cloud db files. The files were saved with an old version of ARC, just like the message states. You will have to upgrade to the latest version. Delete your old cloud files and you'll be fine going forward.

Now that EZ-Cloud is stable, you will no longer run into this problem again.

United Kingdom
#19  

if you look at the sharp sensor when powered by the EZ-B with a camera phone not an Iphone 4S you should see a bright blue light it will show if the transmit part of the sensor is working. It is visible on a 4S but faint much brighter on a Iphone 4 interestingly User-inserted image

#20  

The sensor seems to work User-inserted image

User-inserted image

samsung galaxy s2 camera

#21  

cloud still does not load I'm going to reinstall Ez_Builder thanks for the help I'll try around a bit

User-inserted image

User-inserted image servo.EZB

PRO
Synthiam
#22  

@mitchmen14 Using a camera is not a way to check the sensor. It will only check 1/2 of the sensor. The sensor has two parts, a emitter and receive. The emitter you can check with a camera, but that is only 1/2 of it's functionality. The only way to check the receiver is by connecting it to an EZ-B. If it does not display data, then the receiver does not work.

You can check the ADC port of the EZ-B by following my earlier suggestions.

As for the EZ-Cloud. Again, you will have to delete your existing files that are on the cloud. They are from the older version.

#23  

So no idea but I give up the whole story cost me too much time

the only thing I still like to try is downgrade to the old firmware and builder can you send me pls the old version v12 by email? if it is possible sry for the many problems

blush

User-inserted image

#24  

EZ Firmware 15.8 not Working!!!

  1. i reinstall bluetooth and ARC
  2. check for windows update
  3. I have tested it on three different pc
  4. I've given it to a friend in the hope that he has more luck

same problem............

I would love to build something with the ezboard I now have at least one year and could do anything with it

the thing just makes problems! I have four Arduino and work great

User-inserted image

#25  

mitchmen14,

Hey, Buddy!  I came over from  the Arduino Platform too. It is an Easy system to work with.

At times, things can be frustrating for us all , but we have to Hang in there. If you don't give up hope and keep a positive attitude , things will get better. Remember, this field is in the pioneer stage and we are ALL Pioneers. Robots haven't moved as quickly as we had hoped. But, people like D.J. is making it much easier compared to what it used to be. I have been building robots since 1975 and the field is getting better very slowly.

We all value our time and when we have to waste it, it hurts. But, don't give up and it will be all worth it in the long run. Just be patient. The other day, I felt like D.J. was singling me out and not answering my question. But, I found out that he DOES care. His whole crew is at the Maker Fair expanding their customer base and learning new things to share with us. Usually, he has Very fast service.

Best of Luck!

MovieMaker

#26  

User-inserted image

now i have firmware version 25,5 confused