Asked — Edited
Resolved Resolved by Rich!

Ez-B V4 Firmware Error

So I've got my EZ-B v4. It works in AP mode and connects to my network in Client mode. So far so good. When I scan in ARC , the EZ-B gets located, but it disconnects and requires a firmware update. No problem I thought.

When I get into the firmware update I see that it will only connect to the EZ-B in AP mode, so I reset the EZ-B to be in AP mode and I connect in the firmware, but I get an error. (screen shot below)

User-inserted image

I thought I would rule out an issue with my laptop so I installed ARC on my son's laptop and tried all of the above actions and got the same error.

I hope I'm just missing something and it's an easy fix.

@DJ I have attached a zip of the logs just in case they are needed.

Skip to comments


Upgrade to ARC Pro

With Synthiam ARC Pro, you're not just programming a robot; you're shaping the future of automation, one innovative idea at a time.

United Kingdom

Is there a firmware update for the V4?

I haven't needed to update mine. I just updated to the latest ARC and connected again without needing to update firmware...


EZB 0: 28/05/2014 06:58 PM - TCP Server stopped
28/05/2014 06:58 PM - Attempting connection on
28/05/2014 06:58 PM - Connected to
28/05/2014 06:58 PM - EZ-B reports EZ-B v4 OS
28/05/2014 06:58 PM - Welcome to EZ-B v4 Beta!
28/05/2014 06:58 PM - EZ-B v4 ID: 30-50-0-0-204-255-56-56-57-38-38-39
28/05/2014 06:58 PM - Connected
28/05/2014 06:58 PM - Setting battery monitor voltage: 6.6
28/05/2014 06:58 PM - Setting battery protection: True
28/05/2014 06:58 PM - Setting i2c rate: 100000

EZB 1: 28/05/2014 06:58 PM - TCP Server stopped

EZB 2: 28/05/2014 06:58 PM - TCP Server stopped

EZB 3: 28/05/2014 06:58 PM - TCP Server stopped

EZB 4: 28/05/2014 06:58 PM - TCP Server stopped


When I try to connect to my EZ-B v4 I get this error.

User-inserted image

And there are times where it doesn't give this error but the debug states the following-

EZB 0: EZB 1: EZB 2: EZB 3: EZB 4: 2014-05-28 2:03 PM - TCP Server stopped 2014-05-28 2:03 PM - TCP Server stopped 2014-05-28 2:03 PM - TCP Server stopped 2014-05-28 2:03 PM - TCP Server stopped 2014-05-28 2:03 PM - TCP Server stopped 2014-05-28 2:03 PM - Attempting connection on 2014-05-28 2:03 PM - *Warning: There is 10 bytes of unexpected data available on the TCP connection... Clearing 2014-05-28 2:03 PM - Unexpected Data: 27 91 50 74 27 91 49 59 49 102 2014-05-28 2:03 PM - Connected to 2014-05-28 2:03 PM - EZ-B reports EZ-Robot OS v25.5 2014-05-28 2:03 PM - Welcome to EZ-B v3! 2014-05-28 2:03 PM - Connected 2014-05-28 2:04 PM - *Warning: There is 74 bytes of unexpected data available on the TCP connection... Clearing 2014-05-28 2:04 PM - Unexpected Data: 251 1 255 251 3 255 253 3 87 101 108 99 111 109 101 46 32 84 121 112 101 32 60 114 101 116 117 114 110 62 44 32 101 110 116 101 114 32 112 97 115 115 119 111 114 100 32 97 116 32 35 32 112 114 111 109 112 116 13 10 255 251 1 255 251 3 255 253 3 7 13 10 35 32 2014-05-28 2:04 PM - Comm Err: System.IO.IOException: Unable to read data from the transport connection: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond. ---> System.Net.Sockets.SocketException: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond at System.Net.Sockets.Socket.Receive(Byte[] buffer, Int32 offset, Int32 size, SocketFlags socketFlags) at System.Net.Sockets.NetworkStream.Read(Byte[] buffer, Int32 offset, Int32 size) --- End of inner exception stack trace --- at System.Net.Sockets.NetworkStream.Read(Byte[] buffer, Int32 offset, Int32 size) at System.IO.Stream.ReadByte() at EZ_B.EZB.(Int32 , Byte[] ) 2014-05-28 2:04 PM - BbytesToExpect: 1 2014-05-28 2:04 PM - U Received: 2014-05-28 2:04 PM - Disconnected 2014-05-28 2:04 PM - Disconnected 2014-05-28 2:04 PM - Disconnected

Hope this helps with the diagnosis. confused

United Kingdom

It looks like the connection is the issue, that's based on the part about unexpected data on the TCP, and the fact it thinks it's a V3 running an OS that doesn't exist.

Does it do that on every device (PC, laptop, windows tablet) you have tried to connect with?


On my sons laptop I didn't look too closely at the debug, but got the same "firmware" upgrade error. I'll do a quick test again on his to see what the debug says.


Got a firmware error and a similar debug report on his also.

EZB 0: EZB 1: EZB 2: EZB 3: EZB 4: 2014-05-28 2:17 PM - TCP Server stopped 2014-05-28 2:17 PM - TCP Server stopped 2014-05-28 2:17 PM - TCP Server stopped 2014-05-28 2:17 PM - TCP Server stopped 2014-05-28 2:17 PM - TCP Server stopped 2014-05-28 2:18 PM - Attempting connection on 2014-05-28 2:18 PM - *Warning: There is 19 bytes of unexpected data available on the TCP connection... Clearing 2014-05-28 2:18 PM - Unexpected Data: 27 91 50 74 27 91 49 59 49 102 255 251 1 255 251 3 255 253 3 2014-05-28 2:18 PM - Connected to 2014-05-28 2:18 PM - EZ-B reports EZ-Robot OS v8.7 2014-05-28 2:18 PM - Welcome to EZ-B v3! 2014-05-28 2:18 PM - Connection Failed: System.Exception: Invalid EZ-Robot OS Version. Please Upgrade. EZ-B Reports v8.7. This copy of ARC requires v16.6

Would you like to view the help tutorial with instructions on how to upgrade the EZ-Robot OS? at EZ_B.EZB.Connect(String hostname, Int32 baudRate) 2014-05-28 2:18 PM - Disconnected

I think your right that ARC thinks it's connecting to a v3.

United Kingdom

Is this just in client mode or does it do it in AP mode too?

Just trying to think of what else DJ & co may need to know to solve this one.


You are not connecting to an EZ-B v4 on your network.

There is no EZ-B v4 firmware update. As the release notes say, it is for the V3 only:

The ip address you are connecting to is not an EZ-B v4

If you scan the network, you will find that there will be another device accidently answering with the same message as a v4. This is something we can't control. Because we do not own every network device ever made, other devices will occasionally respond with a similar connection string.

You can see that your images and copy and paste text have different ip addresses. For example, in one image you are connecting to and the text is

If you are connecting in AP Mode the ip address is and never changes.

If you are connecting in client mode, you must find the proper ip address for the ez-b v4. Use the scan tool to find it. You can watch this video to help:


AP mode works. I got v4 info working, v4 audio. I haven't done too much more since I need to make some regulators to run servos and sensors.

I was even running in AP mode along with an network cable plugged in so I still had an internet connection.


When I scan in ARC the only address that it picks up is (on both my laptop and my son's). I even unplugged the wireless blue ray player and turned the WiFi off on my phone. So right now there are only three wireless devices running on my network, my laptop, my son's and the EZ-B v4 (green light is flashing).

United Kingdom

Put the URL in to your web browser (or click here). What comes up?

When I use the scan tool it also picks up my router. I assume the scan tool scans for a specific open port or something similar which other devices may also have, therefore making it seem like it's found an EZ-B V4 when the reality is it hasn't.

The device on the IP address not being an EZ-B didn't cross my mind however I have just double checked what DJ has said and can confirm that when I use my router IP it gives the same error message and info about a firmware upgrade.


Oh Brother, my printer that is. blush My wired printer is the only IP ARC is picking up in the scan. I shut it (printer) down an re-scanned. Nothing.... I reset EZ-B to IP mode and went into the setup page and reconnected the EZ-B to my network with the printer off. EZ-B connected to my network, but scan is not detecting it. confused


Ha, your printer! That's too funny. I just sat down to see if I can find a way to prevent the ARC Scan from finding other devices. I have an idea - and the test was successful. The scanner used to detect our audio amplifier at the office. The new scanner no longer detects it.

I think we have success.

United Kingdom

Does your router list wireless clients connected to it?

User-inserted image

It may be an issue similar to what Dave is battling with in as much that the DHCP server of your router isn't correctly assigning the EZ-B with an IP. This can be due to many things.

Most commonly it is the MAC filtering. Make sure that if it is enabled that your EZ-B is in the allow list.

The EZ-B will think it's connected to a network if your router assigns a 169.x.x.x IP address due to router settings (and even sometimes poor routers - my brothers does this if more than a handful of devices are connected on the WiFi)


There are some similarities between your and my problems. One of my EZB's will say it's connected to my network but a scan will not show it's IP address (other times it will). It will however show up in my routers Client list (other times it wont). It's like the router is screwing with me and only acknowledging the other EZB's when it wants to.

However ARC will always connect to the first EZB and I've never gotten that firmware update message.

I've moved my router within a few feet of my EZB's exploring signal strength as a possible cause and still had the problem. I have no idea what's happening here. I've got a new router arriving tomorrow. I'll see if that helps.

Also In my router my MAC Filter is off along with my firewall trying to eliminate any possible problems, Didn't help.

@DJ said in a previous post that he had success keeping his EZB from connecting to outer devices. Not sure what he meant or what that means to us. confused


@Dave, I think he was talking about the devices the wifi scanner in ARC will recognize. I know certain companies own ranges of MAC IDs. I can't remember the numbers but for example, all D-Link Routers will have a MAC that starts with the same first few digits. Maybe they googled a bunch and make an exclusion list. Or maybe, they added some type of signature to the EZB V4s broadcast that EZBuild will recognize.

I think ARC v2014.05.29.00 may be on it's way and hopefully DJ will add some of the details to the Release Notes.:)

United Kingdom

@Dave, ARC's scanner will look for specific things when scanning the range of IPs. Currently what it looks for can be found on other devices (my router, Steve's printer, DJs audio amplifier), what DJ is saying is that he has found a way of stopping those false detections.

What it means to us? Less confusion like Steve originally had in this topic.


Ya, I kinda thought this may be one of the things that might be happening to me. I've been spinning my wheels trying to keep two EZB v4's able to connect to ARC for more than a few hours after power off for a week now. I think I have several things in play here. Low signal strength, flaky router and a buggy ARC scanner. eyeroll


Sorry I dropped off for a bit. I buggered up my internet while kicking around the router settings.(I had to post this with my phone) I had to take care of other things, so did not get a chance to look into it again. I'll have to get back at it tomorrow after my son's soccer.

Thanks everyone for the help and suggestions.

@Rich - my router sees the EZ-B but it does not want to show me an IP for it, it just had it as static. The only way to know what device was the EZ-B was to toggle the EZ-B on and off to see what MAC address changed. Like I said there was no IP shown for the EZ-B, or at least not anywhere in the router software that I could find with my little networking knowledge.


Got to love hearing a chime when your scanning because the EZ-B got detected!:D

As I was messing with my old router (yes now it's old apparently (just under 3yrs)) I found out D-Link discontinued it. confused

So... I was able to convince my loving wife to let me get a new router. Thanks for the help on that Dave. I had my wife (since she was out) pick up the ASUS RT-AC66U.:D

Hooked it up and got everything going in a flash.

Once again, thanks to everyone who assisted with this but the I have to give the credit to.... This is hard. Now I know why everyone has trouble with this. Since Rich stuck it out and kept directing me in where to look, I give it to him.


:D forgot to select the resolver. blush This is my first time doing this.

Thanks Everyone.

United Kingdom

Excellent news and thanks for the credit there:) 9 more and I hit 200 which isn't bad going:D

Just on the router side of things, my recommendation will always be a router which is capable of running DD-WRT firmware (the most awesomest of firmwares out there IMO). I know all Buffalo routers come with this as standard now but it can be put on many others.

DD WRT homepage

Supported Devices

The Asus RT-AC66U is on the list too. A very worthwhile upgrade in my opinion but probably not for the feint of heart.


Hey Steve good news indeed.... Who do you use for internet if you don't mind me asking? I have Rogers and they supplied my router/modem.... in which they call an all in one.... I used to have a cable modem and a clink I bought.... I guess I can assume with My new setup I wouldn't be able to swap out my router with the Asus one without getting a separate cable modem.... It has been a while since I actually bought one so I may be clueless, but are all routers all in one (modem too) now?

United Kingdom

My modem/router was an all in one but can be changed to "Modem mode" which allows the use of a different modem (and increased performance!).

You'd have to check the settings of the "all in one" for an option to enable "modem mode" (or words to that effect) to be sure.

You can get routers with cable modems built in, my ISP needs to enable the MAC address for it to work but that's a simple process. It's usually down to the ISP for that requirement though, some don't care.


Thanks Rich... I don't currently have any issues with my current setup and my V4s. However it's nice to know what my options are if I should run into issues down the road....


@RichardR - I use Cogeco (cable). It is the only cable choice I have in my City. I have their cable modem then my router connects to. When I was looking into my issue at work yesterday, I thought I saw that they offer modem/routers, I didn't really pay attention to that because I like to have the ability to change things up if I want, not when they want. Kind of what I just had, if I needed a new router I would have had to wait for them.