Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.

Get Started
Asked — Edited
Resolved Resolved by CochranRobotics!

Ez-B Drops Frequently Out Of The Wifi

Hey guys, this is short and simple....just wanted to know if this is a common problem when running the EZ-B on lower voltage!

I am running my EZ-B on 6Volts and I experienced that it gets disconnected from my Wifi network at random times! It tries to reconnect, says it succeeded and drops out right after. This happens for a while, then it is establishing its connection and it stays connected!

So is it because the EZ-B is running on lower Voltage, it is only the Wifi connection which gets lost...there is no brown out, and also it happens while the robot is not moving at all, I am just working on parts and the EZ-B is sitting on the table not doing anything!

Or could it be that there is some interference from the Power Supply, it sits on the table right next to the EZ-B?

Any ideas?;)

AI Support Bot
Related Content
Synthiam
#1  
I also have a similar problem, but it is still related to a battery problem. My ez-b would lock and wifi would be dropped but it would quickly recover. I was running a battery with 2 high amperage motors on it and it failed to provide enough power to the ez-b. Mine sounds more like a brownout though.
#2  
How far is your access point from the robot? Is there a microwave between the robot and the router?

I have never been a wifi fan due to it having flaky issues and a lot of things can interfere. I would start by trying to elementary wifi issues as being a concern first and then start looking at the EZ B. If the access point is close to your ezb, reboot the access point and see if you then keep having issues.
#3  
Yeah, did all that....router is pretty close and the only thing which could cause interference would be the Power Supply, pretty unlikely though right?

I reset the EZ-B, let's see if the problem is persistent!

Just wanted to check if there are any know issues!
Thanks for chipping in your thoughts on this!:)
#4  
No problem. Wifi can be a pain. I have run on 5 volts without any issue with Wifi though. I don't think it is a power issue for you.

If your smart phone is on your wifi (assuming you have it with you when working with JD) and it is also using wifi, it would be interesting to look at the signal on the smartphone when this happens. I wonder if it drops in signal strength for a few seconds when this happens. The smart phone isnt going to be as visible to any wifi issues because it will just fail over to the provider network, but it does show signal strength at some interval. It would at least help to eliminate wifi as being the issue.

Good luck and I hope this helps some.
PRO
USA
#5  
@Mickey666Maus

I'm having the same issues, EZB alone (no servos) and random disconnects, I'll try different power supplies, if you have a chance try a power supply with more than 7.5v, something like 9V/1A do not connect servos otherwise you fry one by mistake.

I'm trying to understand if the power supply (voltage) can affect the wifi performance, so far i tried 7/2A, 5/10A same issues.

@CochranRobotics

Did you get success with 5v ?

I have the EZ-B connected to 5V/10A power supply, the EZB works but the camera didn't come up neither the EZ-B HD servo respond to commands, can't be a problem of Amps

I had idea that 5V could drive the servo and electronics (camera).

All:
Anyone knows if is safe to connect 12V/5A to an EZB (no servos)?
#6  
No issue on using 12V with the EZB. I have run 12V without any issue and the spec sheet shows up to 18V i think.

On the board that I am running at 5V/10A I dont see this issue. I dont run a camera from this board nor do I run any servos. I am only running a 4-n-1 sensor. It is being powered by a Castle 5V/10A BEC that is converting from 12V to 5V.
#7  
Good to hear I am not the only one having issues....I will keep the post open for a little bit just in case someone still has a contribution!

Btw this forum is awesome...thanks for response time is beyond lightspeed!
Thanks everyone!:)
#8  
I am surprised the camera isn't working at 5v. I am not surprised that 7.4v servos don't work at 5v. You can usually (while risking shortened lifespan) run 5v servos at 7.4, but I would not expect the opposite.

As mentioned in the power supplies tutorial and numerous threads, not all power supplies are created equal. Just because it can deliver 10amps steady, doesn't mean it can handle servo inrush current.

Instead of boosting up the amps on the supply, you can try the super cap mod which can bridge the gap for short brownouts: Post 15 of this thread has the super cap mod instructions: http://www.ez-robot.com/Community/Forum/Thread?threadId=8686&page=2

Alan
#9  
The bec has a cap on the 5v side which may be why I don't see any issues with my setup.
PRO
USA
#10  
@Alan,

That idea reminds me this one:

http://www.hobbyking.com/hobbyking/store/__17100__Turnigy_Voltage_Protector_783333uf_3sec_.html

Can be interesting add on for the JD when doing complicated moves (more servos working at same time)

The power supply is a good product:

https://www.adafruit.com/products/658

I've used for a few setups (multiple leds) and raspberry pi & a lot of usb devices connected.

I need to test the EZ camera again with 5V/10A, it's very strange because the camera gets 3.3v from the EZB, so if the EZB can work with 5V i don't understand why the camera does not work, must be my mistake.
PRO
USA
#11  
@Alan,

Just re-checked, the camera works with 5v , it was a software issue, the camera object recognition crashed (null reference) and the camera stops because is too fast i got the wrong idea.

but servos they start holding the position, but 1 second later they stop holding the position.
PRO
Synthiam
#12  
If the camera crashes with null reference, that means it went away. either the wifi disconnected or the camera stopped transmitting.

If you believe this is wifi related, check the faq which is located in the learn section.

If you're browning out due to using incorrect power supplies - there's dozens of threads pointing to correct suggestions.
#13  
Hey guys, closing this one...thanks for the help!
The issues are still remaining, I will if I can get something solved I will let you guys know. Thanks for being with me on this one!:)
#14  
Hey, just a little update on this topic...
@DJSures just told me there is some info and help covering Wifi connection problems in the FAQ section of the EZ-B documentation!

I will try a different setup soon and will give you guys an update if I manage to solve the problem!:)
#15  
I checked my router and the Wifi channel was cluttered with Networks, I just changed the channel and I guess this should solve the problem...lets see!;)
#16  
By the way did changing the channel help with your disconnect issue? Listening to the posts and knowing you were running lower voltage my first guess would have been voltage drop causing the issue. Unless you are running a lithium based battery which handles high current draw you will always have around 2 volts drop when current is drawn around 1C or higher.