Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.

Get Started
Canada
Asked — Edited
Resolved Resolved by CochranRobotics!

Error Message

I am getting the following error message;

9/9/2014 9:42 PM - Sound servo Error: Object is currently in use elsewhere.

What does it mean and what do I need to do to solve the problem.

PRO
Synthiam
#5  
Auto position does not use the audio device. It would be a other control.

With windows, sometimes different manufacturer drivers behave strangely.

Sadly there isn't much we can do to change the behavior of your hardware and respective drivers.

Try removing the speech recognition and using the sound servo.
#6  
I was under the impression that he was having issues using the sound servo. My assumption was that the same digital output was being used in the auto positioning control as an added servo. My bad. Didn't even think about it being the sound card that was in use.
#7  
I shut down the Speech Recognition control and I don't get the error message anymore. It didn't make any difference to the performance of the Sound servo - still not working very well. So how should I configure my project so that I can give Voice commands and have a servo running the mouth of my robot?
PRO
Synthiam
#8  
1) Why are you using the SoundBoard (PC) control if you have an EZ-B v4? I recommend using the SoundBoard (EZB). Please press the ? (question mark) buttons on controls to read how they work and what they are. There is a message when you load ARC instructing/reminding you of this feature.

2) If you still insist on using the SoundBoard (PC) control, you will need to upgrade your hardware. As we have identified earlier in this conversation, your audio driver and hardware is not able to allow two devices to use it at the same time. That is quite rare for audio hardware to not allow more than one device to use it at the same time. Your computer simply does not have that capability that majority of other computers have.

Hope that helps
#9  
I wasn't using a Soundboard I was using the Speech Recognition control. I'm not trying to play WAV or MP3 files - just text in a command.
I'm new here and I do read the ? for each control, look at the examples and watch the videos. If I don't understand something or can't get something to work, I post the question on this forum. I hope I'm using this resource correctly.
#10  
You are using the resource pretty well.
We are all here to help each other. That is one of about 20 things I love about ez robot. The only advice that I can give you about using the resource is to keep to one topic per thread and give it a descriptive name. It makes it much easier to search for others who might have the same issue later. Also, be sure to give credit to the person who answers your question. You will get a lot of help fairly quickly if you do this.

What is the type and model of the computer you are using? It may help us to dig and find out more about the computer to answer the question.
#11  
@d.cochran thanks for the tips. I really appreciate all help you and others given me. I'm using a Dell inspiron 15 laptop computer.
#16  
Asking because this might be your problem


If you rebuilt your computer and you didn't install these drivers in the correct order, you might have an issue.

A good test would be for you to try to play 2 different streams of music outside of ARC. For example, play a youtube video and a mp3 or something else that uses the audio at the same time. See if this works or gives you an error. Your laptop should be able to do this, but if it isn't, we will know there is an issue with your computer build for sure, and it definitely isn't an ARC thing. I also assume that you have rebooted your computer because it is possible that something crashed and retained a lock on the device.
#17  
My computer is factory and it will play the audio of 2 You Tube videos at the same time with no errors.
#18  
try one youtube and one from something else like a mp3 or something else.
#19  
Better yet, Publish your project to the cloud in public mode and I will download it and see if I see the same issues. I will be away for a couple of hours but will check it when I get back.
#20  
I tried what you suggested and everything works OK. I'll read up on putting something on the Cloud and attempt to do that.

It's to bad discussions go off the front page so fast, my "Text to speech servo movement" didn't get a lot of response.
#21  
@d.cochran I uploaded my project "InMoov finger" to EZ-Cloud
#22  
I got the same errors when I loaded the project. I started poking around and noticed that a lot of the servos in the Auto Position tool were not mapped to any ports. On a hunch, I mapped all of these to different digital ports. I then added a variable watch control (because I like to see my variables) and added a Speech Recognition command called BOZO that runs SAY("BOZO THE CLOWN ROCKS THE CAZBAH!") because he does, ya know. I ran said BOZO and got no errors. I then added a soundboard (PC). I added one of my favorite Wall-E sounds and then made the Bozo script play this sound while he says BOZO THE CLOWN ROCKS THE CAZBAH!. I get no errors.

I have uploaded this to the cloud. Please download it and let me know if this fixes your problem. I dont know that it will. I just know that I was getting the errors and now I am not. If it does fix the issue, I would remove the servos that are not being used yet from the Auto Position tool until you need to add them and when you add them, assign them to specific digital ports.
#23  
Wow, was that ever a lot of work for you, Thank you very much.
I will try out what you've suggested and report back to you.I'll mark this as resolved for now.
Once again thanks!
#24  
Ok I'll try that again. Resolved